TTS on homepod mini

Is there a trick to use TTS or to make siri speack text on homepod mini?
I found nothing who work.
On an another box i see this post
https://forum.jeedom.com/viewtopic.php?t=47482

I have try too with shortcuts on iphone. But it works just sometime.

TY for answer

2 Likes

Maybe you can try “Logitech Media Server” with the 3rd-party plugin “airplay”

is it an integration ? I fount only Logitech Hub and Logitech Squizzy

Nope.

It’s an application, fyi:
Logitech Media Server (slimdevices.com)

it doesn’t work. I found [Plugin Tiers] HomepTalk - Multimédia - Communauté Jeedom On Jeedom an add on seems to work. I have try to install Jeedom on a vm just for that, but the add on is not free. And this solution tu run a Jeedom just for on service seem’s not the good way.

Is someone have find a solution ? It is principally to TTS text like “alarm activate …” …

A new & awesome components recommended, quite nice for homepods:

1 Like

TY for this repo.

I have crash, due to version of core HA. Where can I write the command line ?
I run HA in HASSIO on a VM in Proxomox, I have try un the proxmox shell, each command is reject, and I have try via ssh (connect a root), and pip3 (or pip) doesn’t work. It says “-bash command not found”

I’m having problems with this too… using Terminal add-on to try the suggested fix, get errors when attempting to install miniaudio

This looks very promissing … :slight_smile:

However about the bug mentioned in the readme: is this only for HA installations 2021.7.3 → 2021.8.2. I’m running the latest 2021.8.6. There are no issues with that version?

There is a bug in Home Assistant 2021.7.3 ~ 2021.8.2 and it will cause HA core crash. If you are using HA 2021.7.3 ~ 2021.8.2, you need to reinstall miniaudio. Enter the following commands

apk update
apk add build-base
pip3 uninstall --yes miniaudio
pip3 install miniaudio

Notice: If you upgrade HA core to new release, you need to re-install miniaudio.

with the last version it bug. I have write the line code to it works (reinstall mini audio).

yes, re-installing miniaudio is necessary for 2021.8.6 also.

Its works well with 2021.8.7.
Remember to restart the container after reinstall miniaudio.
The only bad thing is when you are playing music, trigger tts play in hass, the music is stopped. Not sure if this can be improved/

I am a total newbie but how do you do this? Do you SSH into HA?

@JDogg016 So you need to have the Terminal and SSH add-on installed - that will enable you to add SSH and configure it up if you really need SSH. I find the terminal in browser is good enough.

That said the default built in add-on terminal is fairly slim with what you can do. To access python/pip you need to access the home assistant container via docker. To do that it’s worth installing the community add-on SSH & Web Terminal. Add a secure password or SSH authorised key into config and turn off protection mode to get access into the containers

Hmm I can’t get this to quite work.

Apple AirPlayer picking up my Airplay speakers perfectly including my HomePod minis. I have gotten into the homeassistant docker container and performed the commands;

apk update
apk add build-base
pip3 uninstall --yes miniaudio
pip3 install miniaudio

And then restarted Home Assistant as a whole, but nope nada nothing. How are you guys testing this? Anything I may have missed?

I am running HA using a VM not docker.

Still applies. I’m running mine on a Pi using HAOS. Homeassistant embeds docker into the program as far as I can tell. May be different for a VM but worth having a look.

I think it is. When I run pip3 I receive the message ‘command not found’