Tuya Convert - NEO Smart Thermostat and Humidity Sensor

Tags: #<Tag:0x00007f739b7abd70> #<Tag:0x00007f739b7abc58>

Morning all,
This might help someone.
I recently bought a smartlife thermometer and humidity (and siren) 3 in 1 sensor. My initial plan was to utilitise smartlifes scenes to trigger things, but out of interest I tried flashing the device with tasmota.
It worked.
But unfortunately for me, there are no templates available for the unit.
However, using the tasmota interface, I set up a generic unit, enabled tuyaMCU, setup weblog 4 and found two Ids being transmitted - 105 and 106.
105, I believe after some testing is the temperature reading.
106, the humidity.
Not being completely savvy with tasmota (I asked for assistance on the tasmota forum just to have my question deleted…) I ended up mapping these values to tasmota 31 and 32 - which are watts and amps I believe. Temperature on 31, Humidity on 32.
A little bit of conversion in HA allows me to read these figures from the sensor.
Alas, the siren part of the setup is beyond my capabilities (and to be honest, I didnt need that functionality), but for those of you looking to find wifi, affordable, ways to monitor these values, this might be what you are looking for.

These devices range from about £16 from China, are all generic units with different branding. Just a caution, some are only advertised as sirens. Look for the 3 in 1.

Hope this helps someone.
Rob

and if anyone has any ideas on how to make tasmota indicate the values as temperature and humidity, please let me know!

PL16053-40

1 Like

Hi Rob - what about this? It looks like the same device…

Many thanks for that hmarcc. Looks the same - is the same!

Hi,

i managed to flash the sirene und to connect to home assistant. The connecntion through Mqtt is working.
What did you do to read the temperature und humudity values? What kind of conversion in HA?

Any tipp or help is appricate!

Greetings
Dodger

First make sure you have the 3 in 1 version that has Temperature and Humidity sensors (I received the version without :frowning: ).

With the proper hardware version enabling temperature reporting is likely TuyaSend4 105,1 and TuyaSend4 106,1 respectively for humidity (with 112 changing between C and F).

Then, in HA need to set up template sensors on the topic used by Tasmota (can use mosquitto_sub -d -t "#" to look at all the messages received by MQTT). Unless you changed the reporting period to anything else than 300 you will not receive any payload from the siren for at least 5 minutes (minimal value is 10 (seconds)).

I bought 3 of these sensors thinking I could get them working in home assistant.
https://www.amazon.com/gp/product/B088K9YPLW/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
They look like the same thing with the added 2.5mm jack for a binary sensor “leak detector” Also looking at the inside it looks like it has a neo type chip running 3 RGB leds. It would be awesome to have control over Humidity, Temp, Leak, Siren, and RGB leds for mqtt automations. I could really use this.
I flashed with tasmota before reading this and I didn’t disconnect any trace/resistor. I got tasmota on the device but, I have no clue how to configure it.
If someone is fairy certain they can get these implemented I’d be glad to donate one. With the added plug for an extra sensor and RGB leds I think this could be a very nice feature for Homeassistant.
Also the siren looks more like a speaker possible to get playback? I post a few pictures of the internals tomorrow when I have some time

You’ve probably completed the most difficult part by flashing Tasmota and now just need to find a proper template to match the actual wiring of the device by identifying the traces of the PCB to the NodeMCU pins with a multimeter (looking at the pins pictures helps but there might be traces that are not visible at a glance).

If your device isn’t already mapped, then worst case scenario is to look at similar sensors templates and find the right setup by trial and error. As you said, it looks like a 3-in-1 with hum&temp&siren (similar to the one referenced above and you can start from that) + binary for leakage + RGB.

I think that the leakage sensor template (https://templates.blakadder.com/W06.html) is different from yours as that is a battery only device (has a separate MCU that monitors the contacts of the probe and only wakes up the ESP chip to make the wifi connection).


The one I flashed with tasmota, I lost connection to when I changed to Tuya module. I then sent new generic config over serial and followed the setoption instructions for setting up tuya here. I lost connection again. After several attemps I got the generic config to flash again over serial and logged into the webui. Setup as Tuya and once again I loose connection. I’m not sure how I will ever figure this out.

Side note: It uses two AA batteries for a battery backup. It’s a very well built design. If I can get it working I’m definitely getting more

Hey Petrica,
thanks for all. It´s working quite well and i getting the MQTT Message:

10:54:31 MQT: sirene/tele/RESULT = {"TuyaReceived":{"Data":"55AA03070008690200040000001494","Cmnd":7,"CmndData":"6902000400000014","DpType2Id105":20,"105":{"DpId":105,"DpIdType":2,"DpIdData":"00000014"}}}
10:54:31 TYA: fnId=0 is set for dpId=105

This is what i try to get out the temperature:

  - platform: mqtt
    name: "Sirene Temperature"
    state_topic: "sirene/tele/RESULT"
    value_template: "{{value_json['DpType2Id105']}}"
    unit_of_measurement: '°C'

It is not working. Do you have tip for me what i´m doing wrong?

Thanks in advance

Hi,

Try this:

- platform: mqtt
  name: "Sirene Temperature"
  state_topic: "sirene/tele/RESULT"
  value_template: "{{value_json['TuyaReceived']['105'].DpIdData | int }}"
  unit_of_measurement: '°C'