Tuya devices disappeared

Hey guys!

I’m new to the community and couldn’t find a similar issue so I decided to post this topic.
I have home assistant up and running on a vm, everything has been fine for a while until I noticed yesterday that my automation to turn off my tuya lights were not working.
I then hopped to home assistant and noticed I couldn’t toggle my tuya lights anymore. When I went to check my tuya integration I noticed there were no devices from the integration(look at the image below)

I decided to check my tuya cloud app and even created a new app and re added the integration on home assistant. The devices are in the tuya cloud app, but not in home assistant.

Finally, I went to check the log viewer on home assistant and this is what I saw

2022-11-11 13:45:19.751 ERROR (Thread-5) [tuya_iot] error while get mqtt config
2022-11-11 13:45:19.754 ERROR (Thread-5) [root] Uncaught thread exception
Traceback (most recent call last):
File "/usr/local/lib/python3.10/threading.py", line 1016, in _bootstrap_inner
File "/usr/local/lib/python3.10/site-packages/tuya_iot/openmq.py", line 161, in run
time.sleep(self.mq_config.expire_time - 60)
AttributeError: 'NoneType' object has no attribute 'expire_time'

I’m not sure if that is related to my tuya issue, but I wonder if anyone has ever had that issue before or how can I even investigate what is going on?

Thanks a lot

1 Like

that make 4 of us so far

1 Like

I think I figured it out. It seems like the IoT Core 1-month trial period has expired. It seems you can extend your trial by 3 or 6 months. I have done that and now my “aplication is pending”. So I hope tomorrow I have a working homeassistant again.

Check your Tuya project, then the tab “Service API” and “view details” of IoT Core service. (Hope this makes sense). Here you will see the one month trial has expired and you can apply for an extension.

I have NEVER heard from this and read NOWHERE this was an issue. You can even pay for a yearly subscription of a rediculous 25000$???

Hope the application for an axtension works for you too.

Tomorrow I am trying to get the LocalTuya integration/addon in HACS working. Then I am no longer depending on the Tuya IoT online platform.

I’ll keep in touch!


That was it! I applied for a renewal of my trial period (extend 6 months) and everything works again. Only thing was, I had to change my entity names again, because Tuya integration did see them as new devices. I have 2, so not a problem what so ever.
Hope this will help you all!

Good luck!

Same happened for me, Tuya APP works, but Home assistant can’t see Tuya. Applied for developer trial extension and waiting confirmation… Do we have to renew API access every 6 month?

This is the second time this year it’s happened to me as the old system was a year. Last time it went very badly and I ended up making a whole new account/project and rebuilding all the automations.
I’m either going to look at paying for it to stop it breaking - or flashing all the Tuya out to tasmota or replacing with Shelly.

This just happened to me. I’m so glad I stumbled on to this thread or I never would have figured this out! I have applied for a 6 month extension. How is the LocalTuya HACS integration different? It still requires the same authorization info.

I have the exact same question… any info on this?

Hi there and welcome @ptv1p3r! Check out the post above by StefanBol. That’s what saved me! Hope it helps you too.

Thank you so much for this thread. I’ve been beating my head for the past month on this and this was the reason. Needed to go into the Service API and extend my trial period, but it only goes for a max of 6 months :frowning:

Hi guys,
This took me about an hour to figure out where to go. Hope this can help anyone find it quicker!

  1. IoT platform (orange button top right by your account)
  2. Cloud
  3. Cloud Services
  4. Find your iOt Service and on the right click view details.

Well… today I had the same issue. Yet at 7:00 at morning it was working but around 12:00 all devices were lost. Funny fact is that according to Tuya IoT page my subscription expired 1,5 year ago:

Keep in mind - today is 2024.02.02. So how did it worked last 1,5 year?

funny, I got same also today. maybe they are doing a “cleanup” every once in a while and not really by the dates. that’s odd.

Having same issue this morning, glad Im not only one. And my also expired in 2022… I opened a ticket with them. Lets see what happens, so many broken automations now, and me adding/removing tuya integration Im sure didnt help…

My date shows as 2022-06-12 14:08:40

Having the same issue. Iot service expired in 2022

Same thing has happened to me today too. Is there any easy fix without going though the whole process again?

This evening I added a third device to my HA, and suddenly i was kicked out of Tuya services. I tried what wrote above and now my application is pending.

I am worried about tuya pricing, I hope we all didn’t sign some contract with written very small sentences… :slight_smile:

Mine also stopped working some point today despite the expiration date being nearly 2 years ago

Hi, same here too, my expiry date was 2022-05-22 13:29:03 and today I can only control using the Tuya app - I have gone through the extension dialogue. This would be quite bad if on holiday, for example…

Another one with the same issue…