Tuya devices/entities gone missing

Hi all,
I had the new Tuya integration working perfectly after the 2021.10 release, but this morning after installing the 2021.10.5 release, it’s showing no devices or entities. I suspect the install is a coincidence as I tried going back to the previous release and I still have the issue. (Have since re-installed 2021.10.5)
I’ve checked that all of the devices are still showing in the Tuya IoT platform - they are, and turning a device on with the Tuya phone app, shows in the IoT platform logs for the device.
I’ve tried reinstalling the HA Tuya integration - installs fine, no errors, but still no devices showing. I’ve tried re-adding the IoT app account to the Tuya phone app, again, no errors, but still no devices/entitites showing in HA.
I’ve also checked HA’s logs and there are no errors to be found.

Any suggestions that I haven’t tried?

Thanks.

1 Like

Seeing the same issue since update to 2021.10.5. This new Tuya integration is truly a new low in reliability.

1 Like

I can confirm that reverting to previous version of HA (2021.10.4) does not resolve the problem. No devices are shown and I don’t see any obvious errors.

In my case I had to create a brand new project… unlink the phone app from the old project… relink with the new project so i could see all my devices then use the new login information for Tuya 2 and it worked. I tested this on core-2021.10.4 and the
Newest Version
core-2021.10.5

I’ve already gone through the process of configuring Tuya V2 when HA 2021.10 was released. It was working with 2021.10.4. I still see all of my devices online in the Tuya IoT platform.

Are you saying we now need to complete the Tuya IoT configuration process a second time with this update? Can someone explain what changed?

Thanks madpb, tried that but I’m still not seeing my devices under the Tuya integration.

Same issue here after updating to 2021.10.5 today. :frowning:

1 Like

Same problem for me too. Stopped working then i updated HA to latest to see if it would fix it but still not showing up. The smart things app works and the items all show up in my My Cloud Projects on the IoT platform so something integration wise has gone down. Not sure if i should leave it and see if it gets sorted or to remove the integration and then reload. Has anyone done this, so i don’t have to?

Sorry just read up and looks like a reload is required

I’ve deleted and reinstalled the integration, it didn’t fix it for me.
Interesting that you say you “…updated to see if it would fix it…”
Most of us are assuming that it’s the upgrade that’s caused the issue, but it doesn’t sound like it is if it failed for you while still on 2021.10.4.

I have also the same issue. I suspect there is no connection between ha and new tuya api

Yep have just re installed the integration, but no kit has been found with it!

Totally just luck that i hadn’t yet done the HA update

that timing looks about right for a change

Last Updated on : 2021-10-16 10:40:54download

The Cloud Development Platform provides a wealth of cloud services for you. You can subscribe to the pay-as-you-go cloud services as you want.

It is important to know that a basic resource pack is a mandatory prerequisite to use cloud services. The basic resource pack you have purchased provides the quota of API calls and message services, and also determines the service price if your monthly usage exceeds the quota.

Some cloud services might have additional charges based on separate billing rules. For more information, see the pricing rules of each service.

Has anyone been able to log in to the Tuya IoT Development Platform? I am unable to log in and if I try to reset my password, the verification code email never comes. I suspect there may be something going on with the IoT platform.

i am signed in now

I deleted and re-added the integration, it accepts the API values / credentials, but no devices are found. Was working fine yesterday. I wonder if this has something to do with Tuya’s new pricing model … maybe it’s not free anymore?

Screenshot_1

1 Like

You are on the same page as me on this.

1 Like

just went back to 2021.10.3 just to see and still nothing improves for me. Just as an experiment

I did a thorough search through the HA logs, no Tuya errors at all. HA is happily talking to the API, it’s just no devices are being presented. At least that’s what it looks like…

Same for me, all devices is gone today