Tuya integration Broken 02/2024?

All my entities became suddenly unavailable in homeassistant, even if I reload them… is it only me…?


Same problem here.

2024-02-02 12:46:31.430 ERROR (Thread-3) [tuya_iot] error while get mqtt config
2024-02-02 12:46:31.434 ERROR (Thread-3) [root] Uncaught thread exception
Traceback (most recent call last):
File "/usr/local/lib/python3.11/threading.py", line 1045, in _bootstrap_inner
File "/usr/local/lib/python3.11/site-packages/tuya_iot/openmq.py", line 161, in run
time.sleep(self.mq_config.expire_time - 60)
AttributeError: 'NoneType' object has no attribute 'expire_time'

Link to github issue

Thanks for sharing.
So I guess not on my side… let’s see how much time they take to fix it… I am assuming it’s a Tuya problem as I haven’t donde any ugprade nor change in my HAAS config. It just stopped.

Oh… I just had a look to this one in github: ℹ️ Tuya integration not working · Issue #80278 · home-assistant/core · GitHub

Looks like my Core IoT is expired. I just submitted a request for an extension.

I have an expiration date of 2023-07-26 and it worked well until yesterday.


I’m waiting patiently :wink:

Same here, my contract expired in september last year. It stopped working earlier today. Renewed for another 6mo, lets see what they say.

I do have local tuya integration, but im lazy to change all my automations :slight_smile:

I also have enough Zigbee devices to replace all the tuya ones. I just have to get my ass in gear.

My expiration date was on 2022 and as you, worked until today… I guess they enforced something today.
I am waiting for the approval.
How good is local Tuya? I never tested.

LocalTuya works fine, it is pain though to get the devices into the integration.
Bunch of stuff i did not understand that i just clicked myself through.

Same problem here. Everything worked fine until today. Although the Core IoT service had expired 2 years ago. Let’s see if extending it solves anything.

Where are you guys seeing your expiration date/time and renewing? I went into cloud - development, and I see my project code, and creation date: 2021-12-28 16:34:04, but I’m not seeing a way to renew the project. So I’m assuming the contract is something else, and located somewhere else. When I did get logged in just now, it asked me to accept an agreement…so is that all it is?

Ah, somehow I clicked into a section in Core IOT cloud that had my expiration as 2023-04-17 00:05:24, and said it was suspended and actively alerting or whatever.
So I did an extend trial. It seems like you can only request 6 months max for the extension.

Beyond that it looks like the trial edition actually costs ongoing fees for messages and API calls. Am I reading that correctly? $3.71/million API calls, and $1.46/million messages? If this trial account is going to start causing me to get billings, I’m just going to trash all my Tuya stuff. Or is there a Tuya direct integration option that will work?

Same problem here… all entries are gone… tried to reconnect… with the same result. No devices.

Guys this was my solution:

I think this Could be the cause.



Setting up their new custom integration worked.

thanks, worked

Thanks for the tip today on the new integration. I was able to add the smartlife integration via HACS. I had to set up smartlife on my phone first, since I had been using the Tuya app, and then have to remove my devices from Tuya and Add them to Smartlife, but once I did that the integration was straightforward and everything seems to work fine.

1 Like

Hi Tim where did you had to remove your devices from Tuya? in your phone app or homeassistant app or in Tuya website?

Idem here, I spent hours trying to fix it, finally uninstall it and reinstall, enter the cloud, nothing … I got bored and I switched to the app smartlife… much simpler, I do not have to have an account in tuya cloud. See How to Install Smart Life Integration (Beta)-Tuya IoT Development Platform-Tuya Developer


It is perfectly explained here: ℹ️ Tuya integration not working · Issue #80278 · home-assistant/core · GitHub

unlink and link.


You didn’t need to move them. It’s works with either app:

I set this up using the Tuya Smart app for Android.

Well, the man himself confirmed that this integration is not ready for prime time:

Hey guys, I did the integration as it’s explained here… I can control the devices, but the automations I have are not working because the devices are still missing in the automations…
Do I have to go through each automation to adjust it again?!
This would take forever…

Or should I do something with the old tuya integration?

How this thing is going with you guys?