Unable to load the panel source: /api/hassio/app/entrypoint.js

I had this problem yesterday. Iam using docker.

Docker image ls -a

  • look for the supervisor module, and copie the ID.
    Docker image rm ‘id’
  • this wil delete the supervisor.
    docker pull homeassistant/amd64-hassio-supervisor
  • this wil download a new supervisor image
    Docker container start ‘super visor name’


Restart server.


I just tried to update supervisor from 216 to 217 if I’m not mistaken and now I can no longer open the tab.
The error is the same “Unable to load the panel source: /api/hassio/app/entrypoint.js.”
Before I tried to restart the supervisor via cli with no success. Then unfortunately I decided to reboot the Pi and now I don’t have access in ssh.
So I’m stuck out of the Pi.
I have hassio installed on a Pi4 with HA .108.3

Last resort worked. I detached power cable from Pi and waited few minutes than I powered it on back and HA brought back to life.
Now I can normally ssh in.
I checked the supervisor versione via cli and il looks it is the 217.
Anyway when I update something in hassio I have to cross my fingers every time…

Restarting the host solved the issue for me.

A power cycle (not soft reset) fixed it for me.

I’m going to share my fix for “Unable to load the panel source: /api/hassio/app/entrypoint.js.” issue here in case it helps anyone. Just so you know the background, I was trying to move a previous instance of hass.io from an ubuntu 16.04 lxc container into an ubuntu 18.04 VM. Banged my head around for a few hours before figuring this out so here are my steps:

1 sudo -i
- Make sure you have network-manager installed or install with apt-get update && apt-get -y install network-manager
2. sudo systemctl stop hassio-supervisor.service
3. docker stop $(docker ps -a -q) && docker rm $(docker ps -a -q)
- You may also need to do docker rmi $(docker images -a -q) but I didn’t have to
4. Move your files over from previous installation if you need to
5. sudo systemctl start hassio-supervisor.service - at this point everything started except homeassistant docker container itself (which you can check by running docker ps) so my final step was…
6. reboot now

This seemed to do everything needed to restart the containers with proper networking.


Just follow this steps and now I no longer have the supervisor tab.
I have the same setup. Hassio on docker on ubuntu 18.04 VM.
Am I missing a step here. Should I update the supervisor container. (Currently its 214).

I posted this in another thread, but this is what solved my previously related issue.

1 Like

Unfortunatelly didn’t worked for me. so I just created a new VM and installed home assistant from scratch… Now I have a diferent issue :frowning:

I have portainer running, so I just clicked on the stopped container, hassio_supervisor, and then ‘Recreate’ and told it to pull from the latest image (219), so as not to use the one it was failing on (214). After a short while, everything was up and running again.

I just installed Home Assistant on a new Intel Nuc running Ubuntu. I got this error today. Doing a hard reboot (sudo shutdown now) fixed it.

I just experienced this fault. It started yesterday as we where going to bed, had done nothing to my system at that time so completely out of the blue.
This morning I started to search around for a fix.

My system:
Rp 3b
SD Card
HA 107.7 (had not updated at that time)
HACS installed

Since I couldn’t get in to the supervisor I was unable to reboot the system. I have SSH add-on (Terminal & SSH) installed, but the somehow the configuration of the port was set to “null”. So I could not get into the system to reboot. The only thing left was to pull the plug :pleading_face:
I was lucky and the system booted up fine.

As soon as the system was up I made a new full snapshot.
Then I looked into the ssh problem and found the issue with the port, I changed that to 22 and made sure ssh worked by using the terminal.

Then I updated the system completely to the latest HA and operating system.
So far the system is working fine, I only had one invalid config. That was an add-on from the HACS, spotcast. This add-on had recently stopped working because of Spotify changing some things. I don’t think that caused this fault on my system.

If my SSH would have been working I would have tried this before doing a hard reboot.

This really made me question having my system on an SD card for sure, I have had this install since late last year with no issues and a great setup I rely on. If I have the same fault again I will report back.

I had same issue this morning and fixed it. I’m running Home Assistant version 0.108.9 and Supervisor version: 220 on OMV Docker. From Portainer I restarted Supervisor and everything seems working now.

This issue appeared for me last night out of nowhere. No changes had been made prior. Could not access Supervisor, Configurator, Terminal. Restarted HA, and didn’t help, made matters worse as SSH no longer worked.

Phew! Power-cycled RasPi, and back to normal (for now).
On supervisor 202 220, HA 108.6.

I ran ha core rebuild on CLI and after it rebooted everything is working.


happened twice yesterday, on NUC and RPI and happened today upgrading to version 0.109.3 in my RPI.
REALLY annoying!
I can’t access the panel and have invalid access token log about every addon and supervisor panel.
I’m rebooting to see if can fix by itself, but this issue should be addressed, 220 version, with HA 0.109.X, is really a mess.
edit: ok reboot fixed nothing, still have tons of error log:

20-05-03 10:18:32 ERROR (MainThread) [supervisor.api.security] Invalid token for access /app/entrypoint.js,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/core_mariadb/info,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/a0d7b954_nodered/info,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/a0d7b954_nginxproxymanager/info,
20-05-03 10:18:55 ERROR (MainThread) [supervisor.api.security] Invalid token for access /addons/a0d7b954_pi-hole/info

I fixed this time doing ha core rebuild in hassio_cli.
Have to check if this will mess up again at every upgrade or not.

1 Like

The additional issue for me running Home Assistant (not Core) is the SSH & Web terminal Add-on failed to start so it was impossible for me to access the HA CLI. The only thing I could do was power-cycle.

Now, lesson learned here is that when this error first occurred, the SSH addon was still working, but I did an HA restart as a normal first resort but this prevented SSH from restarting.

What I really need for insurance is an SSH daemon that runs independently and not dependent upon the Addons not starting due to other HA issues. So I would have to abandon Home Assistant and go the Core route to achieve that?

i don’t know about that addon but i have ssh running as OS service, and so i do for portainer: i have both addon and “native” version installed: if something get screwed HA side, like happened, i’m still be able to access services and do things…if everything goes well i access it from HA, just more easily.
hassio_supervisor is like an orchestrator for all addons, if it get screwed, it could block everything, and some addons doesn’t start by just starting from docker, this is a BIG issue.

Thanks for the advice, but again, I’m not running Core, so I’m not sure what options I have for installing SSH as a dedicated service on HassOS.

Thanx! I had 219 installed and running and all of a sudden it stopped working. Followed your steps and everything works again, installing 220.