Unable to setup HomeKit bridge

Tags: #<Tag:0x00007f739858ea40>

Been a user of HA for many years, used Alexa integration with Emulated hue in past, after I got HomePod I am trying to setup HomeKit bridge and it never worked for me. Recently my Ubuntu box got busted and had to change the SSD and rebuild everything starting from new OS Ubuntu 20. After many days of setup I am back to the way it was and tried whatever I can to setup HomeKit bridge and it does not work.

Here is what I have:

  • installed hass.io supervisor enabled on docker on Ubuntu 20
  • setup emulated hue and was trying to pair using Alexa app and it never worked and stumbled upon a thread where they mention to speak “Alexa, discover devices” directly and it did find all my devices and works fine even it still does not show under my Alexa app anyway.
  • my ultimate goal is to setup Siri integration and get rid of Alexa in my home.
  • I also use traefik 2 setup with HA on ssl with my own domain name (using middleware router), I could access HA by directly the IP of the machine or by my domain name, it all works fine as expected.

Here is what I tried:

  • setup “HomeKit bridge” from UI using the integration option, no errors, got the pin/QR in notification panel, scanned the QR from my iPhone XR home app, and click connect, it spins for a min and says ‘Accessory Not found’
  • removed the homekit bridge from integration, restarted HA, then went directly to the config.yaml and added lines: homekit, advertise_ip, (also port:) , after restart got the QR, but same result, “Accessory Not found”
  • tried to see if there are any errors with logger: debug, no errors and no lines for homekit loading or something similar. when I do ‘Restart HomeKit’ from UI option, I get a log saying ‘sevice.reload’ and that’s about it.
  • I use Unfi controller and I made sure mDNS is not blocked and port forwarding for 5353,51827,51828 just in case

I checked my docker install of hass.io is in network mode:host
on advertise_ip I provided my Ubuntu machine IP

I almost give up in attempt to setup Siri, any help would be appreciated.
how can I trace who’s fault it is, is it my Siri Home App can’t find it, or something in the network not right, or HA homekit bridge not setup correctly (for the fact that I don’t see any log entries for homekit)

thanks in advance for any help.

When you setup the HomeKit Bridge, did you assign any domains to it?

if you mean the entities, yes I did Climate which is just only one, I don’t want to include all my devices into Siri, if the climate works then I will put a list of devices, that’s my idea. Also tried couple of lights instead climate just to make sure that’s the case.

anyone can help?

Well, I can only help by saying that you are not alone.
I too experiency exactly the same, also with a Unifi router.

I tried using Wireshark to analyse if mDNS is blocked (like in this post), but that’s too high tech for me to understand. So I used other logic: I added a Hue Bridge v2 to my Homekit on my iphone. That worked as expected. So mDNS isnt blocked in my network.
Having that ruled out, I still have no clue why the homekit accessory isnt found :’-(

Well, I think I have a pointer in the direction.
I run HA from docker on my synology. I run it in bridge mode.

This is what I found:

Note that Docker command line option –net=host or the compose file equivalent network_mode: host must be used to put Home Assistant on the host’s network, **otherwise certain functionality - including mDNS and UPnP - will break**. The -p command line option or the compose file equivalent ports: is not compatible with host networking mode and must not be used.

Using the docker container in host-mode doesn’t make a difference in my case

my docker based hass.io supervised in my case is running in the host network mode according to the details I found form portainer. I still would like to fix this issue so I could use Siri (am planning to get two more HomePod mini when it releases soon) and get rid of amazon echo.

hoping someone in similar situation chip in for their feedbacks. thanks.

I am having the same issue. I have a Dream Machine. I attempted to configure the mDNS settings as in the following link which did not work. I also attempted to turn mDNS off completely and had the same issue. My homebridge setup is a bit different, I have my home assistant loaded in TrueNas XL. This seems to be an issue with ubiquitin in particular.

I had Qnap NAS, so installed latest HASS 117.6 on container, after its created I setup homekit and from iPhone Home app it was able to find 25 new devices and seem work.

For now I will leave the secondary HASS install from Qnap just to use from Siri.

One reason I didn’t want to setup on QNAP container is I couldn’t find a way to update images when has releases new version.

Okay I got this working on my setup. It was an issue with multi-cast not being allowed on the wireless network as is posted here in the ha forum.

I ended doing the following:

I enabled the mdns on the UDM.

Next I enabled Multicast enhancement on the WIFI network Misc settings.

Next I disabled Multicast Filtering on the WIFI network.

I also turned on IGPM snooping to limit multicast to devices that accept it and protect from DoS attacks.