Update to 2022.11.2 Fails

Trying to update HA Core from 2022.10.5 to 2022.11.2 on a RPi3. I’ve tried multiple times and continue to get the same error from the Supervisor:

22-11-11 11:33:13 INFO (SyncWorker_6) [supervisor.docker.interface] Downloading docker image ghcr.io/home-assistant/raspberrypi3-homeassistant with tag 2022.11.2.
22-11-11 11:38:31 ERROR (SyncWorker_6) [supervisor.docker.interface] Can't install ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.11.2: 404 Client Error for http+docker://localhost/v1.41/images/ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.11.2/json: Not Found ("no such image: ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.11.2: No such image: ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.11.2")
22-11-11 11:38:31 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

It then restarts back into 2022.10.5. I haven’t lost anything but I’d really like this update as some of the new features look helpful. Any ideas what else I can do or other logs/resources check to figure out how to proceed? I’ve ensured there’s nothing to repair in the “repairs” section and I’m able to connect to/work with my HA instance otherwise. Just can’t update the core!


Don’t update if you have a unifi network. Lost connection and impossible to repair on unifi network. Had to add in diffrent network and downgrade before moving back to unifi network. Now it works fine with 2022.11.1

1 Like

Same here. My update just seems to hang. Keeps going and going


Here too, both Supervisor and Core won’t install. Tried Supervisor for 24 hours but just doesn’t seem to update.

here, it also fails. Neither Home Assistant Core nor Supervisor Update correctly!


Thnx for the link, hadn’t found that one yet. Pretty extensive to get it solved it seems, guess I’ll stop being a beta user after this :rofl:

I found leaving the beta channel stopped the unending update. Then restarted and re-joined the beta channel

lol thats so much easier thanks for letting me know I have 2 stuck now and can’t soft reboot because core update is blocking it :rofl: just left beta channel see what happens

Update: still stuck on installing, will pull the plug when I get home from work

My NUC running Home Assistant Supervised is also stuck at 2022.10.5 and is not able to update to 2022.11.3 at this time. I seem to get the same error as @travis.r.valdez and am not on the beta channel (I don’t think I’ve ever been).

The link above indicates no issues with Home Assistant Supervised, so I’m not sure how to proceed. Any help wuld be greatly appreciated.

22-11-17 14:24:49 INFO (MainThread) [supervisor.homeassistant.core] Updating Home Assistant to version 2022.11.3
22-11-17 14:24:49 INFO (SyncWorker_0) [supervisor.docker.interface] Updating image ghcr.io/home-assistant/qemux86-64-homeassistant:2022.10.5 to ghcr.io/home-assistant/qemux86-64-homeassistant:2022.11.3
22-11-17 14:24:49 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image ghcr.io/home-assistant/qemux86-64-homeassistant with tag 2022.11.3.
22-11-17 14:26:34 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install ghcr.io/home-assistant/qemux86-64-homeassistant:2022.11.3: 404 Client Error for http+docker://localhost/v1.41/images/ghcr.io/home-assistant/qemux86-64-homeassistant:2022.11.3/json: Not Found ("no such image: ghcr.io/home-assistant/qemux86-64-homeassistant:2022.11.3: No such image: ghcr.io/home-assistant/qemux86-64-homeassistant:2022.11.3")
22-11-17 14:26:34 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

No beta here, but problem.
Any fix in 2022.11.3 ?

I was just wondering… could this be a good case for push notifications to our HA istances?
I guess thousands of users do not come to the forums every day and getting a message directly in our HA informing us about such proiblems might be a good thing (allowing users to select if they wand or do not want to receive those(.

1 Like

This already exists. Everything added to https://alerts.home-assistant.io/ becomes a repair on every HA system that uses the integration in the alert.

The reason it wasn’t used here is there’s currently no way to target a specific version of supervisor or users on a particular channel (beta or dev) and installation type (supervised or os) with an alert. It’ll probably be updated at some point now that this issue made everyone aware of that need.

EDIT: Also it was announced in the forum as well as in the beta channel of the HA discord, the two main ways beta users provide feedback. Since the main reason for the beta channel is that beta users can provide early feedback and issue reports it was assumed that would reach a large percentage of them. Kind of the best that could be done without alerts support.

SAme here. Cant update from 2022.11.0b4 to 2022.11.4 and supervisor from 2022.11.0 to 2022.11.2.

Supervisor shows:

22-11-21 20:28:28 INFO (MainThread) [supervisor.homeassistant.core] Detect a running Home Assistant instance
22-11-21 20:31:22 INFO (SyncWorker_5) [supervisor.docker.interface] Restarting ghcr.io/home-assistant/odroid-n2-homeassistant
22-11-21 20:31:30 INFO (MainThread) [supervisor.homeassistant.core] Wait until Home Assistant is ready
22-11-21 20:31:34 INFO (MainThread) [supervisor.resolution.evaluate] Starting system evaluation with state CoreState.STARTUP
22-11-21 20:31:34 INFO (MainThread) [supervisor.resolution.evaluate] System evaluation complete
22-11-21 20:31:35 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/beta.json
22-11-21 20:31:35 WARNING (MainThread) [supervisor.jobs] 'StoreManager.reload' blocked from execution, supervisor needs to be updated first

Solution is already provided above, you need to update Supervisor first using the instructions in the forum post linked above. After that, you can update core

Thank you. What aproblem for me. SSH was not installed before - now I can´t install it. I also can´t SSH because I´m not in the building whwre HASS is installed. I even can´t restart.
There is also reset solution - but how to do it from remote access?

1 Like

Do you run HA OS directly on the system, or in a virtual machine?
Easiest solution might be to connect a keyboard and monitor to the system, but that requires physical access to the HA system.

ANy way of fixing it on rpi4 setup? I don t have a backup done and I don’t have ssh terminal installed in HA. I don’t want to rebuild the pi and lose my home setup that I have perfected for last 2years :<

1 Like

:thinking: Maybe you can try plugging a screen+keyboard on your Pi and run the Manual update from CLI.

Once it’s fixed, I’d advise you to follow this guide to setup SSH access to your HassOS

I do not get it…
“update” should be for “improvement”, but instead of “improvement” there are only problems this year… Started with “MQTT conversion”, then “Tasmota integration” and finally nothing works anymore… (no “restart” , just pull the plug)

Why “update” something that works for years? I’m tired of constantly reprogramming.

I no longer want to pay the Nabu Casa contribution and have started to reprogram all sensors with the Arduino IDE for Alexa. My Tasmota relays work with Alexa/Google anyway…

bye home assistant…