Upgrade from 0.83 to 0.83.1 Problem - Can´t access anything

I upgraded to 0.83.2 and this killed the NodeRed, it would not start. I had to un-install and re-install it. the credentials seemed to have been removed during the upgrade.

Which version did you upgrade from? There have been changes in the NR addon recentlt I think - I don’t use it myself.

Back up and working at 83.2.! I don’t use owntracks, but something was preventing the UI from loading. I’ve got a lot going on, Wink, Hue, Lutron, Nest, Node-Red, Z-Wave, MQTT, Lets Encrypt/DuckDNSios, google, asuswrt, tasmoadmin, configurator… Don’t really know what the problem was, but hopefully it is behind me. No updates until I know I have the weekend free, parts of my house heating relies on this.

I suggest having two separate environments: production and test. Mine are simply two old netbooks. No new release gets loaded into the production system until I’ve had time to experiment with it on the test system. FWIW, my production system is currently two releases older than my test system.

or roll two SD cards (if using a RPi) and test the update on one card, leaving the other as per the previous version.

Or break it, then fix it! thats more my style :slight_smile:
and learn in the process :blush:

1 Like

Pretty much. My process is:-
Read the release notes (duh)
work out what if any changes I need to config.
Make changes.
Trigger the upgrade and wait for it to restart.

If all went well it comes up.

Mind you I also use the beta versions but the process is the same - READ the release notes or sometimes even the PR’s if they have changed something I might want to try and it’s not been updated in the docs.

1 Like

I hear you but that doesn’t fly in households where downtime isn’t appreciated by other family members.

I’ve had Home Automation as a hobby since 2006 and the first thing I learned was not introducing services to others that are unreliable or subject to indeterminable periods of downtime (scheduled or not). Otherwise the l’il hobby develops a stinker of a reputation.

1 Like

I agree. I copped A LOT of abuse back when I was using Vera as it had a habit of randomly turning bedroom lights on in the middle of the night! At least when HA doesn’t work for some reason the house simply loses its smart features…

Oh yeah… I only had a sonoff switch randomly coming on during the night in the bedroom and my wife was ready to kill me when the leds on the switch came on… lit the room up like a christmas tree… Glad I fixed THAT!

With all the above being said… Maybe the “JOIN BETA CHANNEL” option on the System page should just be eliminated due to redundancy.

If you’re complaining now, you should have seen what it was like before the beta channel. It’s much better now.

i went from 0.82.1 to 0.83.1 and now on 0.83.2

Yes, never read them.

Same problem here. HA no longer boots up… Tried to downgrade, but only getting an OK and the info is telling me that I am still on version: 0.83.3.

core-ssh:/config# hassio ha update -o version=0.82

core-ssh:/# hassio ha info
    "result": "ok",
    "data": {
        "version": "landingpage",
        "last_version": "0.83.3",
        "machine": "raspberrypi3-64",
        "image": "homeassistant/raspberrypi3-64-homeassistant",
        "custom": false,
        "boot": true,
        "port": 8123,
        "ssl": false,
        "watchdog": true,
        "wait_boot": 600

any help very much appreciated!

I see you are running 64 bit hassio. I have found issues with that, hence I keep my system running on the 32 bit version.

if I have to start over i’ll use the 32bit… but hard to believe that after quiet a few upgrades that my upgrade issues are caused by a 64bit version

Don’t want to be the bearer of bad news but I had the same experience lately where I couldn’t upgrade, downgrade or even grade (run). I threw in the towel, praised samba while I copied my config directory over to my laptop. Scratched the SD, started over and rebuilt.

1 Like

I am heading that way as well… thank goodness have a copy of all my files as well and therefore not ready jump off a 8 story building yet :slight_smile:

In the same boat here. Removed owntracks but even with a downgrade to 82 it’s still not giving me anything. The logs commands all come back with an error and that start command just says “error” which is less than useful.
I’m going to rebuild the SD again( have already tried that once) and stick with 82 till I see a feature I really need and start again with a fresh install.

Is there any appitite for a 1.0 release?