USB Boot on Raspberry Pi 3

Can anybody tell me how setup latest image HASSIO to boot from SSD USB on RPI3 ? Raspbian boot ok from USB but HASSIO image installed by etcher no boot.

There is no way to get HassOS to boot from USB.

But some people write that he can…

Pretty sure it was only possible when using the older Resin OS

That is no good now when we use very often on RPi3 ssd memory on USB. Other system can boot but I don’t know why HassOS can not. No good.

There is an open feature request here : ===> Possibility to install on and boot from external USB media on Raspberry Pi 3

Yes and it is from December 2017and nothing.

See here:

1 Like

Looks like it is merged into dev for hassos.
Will be interesting to see if it makes the next version of HassOS

Looks great! already tried some testing with rel2 of hassos (trial and error), but no succes yet. Hope someone can figure it out to work

It might be worth opening an issue if it is not working so it can be discussed. @berg seems quite keen on getting this working reliably :slight_smile:

Edit: Looks like there is an issue open for this
I am going to follow this also as I want to move HA to a SSD on a Raspberry Pi.

Good point & I agree with you, but I’m a totally newbie on this matter. Trying to educate myself first so I can be of better help.

Have you tried it already? Did you get it to work?

I haven’t tried it myself yet. There is actually an open issue for the patch not working correctly, but not resolved yet.

You’re not right, HassOS can normally be installed on the SSD and booted directly from it, but only on RPi 3b +.

I was right a year ago when I wrote it!

I am sorry date 19.2.2019 :slight_smile:

HI Just tested it last monday

Used Hardware+ Software
raspberry Pi 3b
usb to M.2 adapter for the pi LINK
Kinkston 12GB m.2 2280
HASSOS 4.11 official release

I just followed the steps as followed

  • make a clean install with Raspberry Pi OS (32-bit) Lite LINK
  • Add SSH file to the root directory
  • boot up and ssh into the pi
    Username: pi
    Password: raspberry
  • i did a complete update (but for the boot option its not needed i think )

sudo apt update && sudo apt upgrade && sudo reboot

  • Then enable USB boot mode with this code:-

echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt

This adds program_usb_boot_mode=1 to the end of /boot/config.txt.

  • Reboot the Raspberry Pi with:-

sudo reboot

Then check that the OTP has been programmed with:-

vcgencmd otp_dump | grep 17:

Check that the output 17: 3020000a is shown
Now the USB boot in enabled.

  • install hassos on the SSD/ USB using balena etcher
  • remove the SD card from the PI
  • plug in the SSD in the PI
  • power it up and just wait until installation is finished is finished


For the ones that need to put the old backup back

  • make sure the backup file .tar is stored on your PC
  • from the fresh hassos installation install samba share and enable it.
  • Browse with windows explorer directly to the PI’s ip \192.168.0.XX where the last windows 10 update has issues recognizing the pi.
  • place the backup file in the backup folder
  • in hassos refresh the snapshot page in the richt upper corner.
  • now you will see the snapshot and you will be able to apply it

I needed to delete the database file because my sensors flat-lined

Enjoy IT

For the Raspbee users don’t forget to add in the config on your SD/SSD/USB root :wink:



Hope this helps some of you

1 Like

Just tried it - it does NOT work with an external SSD (Kingston KC300 inside a Chili Green EF253.H813 case, but connected via a USB 2.0 Cable instead of 3.0 - which shouldn’t matter, since the Pi3 B+ only has USB 2.0 anyway), but it does work with an USB thumb drive.

I’m on a RPi3 B+ and use HassOS 4.13 64bit

Not sure if a thumb drive is a great improvement over a SDXC A2 card though…

Online you can find some documentation about the usb boot mode.
the USB port has an limited power supply.
and boot time for ssd is important, if the Rpi is past the usb boot and SSD isn’t recognized on time it won’t work.

best option is to use hardware which is known to be working.
today i prepared a rpi3B for a friend with the same hardware and it’s also working fine.

hope this will put you in the correct direction.

i also got a strange problem with starting HA from USB (SSD).

I tried several things, older HA version, newest HA version.
But its not booting.

If i install raspbian on the SSD it boot directly from USB.
Does somebody have a idea?