Use the switch input for a Z-wave switch (Aeotec Dual Nano switch) to control another non Z-wave device

I have a number of Aeotec Dual Nano switches successfully controlling some of my lights.
A couple of these lights are actually WiFi LED bulbs (of various types) which are also connected to HA.
I would like to make it so that the switch input (toggle switch) which is wired into the Z-wave nano switch doesn’t control the power to the WiFi LED bulb - but instead have HA detect the state of the toggle switch input and then switch the bulb on or off. I can successfully make it so that the switch does not control power to the bulb by changing Parameter 122 from “Control the output load itself” to “control other nodes”. This then allows me to switch the power to the bulb from HA - thus keeping the WiFi bulb always powered and available on WiFi. The part I have not been able to do is to get the status of the toggle switch input in HA. If I can get this status I can use an automation to switch the WiFi bulb. From the various reading I have done - it seems that I can get a Z-wave device to switch another Z-wave device via group association - however I have been unable to find any way to get the toggle switch input status.

Is anybody able to please assist with this configuration?

I have managed to partially achieve what I want with the following settings:
Under Z-wave settings for the node I set the following:

Node Config Options:
Parameter 123: Control destination for S2 = Control other nodes
Node group associations:
Group 4: Control Key2 = Node to Control - (controller Node1)

This successfully sends an event to the controller when the switch is toggled. I can then use this in an automation as follows:

- id: '1581203423803'
  alias: Dining Table LED Light on from Zwave switch
  description: ''
  - event_data:
      basic_level: 255
      entity:id: zwave.zwave_dual_switch_patio_dining_2
    event_type: zwave.node_event
    platform: event
  condition: []
  - entity_id: light.yeelight_color2_7c49eb157036
    service: light.turn_on

and an equivalent automation to switch the light off when basic_level = 0.

When I do this with one light - it works correctly, however when I add the same configuration for a second light (with the automation using the appropriate entity_id) - toggling either switch switches both lights together.
I’m guessing this has something to do with the fact that both switches are set to control Node 1 (the controller), even though the automations are set to trigger off the unique entity_id.

Is there another or better way to achieve this with multiple lights?

1 Like

Unless you had a mistake in copy/pasting, this part of your automation is incorrect:

      entity:id: zwave.zwave_dual_switch_patio_dining_2

Notice the entity:id. It should be:

      entity_id: zwave.zwave_dual_switch_patio_dining_2

This probably results in the trigger having no entity id, which I assume will match any (node) entity.

Thank you very much @freshcoast - that seems to have been the problem. Dumb mistake.

i do have a similar problem, is parameter 123 even working for dual switch? I scratched my head for hours as in the manual only 122 parameter exists and after some digging i see only the in single switch the parameter 123. Is this a problem in aeotec documentation?
Basically i want my s2 from dual switch to control another switch ,i did this succesfully but the s2 switch still turns on. I set parameter 123 to 2 but still both s2 and its linked device turns on/off, why isnt the s2 state remain unchanghed? what i am doing wrong?

I’ve done exactly this. However, I’ve had issues with this implementation. I’ve been getting all sorts of strange affects such as bulbs taking 20 seconds to turn on or even turning on then off then on. Is anybody able to advise on a more robust solution with these nano switches?