Using a broadlink rm4 mini

A lot of discussion on this last year, but not finding much recently.

I’m new to HA and have an RM4 mini with the temp sensor attachment. The Broadlink integration found it and set up the sensor, and it works. The IR remote was identified as such but is just a ‘switch’.

I don’t know yet how to learn and send IR codes through HA. Was I supposed to get more support from the integration, or must I do everything through YAML, scripts and code? I’m just looking around for the bottom rung of the ladder here.

Update - just found this recenlty posted video which very possibly answered most of my questions:


No. Go to Developer Tools | Services and enter the service name remote.learn_command (you’ll get a drop-down as soon as you start typing “remote”).

Select the entity id of your remote, make up a name for the device you’re controlling and the command you want to send, then click Call Service, point your remote at the RM4 and press the appropriate button. The docs are a bit confusing with all the “# Example configuration.yaml entry” bits.

When you want to send a command in an automation or script, use remote.send_command not remote.turn_on (that turns the Broadlink on…) and use the device ID and command that you created.

Your video will probably help, but be aware that the RM4 Pro is not the same as the RM4 Mini (it does RF commands as well).


I needed this video for ages, finally I do understand this a bit… :slight_smile:

The RM4 Mini works the same. All the steps in the video apply.


If you use docker, this is super easy

Just got an RM4 Mini and it says Device not supported. any idea why?

I have made sure to unlock the device in the Mobile app and rebooted it (unplugged, wait 5 seconds, replug). I have also restarted the HA a few times, yet I’m still getting a Device not supported after putting the (fixed) IP address for the device.

Yes, it seems a new version of the RM4 Mini came out and has a different ID. It was fixed but not released yet as a general update. In the forums there is a guy that release steps needed to get it working.

got some strange problem. Worked all the steps above. Seems all to be ok just that it does not learn anything. I startet the learning process as described. LED on RM4 mini turns on. I send the command from original remote and LED on RM4 mini goes off and the button turns green with a check. Seems that everything worked fine. But I cant send the command with “Remote: send command”. I select the device created and the command but the “call service” button is greyed out. Any Ideas?

Open .storage/broadlink_remote_{BroadlinkMAC}_codes in a text editor.

It will look like this:

Using fios_stb as an example this is how I learn the code for the “play” button for my fios_stb device:

To test the code, you only need to change the “Service”:

If it doesn’t work, then learn the code again. I just yesterday learned about 30 buttons on one of my remotes, and one of them didn’t work.

Note, the Device and Command are case sensitive. They must be identical.

I don’t know if it makes any difference, but I selected my Target from “Device” and not from "Entity.


I managed to get it running. Removed the whole broadlink integretion several times and suddenly in worked. Thx

Has anyone had any experience with their RM4 Mini or Pro’s sensor cable disconnecting? I’ve only had my RM4 Mini, newer version, for a couple of days but it’s been running great, controlling a mini split unit using SmartIR and Simple-Thermostat for the frontend card.


Twice now in the past 12 hours, my temperature reading from the unit in HA has suddenly dropped to 32F (I noticed the first time because it triggered an emergency heating automation I had set up and I woke up this morning sweating like crazy) and the humidity will drop to 0%. I don’t think this is a problem in HA itself because when I open the Broadlink app, the two sensors that normally show up on the Broadlink RM4 Mini’s page are gone; combine that with the fact that 32F = 0C, and I infer that both sensor values are zeroing out.

The IR functions continue to work while the sensors are in this state. Reloading the Broadlink integration while in this state will cause both sensors to properly become unavailable, which I would kind of prefer to the zeroing. The RM4 Mini remains connected to the network via static IP as well. It is just the sensors that are affected.


A hard power reset seems to fix this, and while I’ve set up smart plugs to auto-reboot old devices with similar quirks, this is a brand new device that I expect to work well. So, I’m just trying to see if this is known problem with any remedies before I request a replacement from Amazon, as I really love the function and now just want to ensure reliability.

I did some general googling and didn’t find anything. I thought perhaps that not enough power was reaching the unit for both the IR and the sensor, but I looked up the input requirement as 5V/1A and I have it plugged into a 5V/2.4A outlet, so it shouldn’t be short on energy.

The only other thing I could think of is that I do have the length of the cable, lower than the sensor portion, running in a bundle with some ethernet cables on its way to the wall outlet, but even with shielding at its worst, interference would cause a temporary disconnect at best, not a permanent one, right?

Thanks to anyone that may have some ideas or insight. I’ve put a simple condition in my emergency heating/cooling automation not to fire if humidity is reading a solid 0, which should never happen naturally, as a temporary measure.

Those temperature/humidity sensors are integrated into the USB power cable, the Broadlink HTS2 cable you are using?

I have five RM4 minis (Firmware: 52078) with those Broadlink HTS2 cables connected to them for power and temperature/humidity readings using them like you for controlling split ACs with Simple-Thermostat for the frontend cards. The PSs I am using are 5V 2.4A units, branded and quality devices (not no-name cheap china crapware). All that gear is stuffed behind the covers of the indoor units.

All is working nonstop for more than 2 years now on all 5 ACs without any hiccups whatsoever.

Be aware that those Broadlink HTS2 cables are not for RM4C mini but they are specific for the RM4 PRO and RM4 mini.

If you have connected the HTS2-cable to a RM4 mini (notice, not the C-model) with Firmware 5278 and have tested it with different PSs but the described disconnections are still happening than I can only think of a defective sensor (hardware) as the culprit.

PS. Obviously you are using an USB extension cable. If so make sure that the HTS2-cable is on the RM4 mini side. I have noticed that those Broadlink IR (and also RF) Remotes are quite picky when it comes to the Micro USB connector attached to them. You can not just use any Micro-USB ↔ USB-A cable.

1 Like

Yes, they are the sensors from the included HTS2 cable.

Be aware that those Broadlink HTS2 cables are not for RM4C mini but they are specific for the RM4 PRO and RM4 mini.

Yes, I made sure that I purchased the RM4 Mini shown here and not the RM4C.

PS. Obviously you are using an USB extension cable.

No extensions here, just the stock cable. I’m also using good quality power adapters, but I suppose I might try another type if I run into the same problem. If it persists another week after that, eh, that’s what exchanges are for.

Unfortunately though they are difficult to get nowadays. Seems to be a EOL product :dizzy_face:

@ShooterQ Did you ever get this resolved?
I have two RM4 minis bought with the sensor cable included. One is working fine, the other has stopped sending temperature/humidity information twice now. Temperature display in HA goes to 0°C (32F).
I can still send IR commands out through HA, but it isn’t reporting temperature/humidity, not even through the BroadLink app. It’s as though the device doesn’t recognise that a sensor cable is connected.
Each time I disconnected both cable and device from power for 30+ seconds and they started working again, but I wouldn’t consider that a solution. It’s a pity BroadLink doesn’t have a support forum because I don’t think this is a HA problem if it also isn’t working in the BroadLink app.

Device details in case it’s important:
BroadLink RM4 mini
Firmware: v62092 (current 2023-02-16)

Sorry for the late reply, been busy. I also just checked out back then because of some of the assumptive and non-sensical replies I was getting.

In any case, since this post, I haven’t changed my power supplies as they were already of good spec. I purchased a second RM4 Mini sometime in OCT 2022 I think. Both of my units have gone out only once since then, the older one sometime a few weeks ago and the newer one sometime around the holidays.

I didn’t think I had updated my firmware since then, but I’m sitting on 62092 for both devices so I guess it happened automatically. I can’t really tell what the origin of the problem is, as neither of my two outages since then coincided with temporary brownouts nor momentary Wi-Fi outages.

Perhaps you and I just got product from the same bad lot, but with the problem now being infrequent on my end, I haven’t gone back to address it. My current way of dealing with it is to notify me whenever the humidity zeroes out for a period of time so that I can reset the offending device by hand.

In the future, I plan to get more of some reliable Temp & Humidity sensors I already have and keep using the Broadlinks just for the IR/RF, allowing me to position IR modules and temp sensors where it’s better for them individually and to do away with this minor annoyance.

the same happens to me; I’ve three rm4 mini with HTS2 cable and from time to time, I found that no data is reported from temperature and humidity sensors (both 0). Did anyone find any solution?

I was trying for like 45 minutes before I saw this. It seems as if selecting the remote from Device instead of Entity did the trick - thanks!

Not sure if it’s of any help but I had issues getting temp & humidity data from the HTS2 cable as well. It would always show unavailable.

I decided to use a different power supply and found one lying around that was rated for 5v 2.1A. 5 minutes after switching to this power supply, I was getting temp & humidity data again. So the takeaway is, check the power supply to make sure it matches the recommended spec for the unit.