Using CATT

I think we need to use a command line switch to start the cast. We can easily integrate the switch in our automations. That is my theory, maybe it can be done way more simple?

I seem to have gotten it to work using a spare raspberry pi running noobz. Since there’s nodered on there I just use the Exec node to run the Catt commands. Configuring the Home Assistant palette allows me to create a input Boolean that triggers my node-red automation for displaying my camera feed on individual chromecast devices.

How could it be simpler?

no clue?

Must say that i’m unable to get my home assistant to cast to my Nest Hub.
Mine is also stuck with the HA logo at the top of the Hub screen, then goes back to the clock.
Casting a website like google works. I already had the trusted networks added.
Pretty strange…

I was using catt with google nest hub 8’, the moment I enabled duckdns exposing HA to internet catt stopped working, I get for 2 seconds the little HA logo floating on the screen and then it goes back to casting my google pictures.

I have a split DNS on my router so any LAN request going to gets risolved with the internal IP on my LAN.

I call the catt command from node red using the “bigssh” node, once again all was working fine before I enabled duckdns, also the auth_providers was working, it prompted me once to select the user on the google nest hub and then it would simply cast.

Anyone having the same issue and got it to work?

I can confirm if I turn off my duckdns and just use my local IP address to access HA, I can get at least get a partial success in casting my instance.
However, I get stuck at the login page as I understand that the browser on Nest Home doesnt allow the use of a keyboard.
Ive tried using trusted networks to bypass the login, but couldnt seem to get this to work either.

Only for your information: if you have
Failed to connect, retrying in 5.0s I opened an issue and the problem is zeroconf ( 0.24.4 ). Please downgrade to zeroconf 0.24.3. Or wait a official solution/ upgrade catt

Hello everybody,

I am trying to let my google nest hub show my lovelace setup but I cant really figure out why it is not working. the display shows a black screen with a HA logo and a blue button with the text “START OVER”. The button does not appear to do anything.

I ran the following command to start catt

catt -d "slaapkamer display" cast_site ""

And added the trusted network section to my configuration.

Someone has a piece of advice?

Thanks in advance,


1 Like

Hello evrybody,

Same for me, little logo HA and this button “start over” …

@Keizermark did you find an issue ?


Wrong IP in the auth_providers for me, sorry …

It’s OK now …

Thanks Tintolo, that also did the trick for me! Much Appreciated.

This is exactly what I’m trying to figure out as well. Have you made any progress?

I have catt working great on my host Ubuntu system but I’d like a way to run a script through HA and have it run the command on my host. I have ssh working between the two just fine but I can never get catt to work through HA. Other commands like reboot work though.


ssh -i /config/ssh/id_rsa -o StrictHostKeyChecking=no [email protected] 'catt -d "Living Room display" cast_site ""'

I get catt: command not found.

I could just install it in my docker container but I want to avoid having to do it each time I update HA… Does anyone have a solution?

Try giving the full path to catt.

1 Like

What do you mean by that? Full path to what?

catt works directly from the host machine to cast my views, I just can’t get it to work through my HA docker container using ssh. Other commands seem to work just fine though.

Where exactly is catt installed? Which directory?

I honestly don’t know. I just did pip3 install catt on my Ubuntu machine and got it working. I’m not too savvy when it comes to Linux.

So thanks to your hint I was able to figure it out finally! For anyone else struggling with this here’s what I did.

$ which catt to find out that the directory is in /home/user/.local/bin/catt

Then added this to my shell_commands.yaml:

cast_living_room_display: ssh -i /config/ssh/id_rsa -o StrictHostKeyChecking=no [email protected] "/home/user/.local/bin/catt -d 'Living Room display' cast_site ''"

Finally, I added this to my script.yaml:

     - service: shell_command.cast_living_room_display

Now I can write automations to cast my views and I don’t have to worry about HA updates undoing everything :grinning:

1 Like

Yes that is what I was referring to, great it is working.

1 Like

Just a message to thanks everyone who posted their conf and tips here. I am now using CATT on a google nest hub with lovelace and custom cards. Great job !

Can anyone tell me if you are able to get around the problem using HA Cast as is described here: Cast - Size of Cards too big on Full HD Screen? I have this same problem. I see in the CATT page, it says “The display resolution is 1280x720.” On mine, it appears to be more like 720x1280, because it looks nearly the same as on an iPad in portrait mode, showing white bars on either side of the screen. Since I have a 4k screen and a Chromecast Ultra, this is just unacceptable.