VELUX KLF 200 pairing with Somfy IO motors and remotes

I’m not willing to buy anything more to get it working :slight_smile: I just have to reset my somfy motors, but im getting help with it, so all will work again then :slight_smile:

I have been using the KLF-200 with two of my covers for months now. It works fairly well, however I noticed on one cover, if I call the service cover.open_cover, the cover first goes fully open, and then down for about 5cm.
With another cover its even worse, it opens fully and then goes down by about 15cm.
Then, a 3rd cover does not go down at all once its fully open.

All of them report open 100% in this position (0cm, 5cm, 15cm) - does anybody have an idea how this can be resolved??

@skank by the way the manual for the situo 5 can be found here
But simply put, to remove a motor from a group, first go to the original channel of motor. Press the prog till you get feedback. Go to the channel in which you want to delete the motor and press the prog shortly. That way you should have removed the entity from the group.
I succeeded in reseting the motors my self and couple them again to the KLF, but it again only worked for the lights and the sunscreen (cover). But the “lamellen” still don’t work.
I started to wonder the motor was not supported, but since it works for you the motor must be supported.

Here, the people who placed the “roof” will come to reset all.

ok someone (not the company who placed) it, succesfully succeeded in putting the functions back to the remote.
So now the remote works for:

  • light
  • screen
  • roof

However, trying to pair the veluc klf200 doesnt work anymore … he cant find the device :frowning:

I guess its not completely reset then?
Crap hate this sh*t

Not sure if i can even reset it?
I thought we did by putting of the fuse for 2 seconds, back on for 10 seconds then back of for 2 seconds again and then back on$
That way the cover and light now works but as a said, nothing in the velux klf :frowning:

i found this, but nothing in there usable

If you own a Somfy TaHoma box and your motors support HomeKit (like the popular Oximo-io motors), you can move away from cloud to local controlling, by using the HomeKit-Controller integration with the TaHoma box!

The only downside at the moment is, HomeKit-Controller does not support tilt_position a the moment. I just created a feature request for this, if you can vote for it, it would be great.

Trying to set thisback up, my velux integration keeps failing:

Failed for velux: Integration failed to initialize.
21:25:03 – (FOUT)
Can’t connect to velux interface:
21:25:03 – (FOUT) velux

Any idea?

Aha ! After the firm has come to reset all, all is working again through HA
Now i’m keeping all, and never resetting the velux klf200 again :stuck_out_tongue:

See picture up how it looks in my HA dashboard.
Still looking for a more appropriate cover card

Also: anyone exposing to google assistant?
I can, but i was thinking if i shouldnt make scripts, so my screen and lamellen open at …% and close fully…

Any ideas about that?

I exposed my Velux roof Windows to google, allthough I just open/close them :slight_smile:

yeah i exposed it to google too, but not devices, i made scripts so it opens till % open
and closes

Yeah, but I want to speak native to google, and not use Keywords like activate for scripts, I prefer open/close/stop cover :slight_smile:

I have 8 SOMFY motors for rolling shutters, paired with a KLF200 and everything is working perfectly. I also had a SOMFY motor for a garage door and it also worked well with the KLF200 and HA.
But I also have a SOMY on/off plug. It is OK on the KLF200 side (the plug is paired with the KLF200) but I can’t find the plug in HA…
Does anybody have an idea what could be the problem?

Plugs are not supported by the Velux integration as per the docs, see here:

Thank you for your answer.
I read this page but it was not so clear to me. I was a bit confused by the mention of « light ». If I am right, the here is no io light product, but there are io receveirs than can drive lights. So I though that my plug will be recognised as a light.
Anyway, I think this page of the doc should be more clear about what kind of devices are supporter or not.

Since my previous message, I read the github page of PyVLX.

I had some hope when I read this
« Changing of on-off switches:
await pyvlx.nodes[‘CoffeeMaker’].set_on()
await pyvlx.nodes[‘CoffeeMaker’].set_off() »

(My plug is recognised by the KLF200 as an on-off switch)

but then I saw someone posted an issue to ask for the support of on/off plugs.

Someday maybe…!


I tried to add my KLF200 to HA running in Docker on Synology NAS yesterday. But I wasn’t able to add the integration. I tried to add custom integration in HACS which looked it worked, but still can’t choose the integration.

Anything else I need to install, Python or something?

Thx, pretty new to HA

The Velux integration is part of HA, no need to add. Unless you mean the MyVelux integration, that is a little different. Have you added the config with the IP address in the configuration.yaml as described in the above link?

Yes I did, but doesn’t change anything or how can I now control anything via KLF200 ?

The below is what I added. and a custom integration as well, but still can’t choose integration vellum anywhere in home assistant

host: “192.168.X.XXX”
password: “KLF200WIFIPASSWORD”

I also tried this My Velux via HACS but it doesn’t show up nor download the folder to custom components :frowning:

Make sure you have the indentations in the config, else it will fail. And of course no “quotes”

  host: IP_ADDRESS

Then, do a HA-config check and a HA-reboot, as far as I remember, it should do an auto-discover of the device (but I’m not sure). If that is not the case, head to Integrations, click add and search for Velux in order to configure it.
Also, and this is very important, what Firmware are you having on the KLF at this stage?

Unfortunately I’ve done all this, no difference between quotes or not. I cannot find Velux at all in the integrations part, not showing up to choose it

These are the errors showing up in the log when I just started the HA

Can not process <Telegram direction=“Incoming” source_address=“1.0.16” destination_address=“10/3/14” payload="<GroupValueResponse value="" />" /> for Licht Zimmer 1 - State: <CouldNotParseTelegram description=“Payload invalid” payload=""/>

21:53:58 – (WARNING) /usr/local/lib/python3.9/site-packages/xknx/remote_value/ - message first occurred at 21:51:37 and shows up 5 times

Could not sync group address ‘12/0/1’ (Stromverbrauch Total - Value)

21:53:41 – (WARNING) /usr/local/lib/python3.9/site-packages/xknx/remote_value/ - message first occurred at 21:51:37 and shows up 4 times

Error: KNX bus did not respond in time (2.0 secs) to GroupValueRead request for: 12/0/1

21:53:41 – (WARNING) /usr/local/lib/python3.9/site-packages/xknx/core/ - message first occurred at 21:51:37 and shows up 4 times

custom-components/wienerlinien - Repository is archived.

21:51:54 – (ERROR) HACS (custom integration) - message first occurred at 21:51:54 and shows up 2 times

Setup failed for velux: Integration failed to initialize.

21:51:51 – (ERROR)

Can’t connect to velux interface:

21:51:51 – (ERROR) velux

Setup of velux is taking over 10 seconds.

21:51:43 – (WARNING) /usr/local/lib/python3.9/asyncio/

Error doing job: application protocol failed to receive SSL data

21:51:41 – (ERROR) /usr/src/homeassistant/homeassistant/

Entity sensor.hacs (<class ‘custom_components.hacs.sensor.HACSSensor’>) implements device_state_attributes. Please report it to the custom component author.

21:51:37 – (WARNING) helpers/

Detected code that uses str for device registry entry_type. This is deprecated and will stop working in Home Assistant 2022.3, it should be updated to use DeviceEntryType instead. Please report this issue.

21:51:37 – (WARNING) helpers/ is not logged in to a HEOS account and will be unable to retrieve HEOS favorites: Use the ‘heos.sign_in’ service to sign-in to a HEOS account

21:51:35 – (WARNING) Denon HEOS

The ‘tunneling’ option near /config/configuration.yaml:31 is deprecated, please remove it from your configuration

21:51:34 – (WARNING) KNX

What is the Velux Gateway Firmware Version?