VM stuck at auto boot

As per the Home Assistant documentation, the configuration file is located at:
/config/configuration.yaml
Configuration.yaml - Home Assistant

The backup folder is located directly on the root of the drive at /backup/

To access these files, I just installed and configured the SSH & Web Terminal Add-On, and used WinSCP to connect to my Home Assistant instance:
Home Assistant Add-on: Terminal & SSH
Home Assistant Community Add-on: SSH & Web Terminal - Home Assistant OS - Home Assistant Community

I hope this helps.

You just saved my life! :heart_eyes:

1 Like

Life saver. I’m running a QEMU VM on Debian. ‘2’ then ‘Enter’ got it to boot.

Why does this happen?

1 Like

I am not entirely certain, but I would guess that either the bootup or shutdown process(es) are getting interrupted/corrupt, and perhaps a file is not getting written to properly that is used for the bootup initialization?

I’m finding my VM (under Proxmox) reboots having taken the steps above. I see a sys log message mentioning “failed to start QEMU agent”. I haven’t updated my instance for some time now. I’m not sure what could be causing this failure.

In case it helps anyone, the problem for me was caused because the disk was full. I enlarged the VMs disk within Proxmox, followed steps above, and HA came back up.

1 Like

You sir, are a hero.

1 Like

I have the same issue. I am running HA OS on a NUC. I have had this issue for a very long time and figured out the same.

I just use arrow keys on keyboard select system 0 and hit enter then it boots.

I want to know how I can stop this because have this issue everytime I update HA and needs to reboot.

No one knows why this is happening and how to fix?

Hello Guys and thanks! this is my first post here. Today had same problem.
Following the mbielech5 procedure it seems to start but after some strings loading it restarts again and go back to Autoboot Screen. Theres no way :frowning: . I use VMware in windows 10. I thought to reinstall all again but i need my HA backup and dont know how to get it if i cant start VM… Had a lot of scenes setted and addons, i dont wanna start again from 0. Any suggestion?

like i posted. Use a keyboard push arrow up or down it will show a selection then choose boot system0 and press enter

is not free! with VMFS Recovery i found the HA backup i need inside the vmdk but to save it it asks for registered version!! How can i extract it from the vmdk file without paying?

have u seen the video? is exactly what i do.

oh my bad did not realize it is a video, Sorry

1 Like

I am having exactly the same issue here.
This is looping

exactly! is looping. Any idea to fix this without reinstalling?

I assume you have tried to reboot, windows, And also make sure windows is updated … Specially if you haven’t configure windows Anti-malware to exclude the disk you have your WM- .vmdk and .vmem files.
EDIT: Anti-malware and Anti-virus systems do “peak” in “compressed/container” files :wink: , and windows give A.S if it’s your Home-Surveillance system files

Windows Antimalware can lock( During it’s “Search/Check” ) the .vmdk or .vmem files, can usually occur during boot of the image

Not that i know this is related, but could be worth a try, and to have in mind … i.e there is no reason for either antimalware or antivirus programs to “check” these files, or the whole drive for that matter, it’s just a big risk

PS: if it doesn’t help, and the .vmdk is not corrupt, you can open it with 7-zip
You find your files in 7.hassos-data.img /supervisor … just double-click on .img

Hi,

On my end I found the issue.
the vidisk was full so I increased the size of the vdisk.
You should probably try to do that.

1 Like

already tried this. i have allocated more space to virtual machine either if it wasnt full.


i think the problem is here with some partiton corrupted.
Any idea?

windows 10 updated and antivirus disabled. problem persists