Wallbox pulsar plus integration?

1st of all, thank you for the absolutely excellent integration, and especially the MQTT stuff. I have been using it both for the Wallbox Pulsar and to get the readings from the EM340 I have installed. One question though: Would it be possible to get the energy readings per phase (L1, L2 and L3) as opposed to just one summarized reading. I like granularity and seeing the consumption per phase allows me to identify at least roughly what I consume electrical energy for.
Thank you in advance,

if I’m not mistaken, the values from the EM340 through micro2wallbox are not summarized but the values of L1.
you can add the other phases in wallbox.yaml by copy/paste the L1 sensor code and rename to L2 and L3.

Might be missing something but I can’t find any other reference to the energy (Wh) than the sensor named sensor.micro2wallbox_energy. Or am I missing something here? The current and voltage per phase are there to get the power per phase, but not the energy (Wh) as that also needs to be persistent (shouldn’t reset to zero after each reboot).

I’ve just updated my Wallbox to 6.1.19 and can confirm that both SSH and MQTT bridge keeps working.

I’ve also added individual phase power measurements (used to be only the total l1+l2+l3). Also charging current per phase (I’ll use it for load balancing). Run the install script again to update.

1 Like

First I ran the install script to update MQTT bridge, and restarted Mosquitto Broker to be sure.

Then updated my Wallbox to 6.1.19 and noticed the much greener Halo LEDs in the Ready state.

But I don’t see any additional sensors for L2, L3. My Wallbox is only single phase, so perhaps that’s why. However, I expected to see additional sensors with 0 readings for L2, L3.

Is there anything else I need to do?

You can create template sensors to calculate power in W per phase (voltage * current) and then create integration sensors to convert it to energy in Wh. You might find Energy Disaggregation or Non-Intrusive Load Monitoring (NILM) blueprint more useful though. I also have the EM340 meter and I’m able to track dryer/oven/stove/microwave/rice cooker appliances with that blueprint.

Did you figure this out? I also updated the wallbox to support the three phases but i can’t see the power on the other phases and the power reading on the power sensor now only shows half of the consumed power, as I am charging my car with 2x16A….

if you’re charging with only 1 phase (L1 + N), it would be 1 x 16A.

Might have pushed the trigger too soon. For some reason which I nedd to figure out the charger only charged the car on L2. Also the car claims it only charges with 3.6kW as it always before was 7.2kW. Need to investigate if powerboost is doing something here… the other thing that changed after I updated the mqtt scripts on the charger today is the mqtt sensor for powerboost status comes up as unknown. Before that it was ”3”. Wonder if this is related…

A little update here. Just plugged in the car again and it claims it get’s 7.2kW power but all sensors in HA (both MQTT and the original cloud based one) says it provides 3.6kW. The really wierd thing is that the wallbox app also says it is delivering 3.6kW only….?!?! Any idea what is going on here?

@rogli - No, I haven’t figured this out yet. I checked the file creation date on my Wallbox for the ‘bridge’ file in ‘mqtt-bridge’ folder. Sure enough it was updated on the day when I ran the install script, but otherwise it’s as if nothing changed. No extra sensors at all.

Hopefully, we will hear from @jagheterfredrik with an update because it seems as though something isn’t quite right with the latest version of MQTT Bridge.

I’m not sure but i recompiled the bridge now, try install again

1 Like

Yes, it’s working now. Thank you :slightly_smiling_face:

To help others going through the update process, this is what you should see…

root@WBxxxxxx:~/mqtt-bridge# curl -sSfL https://github.com/jagheterfredrik/wallbox-mqtt-bridge/releases/download/bridge/install.sh > install.sh && bash install.sh
Downloading the bridge
Setting up auto-start
Created symlink /etc/systemd/system/multi-user.target.wants/mqtt-bridge.service → /lib/systemd/system/mqtt-bridge.service.
root@WBxxxxxx:~/mqtt-bridge# ls -l -a
total 5900
drwxr-x— 2 root root 4096 Jan 22 11:10 .
drwx------ 8 root root 4096 Jan 19 11:44 …
-rwxr-xr-x 1 root root 6029312 Jan 22 11:10 bridge
-rw-r–r-- 1 root root 255 Dec 25 21:22 bridge.ini

The directory listing at the end shows an updated time/date for the bridge file (was previously Jan 19).

And here are the new sensors…

Great work!

Pushed another version that rate limits the new sensors

1 Like

OK - status update here:
I updated the latest scripts from @jagheterfredrik and restarted the Walbox Pulsar Plus I have. Now the car is charging and there is still something odd going on with sensors in HA:
-The car says it is charging with 7.2kW
-Looking at the energy dashboard and the energy consumed per hour, the power fed to the car must be 7.2kW.
-The wallbox sensors in HA, both cloud and through the mqtt service says the power was 3.6kW
-Also the wallbox iOS app reports 3.6kW as the charging power
-The new per phase values for the mqtt sensors said that L1 fed 16A but L2 and L3 were on 0 A
So it seems the charger is providing the power that the car requests but the reporting is really off. Any idea how to solve this? Is it possible to get older versions of the MQTT modifications for the wallbox installed? Is it possible to go back to the previous firmware version of the box?
Any help here is truly appreciated!

That seems unrelated to the rooting and the bridge as the app also reports the wrong value. I’d try a restore (advanced settings in the app), that will take you back to the version that was present when your wallbox was manufactured.

Edit: if this is v4.x it seems you might not be able to root again!

Is there a way to find out before? Thinking about it, if it was a 4.x at delivery (which it likely was since it was bought in 2019), how was I able to root it in that case? Sorry, but rooting is really not something I am mastering, but wouldn’t it be possible to root if I reset it, update it to the latest fw and then root it?

I just know that I seriously want the device rootes to get all the features you have been providing through that!

@rogli - My Wallbox was also bought in 2019 (with the Zentri bluetooth chipset like yours) so I expect it had the v4.x firmware originally. However, it has been regularly updated so was running v5.x firmware until last week. Now I’m running v6.x and this is unable to be rooted at present. However, because I installed root access prior to upgrading, it’s still OK.

What you need is a way to roll back to v5.x to solve the problem you’re experiencing. There are hints that this is being worked on, but I don’t know for sure. Definitely, it’s not a good idea to publish copyrighted software from Wallbox in an open Github repo, so this would need to be arranged in private with the repo owner.

And just want to be sure I understand correctly. There is also no option to restore the wallbox to v4.x, root it and after that upgrade to 6.x?

One user has reported that v4 failed to root and I have no way to test