WallPanel for Android Redux

I have released v0.8.5 (0.8.1-beta.5) to Google Play and the Github project page. This includes the ability to pass a user agent into the Android WebView as outlined by @WazWaz. Please test it when you get a chance. Previous v0.8.4 had a small crash for new users without motion/face/qr enabled.

1 Like

Ok here is a comparison between WallPanel and the built in camera app. Yes the camera is very low Rez (640x480) but you can see the difference in brightness straight away. They are taken seconds apart in the same location (excuse the expression lol )


That’s crazy because in my application and on my devices (all nexus) I am seeing nothing like what you display. That is not normal at all and I am not sure hot do address it. Here is what I am getting from my device for the preview.

What are you running?

Thank you very very much @thanksmister. Just downloaded it and given it a try, and it has half solved the problem. I can now get through the authorisation page on Google. Then when I log in, it then redirects to a blank page, and stops there. What I think should happen is, it is trying to get the authorisation token from google, and then it lets it have access the api, but it seems to be stalling saving the token maybe ? Not too sure, maybe the amazing @WazWaz might know a bit more about it than me. But many thanks again for the update, its certainly a step in the right direction :+1:

I am using a Hipstreet Phantom 2 tablet, yeah, exactly, but just did a comparison on the camera’s for you, and its the same in both WallPanel and the Camera app here, looks nice and bright on both.

Yeah, that is probably part of the issue since we sort of grafting on this feature without fully understanding how it works. I haven’t had time to look at the other application you mentioned.

1 Like

I think the user agent part is working ok now. It might be something to with how WallPanel works with popup pages, or access token’s or something.

This is a screen shot of after I try to authorise, so you can see the url, with a my info blanked out, but might make a bit more sense to you than me.

But you didn’t use the User Agent String setting? That is where I think you were suppose to put the authentication, from what @WazWaz said, its why I added the setting. Read his post again and then add the appropriate string to the User Agent String setting (on this same page).

Thanks for comparing the camera’s. All my devices have the same camera image basically as my Samsung. I event tested it on a 2012 Asus 7" Tablet which is pretty old and the image is fine. I can’t think of what’s causing @apt to have such a dark image other than his beard :). However, I will investigate once I have his device information.

I think we need to have @WazWaz provide us with a string for the user agent or find out more about what he meant by inventing one for WallPanel. But if you do have a proper user agent it can be entered into the User Agent String setting.

I did set the string, as otherwise I couldn’t have got as far as I did. I tried it with an IE Windows 10

(Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; Trident/6.0; MDDCJS)

and Chrome

(Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36)

string, and it did work, as far as I could log into google, but it didn’t get past the login. Without the string, it doesn’t even let me login. So the user agent part works fine.

When i do the same process on a PC, i login with my user name in google, then put in my password, then a page pop’s up, and then closes, and then I am logged into the calendar, so I am pretty sure that popup page saves an access token somewhere from google, and thats the part where WallPanel is getting stuck.

I see, the user agent is set but its just not showing up on the setting screen when set (oversight on my part). Well maybe its the user agent or some other magic. We’ll have to wait and see if we get a response.

All a useragent does is tell a server what kind of browser it is using, and as google is funny as to what browser’s it lets access its api, tha’s why you have to “fake” it, just telling the server what it wants to “hear” so I think that side is fine. When I did this on Fully Kiosk, I had to enable pop up’s in the settings, so when I went to login, it pop’d up with the login window, I entered all my information, and then that window closed, it went back to the dashboard in Fully Kiosk, and the calendar is loaded.

The current user agent is:

Mozilla/5.0 (Linux; Android 5.1.1; Nexus 7 Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/65.0.3325.109 Safari/537.36

But it might vary by device depending on Android version.

It could be something related to the FPS of the Google Vision API as explained here https://github.com/googlesamples/android-vision/issues/162. I could try lowering the FPS but not sure what effect it might have on other devices. Right now its 15FPS for the camera rate.

Android Version 6 on a Alldocube Play 10.

Maybe a toggle for affected cameras so there’s a choice?

Has to be newer than my Asus 7" Nexus which is 2012. I don’t have that issue, but still investigating. I can’t replicate your environment so I have to find the issue someone reported. I can make the FPS dynamic so users can set the camera FPS to test performance, that way you could test it without others being affected. It will take a few to implement.

1 Like

Appreciated. It’s a new (ish) model:

Did you find out if it has any sensors?