Home Assistant Community

Wink/PubNub not updating

#1

Getting this error endlessly:
Fri May 03 2019 09:41:46 GMT-0400 (Eastern Daylight Time)
Exception in subscribe loop: HTTP Client Error (400): {“message”:“Invalid Subscribe Key”,“error”:true,“service”:“Access Manager”,“status”:400}
and, of course, Wink attached devices are not updating.

Any suggestions would be appreciated.

1 Like
Life360 Device Tracker Platform
#2

same here, and also getting connectionpool.py read timeouts to ps pndsn com - over 4,000 times since yesterday.

I assume the pubnub error is due to a “service degradation” reported by Wink yesterday.

#3

Probably so. Thanks.

Does the HASS code have to fail thousands of times in such a condition? And, local control seems to fail as well.

#4

There is no logic to give up after so long, it will try forever until it works again.

#5

It would sure be nice to have a workaround to avoid spamming the log with an error and a warning every 11-12 seconds “forever, until…”

EDIT: The following WORKS to suppress these pubnub errors and warnings:

logs:
  pubnub: critical
  urllib3.connectionpool: error
#6

These errors aren’t coming from Wink they are the underlying networking library that is throwing them. I am not 100% on how to filter those out. Can you send me the log?

#7

I was reluctant to set my default logging to critical, but have done so now and see that this does hide the detail for errors/warnings. There is still a summary provided:

Exception in subscribe loop: HTTP Client Error (400): {"message":"Invalid Subscribe Key","error":true,"service":"Access Manager","status":400}

1:03 PM /usr/local/lib/python3.7/site-packages/pubnub/pubnub.py (ERROR) - message first occured at 1:03 PM and shows up 3xxx times

Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ReadTimeoutError("HTTPSConnectionPool(host='ps.pndsn.com', port=443): Read timed out. (read timeout=10)")': /v2/presence/sub-key/sub-cxxx/channel/908xxx%7Csensor_pod-592455%7Cuser-559xxx%7Clock-195747%7Cuser-559xxx%7Clight_bulb-3177836%7Cuser-559xxx%7Clight_bulb-3199554%7Cuser-559xxx%7Clight_bulb-3150844%7Cuser-559xxx%7Clight_bulb-3156957%7Cuser-559xxx%7Cuser-559xxx%7Clight_bulb-3250112%7Cuser-559xxx%7Clight_bulb-3668414%7Cuser-559xxx%7Clight_bulb-3796400%7Cuser-559xxx%7Cbinary_switch-624094%7Cuser-559xxx%7Cbinary_switch-764524%7Cuser-559xxx%7Cbinary_switch-771093%7Cuser-559xxx%7Cbinary_switch-777551%7Cuser-559xxx%7Chub-516611%7Cuser-559xxxxx8%7Cgarage_door-123007%7Cuser-559xxxxx/heartbeat?heartbeat=300&pnsdk=PubNub-Python%2F4.1.0&uuid=xxx

1:03 PM /usr/local/lib/python3.7/site-packages/urllib3/connectionpool.py (WARNING) - message first occured at 1:03 PM and shows up 3xxx times
#8

It’s not just throwing the errors, status updates don’t seem to be coming through at all, so hiding the warnings isn’t going to solve the problem. Glad I’m almost completely off Wink at this point.

#9

I too am seeing those errors since 7pm EST last night. Now none of my sensors are indicating status changes etc through Node-Red or through the default HA automation tasks.

Right now I am dead in the water…

Its not all WINK… because Alexa and other tools are still communicating to the Lutron interface via wink. So it may be the WINK local working but not cloud APIs?

#10

Yes, I’m painfully aware of that. Until such time Wink comes fully back online OR I can replace the Wink and re-pair a bunch of zwave devices and get Google assistant working, I was just trying to minimize the intense crap in the logs.

#11

I had to set logging:

logs:
  urllib3.connectionpool: error
1 Like
#12

That would hide the connectionpool WARNINGS. Not sure how that would help with the pubnub ERRORS. I would try it, but a lightning strike knocked our broadband transmission tower offline an hour ago, so no home Internet ('cept my cell phone).

EDIT: @web10321 - Nope, didn’t work - still spammed by pubnub errors during this extended wink outage, but it did eliminate the warnings. A bit drastic, but setting the default logging to critical is good enough for now to save wear and tear on the sdcard.

#13

Can’t depend on Wink any more. I can accept an occasional problem, but not an outage for almost 24 hours. Ordered a z-wave stick today.

#14

I just added my entry after what you have published earlier.

default: info
logs:
...
  homeassistant.components.wink: critical
  homeassistant.components.wink.pubnub: critical
  wink: critical
  pubnub: critical
  wink.pubnub: critical
  urllib3.connectionpool: error
  ...
#15

I concur - just posted similar item in the forums too regarding the sensor data is not working.
This appears to be a HA to WINK issue as the WINK app controls the items just fine as well as robots are working between the sensors and lights… but HA is not detecting state changes.

#16

Home Assistant relies entirely on pubnub for push updates to get updates in to HA. Wink probably falls back to polling their API for updates. So if there is anything related to pubjub going on HA isn’t going to work.

#17

In addition to setting log levels, I added an automation to issue “service: wink.refresh_state_from_wink” each minute. That is helping to keep my sensors and switches almost up-to-date.

I would be satisfied to turn off the pubnub calls altogether if it were possible. w1ll1am23, could you post such code?

I still plan to move off Wink.

#18

@jaalperin can you share how the automation looks in yaml or node-red?

#19

Should be pretty easy, the issue is Wink may ban you. That is how Wink original worked and they reached out to balloob asking for use to stop.

Send me a PM and I’ll get you something together to test out.

#20

from automations.yaml:

  • alias: Refresh Wink States
    initial_state: ‘on’
    trigger:
    platform: time_pattern
    minutes: ‘/1’
    action:
    service: wink.refresh_state_from_wink

Once again the formatting is wrong.