Xiaomi Aqara Devices Frequently Unavailable

Tags: #<Tag:0x00007f3f1c5bd058> #<Tag:0x00007f3f1c5bcc20>

I have a Xiaomi Aqara hub and a handful of buttons, motion sensors, temperature sensors, water leak sensors.

All types of devices frequently show “unavailable” as their status. Here’s today’s history of a few devices for example:

(And strangely, that Upstairs Motion sensor is the most reliable but is farthest away from the hub).

Any ideas here? Hass.io 0.65.5, Xiaomi Gateway FW 1.4.1_151.0143 (1.4.1_153.0143 is available). Am I asking too much of these devices or should I be able to find a fix? Anyone tried 1.4.1_153?

Thanks!

I’ve actually just started seeing this too in the past week or two - not sure exactly when it started. Prior to that I didn’t notice it though.

Hmm yeah maybe you’re right. I’ve only recently started using the motion sensors in automations, but now that you mention it my buttons at least were pretty stable before a couple weeks ago. Temp sensor too. Did you update your Xiaomi firmware recently or just HA? I don’t think I updated Xiaomi but it’s possible.

Confirmed. Perfectly clean until March 12. Hot mess from March 13 onward. Reviewing my logs to see what happened around then.

Hey @nick67

Check out this issue #11926. I was experiencing similar issues during January.

I ended up giving up on Xiaomi gateway integration due to this instability and privacy/security concerns. I did it by purchasing a Deconz server compatible device (ZiGate is another option). Its been fantastic but still requires development to easily support the range of Xiaomi Zigbee devices. The door/window sensors and motion sensors can be easily added via Phoscon.

Cheers,
Chris

This is a new feature in the module, introduced recently. If a sensor hasn’t reported in a while it’s marked as unavailable. This is to ensure that your smoke sensor is actually working and not find that out when there’s an event but nothing is reported.

1 Like

I’ve updated both.

I’m away from home, overseas, for a week and a half so can’t easily assist with troubleshooting or identifying if it started after my firmware update… but I’ll be following along and answer what I can in the meantime.

My gateway is on firmware 1.4.1_153.0143, Hass.io is on version 0.65.6 and I have 14 aqara devices connected to the hub and I never have any devices showing unavailable except a temperature sensor which was a long way from the hub and after moving it a bit closer that issue went away.

Ok I’ll try updating and report back. At least some of the time, devices are showing offline in the MiHome iOS app too so it seems like it’s on the Xiaomi end.

1 Like

Hi, any update on this?

I have just bought a gateway and I noticed the same behavior with a temp sensor and a door sensor. The sensors are are working fine then unavailable after a few hours.
It is also preventing Hass to restart. I have to stop then start again Hass manually.

Have you checked you network is performing correctly

The reason i say this is that i had the same issue with sensors going unavailable all the time

i changed my 2.4g network to the lowest channel as my xiaomi gateway was at zigbee 25 frequency and this was overlapping with wifi channel 11.
Since moving to the lowest WiFi channel i have had no issues for the last month.

Have a read of this article as i found it useful in the zigbee/WiFi channel overlapping issue.

also look at this thread on how to see what zigbee channel your gateway is on.

hope this helps

3 Likes

I will look into this.

It might be the issue indeed as I’m living in an apartment this a lot of different wifi signal.

Something is odd as well. Mine were working perfectly with 0.64, but since 0.68 and 0.69 they’ve been showing unavailable at random times. I will have to go back to 0.64 it seems. Ive also reset the GW and sensors and they showed up last night, and then showed unavailable after 3hrs of no movement.

So that was it !
I checked Mi app and the gateway is using channel 11. My router was using an option to automatically select the best wifi channel. I deactivated this option and selected channel 1for my 2.4ghz wifi.

I restart my rooter and Hass and since then the temp sensor is working flawlessly. Temp data are updated every 20min or so and I don’t have the gateway or any sensors unavailable anymore.

Thanks for your help.

1 Like

It would be good if it was possible to change the gateway zigbee channel and push it further out. i have found no way to change the gateway channel, even a complete reset doesn’t seem to change it. i even tried a completely different account in case it was account based in the m-iapp

but glad it helped for you also

unforunately no luck for me. channel and wifi are different. im on firmware 154 but i see 155 is out. same behaviour in 0.70. last working one without this issue for me is 0.67

just wanted to comment on here that I too had this issue and in my case moving the Xiaomi gateway stopped this from happening. You guys need to think about your mesh and how to make it stronger. Move the gateway and add a powered socket that will help a great deal.

whatd you mean “moving” the GW? my GW is plugged into the wall using an adapter.

I mean physically move it to a more central location and/or add more powered devices that connect to the gateway via zigbee like the wall socket. The issue is that all your devices are battery powered and they do not route to each other, you need powered devices to do that. Depending on the size of your property you may need to do both. In my case I moved it from one room to another and all seems to be well.

Interesting. So i do have another GW which i can plug in for all sensors on the 1st floor (theres only 1). the main GW which im using now is on the 2nd floor, and the motion sensor is directly in line of sight.
kirichkow says its some new feature if theres no reported movement, then it will be unavailable. Im wondering if thats the issue, because during the day there is no movement. After 3hrs, they become unavailable.