Yale Keyless Smart Lock + Z-Wave Module 2 + Keymaster


I have been using Yale Keyless Smart locks with Smartthings for many years with Rboys Lock User Management to handle the user pin and RFID tags for the 3 Yale locks that I own. One of the great features of this is that it can send you a notification to say who has opened the door and by which method (pin code or RFID tag). Unfortunately, as this is based on the Smartthings groovy platform this will stop working at the end of the year when Smartthings switches it off. From what I can tell there will be no immediate replacement for this loss of this lock management functionality on the Smartthing platform.

Upon searching for a replacement solution, I came across the Keymaster HACS integration on Home Assistant. This prompted me to migrate all my smart home devices from Smartthings over to Home Assistant. For Home Assistant, I purchased the Z-Wave Plus Aeotec Z-Stick 7, which I upgraded the firmware in the device to the latest version. I have securely paired the Yale Keyless Smart Lock (model yd-01-con-nomod-ch) to Home Assistant and set up Keymaster. Keymaster seems to work fine with the lock (ie it can successfully programme users code into the lock device) but the one item I can’t get working is any feedback from the lock itself, ie I don’t seem to be able to get any notifications from the lock to Home Assistant that the door lock has been opened. I don’t think the problem is with Keymaster but might be more a zwave problem.

Being new to Home Assistant I am hoping someone can help guide me on troubleshooting the issue. Is there a way I can see the raw zwave messages coming from the door lock to ensure that these are being sent? Obviously, I know the door lock can support this as it was working fine in Smartthings.

I have tried removing the door lock from the zwave controller and repairing (with the controller a few inches away from the door lock itself to ensure good signal) but I still don’t get any feedback from the lock via Keymaster.

I am really hoping I can get this resolved as it’s the last item I need to fix before I can switch of my Smartthings system and complete my move to Home Assistant.

Thanks for any help in advance

1 Like

You can monitor the log files for the zwave integration via SettingsDevices & ServicesIntegrations(tab)Z-Wave (CONFIGURE)Logs(tab)

Configure the various Log Levels for amount of detail.

Look in the key master thread there’s instructions on how to setup notification scripts. In fact if you haven’t done it you probably have an error in the log complaining about the system not being able to locate a (lock name) notification script (i dont remember the exact text) every time someone unlocks the door.

Here is my Yale lock device info

Device info
by Yale
Firmware: 33.16
Z-Wave Info
ID: 30
Status: Alive
Ready: Yes
Highest security: S2 Access Control
Z-Wave Plus: Version 1

I have switched the Z-Wave JS Logs to silly mode (thanks ski522 for the info) and opened the lock by both a pin code and an RFID tag and I don’t get any entries in the log. If I use Home Assistant to unlock the lock remotely I see the following log entries

Subscribed to Z-Wave JS Log Messages…
Log Level changed to: Silly
2022-11-16T12:39:37.310Z CNTRLR   [Node 030] [setValue] calling SET_VALUE API DoorLockCCAPI:
                                    property:     targetMode
                                    property key: undefined
                                    optimistic:   true
2022-11-16T12:39:37.315Z SERIAL » 0x011f00a9011e139f03920099a0e8c62f9e3441755e8fee58eaf02500000000b50 (33 bytes)
2022-11-16T12:39:37.315Z DRIVER » [Node 030] [REQ] [SendDataBridge]
                                  │ source node id:   1
                                  │ transmit options: 0x25
                                  │ callback id:      181
                                    │ sequence number: 146
                                      │ session id:      14
                                      │ request updates: true
                                          target mode: Unsecured
2022-11-16T12:39:37.323Z SERIAL « [ACK]                                                                   (0x06)
2022-11-16T12:39:37.324Z SERIAL « 0x010401a90152                                                       (6 bytes)
2022-11-16T12:39:37.324Z SERIAL » [ACK]                                                                   (0x06)
2022-11-16T12:39:37.327Z DRIVER « [RES] [SendDataBridge]
                                    was sent: true
2022-11-16T12:39:38.820Z SERIAL « 0x011d00a9b500009202a17f7f7f7f0101030c0400000201041e7f7f7f7f7fa2    (31 bytes)
2022-11-16T12:39:38.821Z SERIAL » [ACK]                                                                   (0x06)
2022-11-16T12:39:38.824Z DRIVER « [REQ] [SendDataBridge]
                                    callback id:            181
                                    transmit status:        OK, took 1460 ms
                                    repeater node IDs:      12, 4
                                    routing attempts:       1
                                    protocol & route speed: Z-Wave, 40 kbit/s
                                    ACK RSSI:               -95 dBm
                                    ACK RSSI on repeaters:  N/A, N/A
                                    ACK channel no.:        1
                                    TX channel no.:         1
                                    route failed here:      4 -> 30
2022-11-16T12:39:38.912Z SERIAL « 0x011a00a800011e119f030400bb0675f6b6569b044b8d51b90f00a11a          (28 bytes)
2022-11-16T12:39:38.914Z SERIAL » [ACK]                                                                   (0x06)
2022-11-16T12:39:38.916Z DRIVER « [Node 030] [REQ] [BridgeApplicationCommand]
                                  │ RSSI: -95 dBm
                                    │ sequence number: 4
                                        session id:          14
                                        more updates follow: true
                                        status:              Working
                                        duration:            2s
2022-11-16T12:39:38.919Z CNTRLR   [Node 030] [translateValueEvent: value updated]
                                    commandClass: Door Lock
                                    endpoint:     0
                                    property:     currentMode
                                    propertyKey:  undefined
                                    internal:     false
                                    secret:       false
                                    event source: undefined
2022-11-16T12:39:38.920Z CNTRLR   [Node 030] [~] [Door Lock] currentMode: 0 => 0                    [Endpoint 0]
2022-11-16T12:39:38.920Z CNTRLR   [Node 030] [translateValueEvent: value updated]
                                    is root endpoint:        true
                                    is application CC:       true
                                    should hide root values: false
2022-11-16T12:39:38.921Z CNTRLR   [Node 030] [setValue] result of SET_VALUE API call for DoorLockCCAPI: (Supervi
                                    status:   Working
                                    duration: 2s
2022-11-16T12:39:38.922Z CNTRLR   [Node 030] [setValue] updating value with event
2022-11-16T12:39:38.923Z CNTRLR   [Node 030] [translateValueEvent: value updated]
                                    commandClass: Door Lock
                                    endpoint:     0
                                    property:     targetMode
                                    propertyKey:  undefined
                                    internal:     false
                                    secret:       false
                                    event source: driver
2022-11-16T12:39:38.923Z CNTRLR   [Node 030] [translateValueEvent: value updated]
                                    is root endpoint:        true
                                    is application CC:       true
                                    should hide root values: false
2022-11-16T12:39:40.831Z SERIAL « 0x011a00a800011e119f030500b4d4fe991205eb63bc6e3df03100a1cd          (28 bytes)
2022-11-16T12:39:40.833Z SERIAL » [ACK]                                                                   (0x06)
2022-11-16T12:39:40.840Z DRIVER « [Node 030] [REQ] [BridgeApplicationCommand]
                                  │ RSSI: -95 dBm
                                    │ sequence number: 5
                                        session id:          14
                                        more updates follow: false
                                        status:              Success
                                        duration:            0s

Is this indicating some sort of communication problem?

for reference Node 4 is a mains powered Fibaro double switch

by Fibargroup
Firmware: 3.3
Z-Wave Info
ID: 4
Status: Alive
Ready: Yes
Highest security: None
Z-Wave Plus: Version 1

and Node 12 is a main powered Fibaro Dimmer 2

by Fibargroup
Firmware: 3.5
Z-Wave Info
ID: 12
Status: Alive
Ready: Yes
Highest security: None
Z-Wave Plus: Version 1

Any ideas why I’m not seeing any response in the Z-Wave logs when I open the Yale Smart lock?

Thanks for your help

Hi Oceanic, Can you help me on this as we’re using the same z-wave device? It works previously but didn’t work on the recent JS upgrade.

Keypoint this alarm is missing hence JS can’t sense it or was it re-located somewhere?

I have exactly the same lock same situation as yourself only set up home assistant a few days ago had smartthings and hubitat working properly with this lock.

Not sure where I’m going wrong

Reading through the thread that Andrew77 provided it would seem that the feedback from the lock is provided by the following entities

Alarm Level
Alarm Type

I have checked and both these entities are Enabled in my HA but as you can see from the screenshot they are always showing Unknown and never change. I’m using the second gen2 Zwave Yale module (blue one), Zwave-js and S2 security.

Andrew77 and ADDZ2108 is this the same for you?

Unfortunately I don’t know how to fix this

Mine is this

  1. How do you upgrade your fw ID?
  2. I just enabled Alarm Level and Alarm Type just now, it was disabled(default? huh?. Is it supposed to work this way?
  3. Do I setup automation via the 'Automation Box?


Same as you guys, my alarm both show as unknown even though I enabled them the other day.

Hi Andrew77,

I think yours might be working now. If you unlock the door via different methods and users are the Alarm Level and Alarm Type numbers changing? By decoding these you can see how and who unlocked the door.

I notice you don’t seem to have the S2 security enabled. Are you using a Gen1 Yale Zwave module (ie a green colour one)?

Hi Addz2108,

You seem to be having exactly the same problem as me. You are on the same Yale firmware and using the same S2 security but your Alarm Level and Alarm Type are not giving you any information back from the lock.

I’m reading through the Zwave-is Home Assistant documentation at the moment to see if that gives me any clues.

Hi Oceanic

Seems as though it used to work with the old zwave integration from what I’ve gathered.

The only this I haven’t done differently than you is haven’t yet installed keymaster I was going to but thought I’d try getting the lock working fully first.

Hi Oceanic,

I think it’s the green one. Would this be ok that I still be using this. It’s still secured rite? As per last z-wave deprecated, I did a keycode unlock and I think it triggered. I should be looking at alarm # 19 for initiation? Thanks

p/s : did you check if yours are supported? I know mine is not listed
Z-Wave JS Config DB Browser (zwave-js.io)

Did you ever find the solution to this I haven’t been able to get it working properly?

Also I tried key master and the code changed but never showed as complete.

The only thing I haven’t yet tried is a full reset of the lock.


How are you able to S2 Access Control and mine is S0? Do you think i should re-pair it?
Also , what do you mean the complete part? Which parameter should I check from my end?

Side track,
I’m considering just getting a sensor to activate the automation rather than using the door lock.

I think I’m able to get s2 security because iv got the newer blue z wave yale module.

But my alarm types don’t show like yours mine are stuck as unknown.

Any updates on this issue as I’m still scratching my head?

I still haven’t managed to resolve this. I read the ZWave-JS documentation but that didn’t help. I am not sure if the problem is with ZWave-JS integration or the locks entry in the ZWave-JS Config DB

The lock module is listed in the DB and the Alarm type mappings for the Yale modules seem to be shown OK


I’m thinking we might need to raise a bug request, but I have not raised one before and it would be nice if someone with a bit more knowledge could confirm if we need one before I raise it.

1 Like

OK - I have raised an Issue in gitlab, I am suspecting it might be related to the S2 security but then again I could be completely wrong

(1) Z-Wave JS - Not receiving Alarms (unlock notifications) from Yale Keyless Smart Lock using S2 security · Issue #83135 · home-assistant/core (github.com)

1 Like

Good work but seems like you’ve posted in the wrong place by what I’m reading which will also link you to the comment that I left a week or so ago on GitHub.

Hopefully this will get sorted unless its something were doing wrong ourselves.