Yale Zwave locks

Yea it’s strange i noticed i get that if i reset HASS and thats what the device template picks it up as

This is great but do you know how to only show the latest person who unlocked the door ?

This is unfortunately overwritten by " Auto re-lock" after 1 second.

Does anyone have any good automations using the alarm level, type?

I’m thinking

  • Send notification when battery low
  • Enable/disable user codes, maybe a boolean I can manually toggle or trigger with automations and conditions
  • Displaying the battery percentage

My repo has some automations you may find useful. Yale Touchscreen Lock:

1 Like

Whats the purpose of the node anchors section of your package file? Anywhere I can read up more on this?

Is there a way to force HA to poll the data from the sensor after reboot of HA so that it does not maintain an unknown state after reboot but before first communication received from yale lock?

I am stuck here. I have set up the network key in config.

usb_path: /dev/ttyACM0
network_key: “0x22, 0x53, 0x02, 0x31, 0x04, 0x05, 0x08, 0x09, 0x09, 0x0X, 0x0S, 0x0D, 0x0D, 0x0E, 0x0F, 0x10”


2019-01-06 16:26:08.605 Detail, Expected callbackId was received
2019-01-06 16:26:17.316 Error, Node010, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-01-06 16:26:17.317 Detail, Node010, Removing current message
2019-01-06 16:26:17.317 Detail, Node010, Notification: Notification - TimeOut

Anyone have any ideas? I tried factory resetting and re syncing via secured node but cannot get this to work?
If I am reading the log correct is it an issue with with network key?
I am able to see it and see the switch but lock/unlock does not work.

I am just realizing my lock is the YRD226NR619 this showing the YRD446?

I was on discord and @freshcoast helped me today. Just in case it helps someone else. The problem was that I installed zwave AFTER I put in the network key. this caused the key to not show up in the .storage/core.config_entries file. I removed the lock - copy and paste the network key into this file - restarted - and re-pared the lock. This worked like a charm! it is fully functional now. Not sure you will see this but thank you very much @freshcoast!

1 Like

Is anyone using Keyfree lock with Zwave S2/Plus module (light blue)?
Im struggling to set it up, some of the advanced config options are working all right, but the nodes does not contain any entities.

Hi Derek
I’m struggling on setting up my Yale lock
Can you elaborate on how should be configured?
I did not understand your last comments

Yeah I have the network key set- I did everything as the docs state for a secured node

Basically same issue I have right now

My issue is that I’m not seeing any of the sensor data. I have the lock paired in Vera so I’m not sure if that’s the issue (seems most people here are using a zwave stick instead). Any idea how I can get it to report the alarm values?

Guys, I’ve reading a lot o forums threads about Yale ZWave locks, but i couldn’t find anything precise about the matter: are all yale zwave locks compatible with home assistant?

I run my HA in a raspberry pi. Still don’t have any zwave device (only one zigbee). I’m thinking about buying this stick: https://www.amazon.com/gp/product/B00X0AWA6E/ref=ox_sc_act_title_2?smid=A1O77D5UJY7IVU&psc=1

Will it be OK to use any new Yale Lock (given it is zwave compatible) with my setup?
Thanks in advance!

One more thing: do you guys suggest any lock that uses fingerprint?
I would REALLY like one with a key pad for pin, fingerprint and external key.

I liked this one: https://www.yale.co.in/en/yale/yale_co_in/products2/digital-products/digital-door-locks/ymf40-mortise-lock-biometric-pin-code-mechanical-key-remote-control-optionalymf40-mortise-lock-biometric-pin-code-mechanical-key-remote-control-optional1/
But this is India’s Yale website. I just couldnt find any site in the US that has that one for sale. =/

I have mine paired in Vera as well and there are sensors from Vera in HA. I have this in my lovelace config to display the lock/unlock status and battery level. Can also unlock or lock from HA.

  - entities:
      - lock.side_door_lock_271
      - sensor.side_door_lock_bat
    title: Door Locks
    type: entities

Hi, yep that’s all fine, the issue is that there’s a fair bit more data available that isn’t exposed by Vera currently.

I just signed up because I wanted to share my experience with my Yale YRD446/Aeotec Z-Stick Gen5/Home Assistant/unRAID.

I’m still new to Home Assistant and automation, so cut me a little a little slack if some of these things should have been obvious.

Backstory: I first attempted pairing the lock with the Z-Stick using the supplied instructions. I didn’t realize how much frustration this would cause. After pairing the lock and Z-Stick, I added the Z-Stick to the docker config. The lock immediately showed up, but I had no control of the lock functionality via Home Assistant. After doing some research, I came to understand that the device needed to be added securely from within HA, openHAB2, or Domoticz - I believe it doesn’t matter as they all use open z-wave on the back end. However, no manner of removing and adding securely/un-securely or blowing away my HA instance and starting from scratch would solve the problem.

What solved the issue for me was to remove the pairing then go back even further and complete a factory reset of the Yale door lock. After the reset, I paired the devices securely through the Home Assistant UI and magically everything was functional.

I’ve read a few posts now that many Z-Wave devices must be factory reset in order to clear whatever key was provided to them prior to being able to pair with a new key. If you run into functionality issues even when the device appears to pair, I’d give a factory reset a shot. That and keep a copy of the key somewhere safe if you have to start from scratch in the future.

1 Like