YET another take on an alarm system

Hey mate,
Did you ever sort out the disarm function via the mqtt panel? I’m currently encountering the same issue.
Thanks.

from setup part, I don’t know what you have done.
But in configuration.yaml you have to put

frontend:
  javascript_version: es5

Thanks, but that didn’t do the trick for me sadly.
All my errors is gone from log once I comments out the:

alarm_control_panel: !include alarm.yaml
panel_custom: !include panel_custom.yaml

so somewhere there lays my issue I suppose :-/

alarm.yaml <== is in homeassistant config directory (/home/homeassistant/.homeassistant/alarm.yaml)
panel_custom.yaml <== is in homeassistant config directory (/home/homeassistant/.homeassistant/panel_custom.yaml)

I’ve found the issue… :roll_eyes:
Somehow saving the files with Firefox messed them up… so I got to copy and paste the code of every file.
no more errors in log and the interface is working like a charm :smile:
Thanks for helping me out

I finally made the Zipato keypad work with Hass-Custom-Alarm :slightly_smiling_face:

It wasn’t so difficult, as gazoscalvertos said the “interconnection” part between the keypad and the alarm components only relies on automations to sync the state of both.
When you set the mode to “home” or “away” on the keypad (using a valid RFID tag or a valid user code), the alarm_level sensor of the keypad switches between 0 and 255, and so it’s easy to arm or disarm the alarm accordingly.

I used this topic to configure the keypad :


and I had to apply some changes to zwave/lock.py component, as described by merredin in this post Basic Home Alarm Setup with Zipato Keypad

Also, when I first paired the keypad with my hass instance using Zwave classic mode (i.e. “not secure”), it didn’t work, I cannot set any user code.
Then, I removed the device and paired it using Secure Z-wave pairing process, and it worked like a charm !

So, first apply the changes to lock.py file, then, pair the device securely. After, define some user codes (or pair tags), and then work with automations to sync the state between hass-alarm and keypad.

If you need some help feel free to ask me :slight_smile:

2 Likes

Is it possible to have a badge of the active sensors? ANd give an alarm if they are less then the programmed ones.

I do have 15 motion and dorr/windows sensors, it would be good to have a badge showing the amount of registered sensors, so you know if some are not registered as entity_id, hence not working

can you please explain the advantages of the key? Just for not using a smartphone to arm/disarm, or?

Alright, it’s to have another way to arm/disarm the alarm instead of the phone.
Actually, if you come back home and your phone is out of battery, you can’t disarm the alarm… So bad to wake up you neighbors with siren because of that :slight_smile:
Another reason to add a physical keypad anybody can use, is if you have someone coming in your house (for cleaning for example), and you don’t want this person to access all your data through the home assistant app. With the keypad, you only give him a code, and that’s all, he’ll be able to arm / disarm the alarm.

Hi,
I have a strange issue with one of my tablets (Kindle Fire HD 8.9 running Android 7.1).

The alarm panel shows the wrong time. It shows UTC instead of the device’s time (visible in the upper right corner):

On my other devices it shows up fine.

Any ideas?

Jochen

The time in alarm control panel should match what you see in HA. As from the picture the Kindle Fire HD show 22:43.

The alarm panel display the time according to HA.

I get the same issue on my phone. Its very strange. I can be sitting at my laptop with the alarm control panel open on both my laptop and phone, my phone always shows the time 1.5 ahead in the control panel despite the actual phone time being correct.

The time is correct in HA and on the Pi that it is running on.

The time and date sensor in HA shows it:

So, I guess that HA is showing server time and the alarm screen is somehow determining the client time which is probably buggy in certain circumstances when locales or other things are involved.

Another thing, just found errors from bwalarm.py in the HA logs. I triggered 2 motion sensors in the house, but both are not relevant for the alarm in home mode.
The logs are not really indicating what the error is:

<state binary_sensor.bewegungsmelder=on; battery_level=None, friendly_name=Bewegungsmelder Flur OG, device_class=motion @ 2018-02-01T06:09:48.119472+01:00>
06:10 custom_components/alarm_control_panel/bwalarm.py (ERROR)
<state binary_sensor.fibaro_motion_sensor_sensor=on; node_id=4, value_index=0, value_instance=1, value_id=72057594110017536, old_entity_id=binary_sensor.fibaro_motion_sensor_sensor_4_0, new_entity_id=binary_sensor.fibaro_motion_sensor_sensor, friendly_name=Bewegungsmelder Flur EG, device_class=motion @ 2018-02-01T06:09:58.199837+01:00>
06:10 custom_components/alarm_control_panel/bwalarm.py (ERROR)

Hi first post here.
Evertyhing looks great and i have the system up and running, but I have the same issue with the codes, that only the Panic code will deactivate the alarm. I have tried without quotes with single quotes ( ’ ) and with doublet quotes ( " ).

I have looked at the install fines and they seem to be same date as the ones I find here, are there any fix for this problem yet?

Thank you for the answer in advance and the great work you have put into this project.

/Steffen

My motion sensor is in “standyby” (all lower case) and “motion detected” when triggered

I use his latest update from github. He just recently updated. Both put direct in alarm.yaml or secrets.yaml work fine for me.

from alarm.yaml I have single quote ‘1234’ and ‘5678’ on both
code: ‘1234’
panic_code ‘5678’

When I put the code and panic_code in secret file.
code: !secret alarm_code
panic: !secret panic_code

in secrets.yaml
alarm_code: 1234
panic_code: 5678

Newb question, panic mode is when you want to trigger the alarm??

I didn’t see any explain regarding the panic mode

Panic mode is used to unlock the alarm but send an SOS notification to a predefined recipient. If I’m not mistaken, it’s described inside alarm.yaml