Z-Stick and GE devices manual state changes

I have a Aeon Z-stick gen 5 running on a raspberry pi v3 and my ge z-wave devices (12722, 12724 and 12720) are not updating their state when switched manually / locally. I can change the state of the devices via scenes and automations. Their states eventually get updated by polling but using them as triggers in automations do not work (I have a non-load switch where I am trying to turn on hue lamps).

I have tried ozwcp and checked the logs and nothing updates or shows when hitting the switch manually. I also tried to ensure that they are in group but it appears they dont support associations. I have reached out to tech support as well.

Just curious if any one else has this setup and experiencing the same issue (or not).

I have seen the same thing with my Gen 5 zwave stick and GE switches. I want to try this but haven’t had a chance yet, it looks promising -> Z-Wave devices not being polled

I tried that but it updates the polling but not a hail or instant state changes.

That’s a pity - I just ordered 3 GE switches hoping that they would solve the problem of my Linears not sending updates (my online research seemed to suggest they would). I had read that Lutron? had a patent about timely status updates for wall switches and that GE licensed it but Linear didn’t. I have ZWave bulbs that report their status within a second or two when they are powered on, so it doesn’t seem to be a limitation with HA or the Aeon stick, just the dimmers themselves.

Falling back on polling is fairly hideous, I couldn’t do better than a minute or so to get the status updated and I assume that will get worse the more devices you add to be polled.

Has anyone had success with a wall dimmer that sends timely updates?

My smartthings hub would get the updates instantly even as a secondary controller so i dont know if its a z-stick problem or they are setting some parameter when I add them. I just cant do complex rules in ST so I was switching over. One simple thing I found is that I can set the dimmer level with HA with the light off. in ST the light turns on when setting the level.

Yes, I saw the same with SmartThings - I think its some kind of workaround they added.

I have a number of GE switches, but only the 12724 3-Way Dimmer gives me this problem. I also connect using the Gen 5 zwave stick. I am afraid that none of the changes to polling have made a difference.

Interesting - I’ll report back when I have installed my dimmers - I have a few regular 12724s and a 3 way 45613.

Weird some were working fine when I got home, one still has a delay sometimes.

also just received this from Jasco

“None of our Z-wave switches (300 series) that are on the market right now will report their status. This will change once the 500 series switches are released which should be later this year.”

I think this is evidence of the patent lapsing - probably other manufacturers will follow suit.

I find that if I click on the card for the dimmer after manually turning the switch off at the wall, I see this displayed consistantly. If I then slide the dimmer all of the way to the left, it then changes to OFF.

So I wonder if the dimmer is just not dimming to zero when it is manually actuated?

I also have the 12724 dimmers. Same behavior here when turning the switch off at the wall. I think it is due to the zwave light component updating its state before the dimmer has finished its built in fade out.

See here:

In value_changed there is a 2 second timeout after which it refreshes the value. For the 12724 I think this happens while it is still in the process of dimming to the off state so it picks up a value somewhere around 30% pretty consistently.

This could probably be fixed by simply increasing that refresh timeout. That does not sound like a great solution but given the behavior of the 12724 not sending status updates I think that might be the best we can do. Also I am not sure why that 2 second timeout is there in the first place or if changing it would break anything else.

1 Like

I was just about to post a similar conclusion - I just installed my 12724, and actually I am getting instant (well maybe 2 second) updates back to HA when I switch it on. way better than the linear I replaced. When I turn it off I see the same thing in the logs - it didn’t report being off, it reported being on at a lower level, so the system kept it on.

To add weight to your theory, if I turn the light off, and then press the switch in the off direction again, I do get the device transitioning to off in HA - presumably because since the brightness was zero at that point, and the same 2 seconds later it decided it was actually off.

And I just thought of another confirmation - when switching the light off from already very dim levels, the device would transition to off in HA probably since it took less time to actually switch off.

I just changed the timer to 3 seconds and it works perfectly :slight_smile:

Which file did you change? And where is it located?

Found it! Works like a charm:


Line 80: self._timer = Timer(2, _refresh_value)

Changed (2 to (3

That’s it :slight_smile: problem is it will revert during the next upgrade. I should see about making a PR to get it changed permanently.

Thanks @imagio for pointing this out :slight_smile:

I submitted a PR for this today.

Thanks - I coded one up then got sidetracked rebuilding my entire environment :slight_smile: