Z-wave and aeotec s-stick Gen5+


Unable to install z-wave in HA, I always get the “connection failed” message

url : ws://localhost:3000 = “connection failed”

why ?

I haven’t found an effective solution on the internet :face_with_raised_eyebrow:

DSM 7.2
“zwavejs-zwave2mqtt” container
“homeassistant-home-assistant” container
z-wave aeotec s-stick gen5+ usb stick

error message on “zwavejs” setup :
Driver: Failed to open the serial port: Error: No such file or directory, cannot open /dev/ttyACM0 (ZW0100)

could be the cause of the problem? but how to solve it?

thank very much for your help :slight_smile:

The HA machine cannot see your USB stick.

Do you have the path correct?
Above you use ttyACM0 which is one of your virtual USB ports. Is it the right one? Also these ports can ump around. It’s usually better to address the port using the long by-id path to the device (you can find it under the hardware list.)

Alternatively did you try to setup the BUILTIN ZWaveJS first? Because the websocket error indicates your trying to use either a separate ZWaveJS server or ZWaveJSUI. That error comes from that service not starting… Probably because it can’t open your stick. You can only have one integration use a stick at a given time. If both are trying neither will be successful. Make sure you’re not trying to start a built-in ZWave integration and an external ZWave addon at the same time.

yes you are right, the key is not visible for HA, yet I see it in “system info” of Synology.

Where to find the path as you suggest ?
Currently I only see 4 “serial ports” offered by default in the Zwave setup


Only 2 containers are active (is this a problem ?)



There a well establish problem with Synology DSM 7.0 and zwave sticks. Google for that and you will find the solution.

1 Like

yes of course, I have already tried many proposals found but none have succeeded in resolving the impossibility of adding a “new integration”, Z-Wave, in HA.
I still receive the same error message: “Connection failed” with ws://localhost:3000
Maybe there is no solution…

Thank you all for your responses

Just for your information, the key works when I connect it directly to my PC with Domoticz. But I don’t leave the PC on all the time, hence the interest that would have been the connection to the NAS… Sad to see that there is no solution :frowning:

Did you do what @peterage suggested?

This link was in the top three of the search here on the community site.

thank you Nathan for this link (which I probably didn’t find because I wasn’t using the right words). But unfortunately that doesn’t solve the problem. Still unable to include “z-wave” with still “connection failed”

maybe there is an error in my attempt to correct it ?

here is the result concerning USB with the line proposed by kcsoft: “To test if the module is loaded:
lsmod | grep bt”

and with this another line, there is an error on the container terminal (maybe a mistake on my part ?) :
"You can verify that in the docker container:
docker exec -it homeassistant /bin/sh"


You need to create a script that runs at startup of the DSM to properly load the USB drivers. That is the first step:

/sbin/modprobe usbserial
/sbin/modprobe ftdi_sio
/sbin/modprobe cdc-acm

chmod 777 /dev/ttyACM0

Marius has a great videos that walks you through the process of setting this up in task manager.

Run lsusb -i before doing this and capture the output, then run it after the command runs and capture the output. Post that here.

The second step is to pass the device to the zwavejsui container, this requires some skill with docker to do. The simpler approach is to use the Synology UI to create the container and selec the box too run it at high privilege

The other option is to install the Synology Virtual Machine Manager and use that to run the HASSOS image - that is the simplest approach which may be easier to accomplish and does not require the script above.

I have already done the script mentioned, no visible difference
I have already followed Marius’ tutorial, without visible effect

here is the result of the command lsusb -i :


I see that the problem is mainly with the ‘serial port’ (probably linked to the USB driver?), when recording I always receive an alert message :


I installed the “zwave js ui” container in addition to the “zwavejs2mqtt”.
Should one be deleted ?

and why the “connection failure” message when I want to add a “Z-Wave” integration in HA?


I prefer to wait for VMM to have a dedicated NAS for it

You need to ssh into the Synology box and run lsusb from the ssh command prompt.

Ok, here is the command line response :


That 0658 device is the Gen5 stick, it is not configured correctly. Do this

sudo -i

Then run each of the lines from the shell script in my comment. The run the lsusb command again.

It should look more like this, you can see the cdc_acm driver is loaded and the device it mapped to ttyACM0

Also it looks like your device is not on USB 2.0 hub; which is one of the recommendations for this stick

thank PeteRage,

but :

where is my error ?

(you’re right it’s an AEOTEC Z-Stick Gen5+ key)
(Yes, I saw that a USB2 hub is recommended, I don’t have one at the moment)

Reconfigure the zwavejsui docker container to " Execute container using high privilegemode. This should be an option in the Synology docker ui

Note: that script must be run every time the NAS reboots. So I have it setup in the Task Scheduler to run as root and to run at boot.

yes, I did this “high privilege mode”
This is correct as far as the script is concerned, I also enabled running as “root” on reboot.

I will have a usb2 hub this Wednesday, I hope the result will be conclusive :wink:


Do not run zwavejs2mqtt that has been replaced with zwavejsui. Also please post your docker config.

ok, I deleted the mentioned container

what do you want to know about containers ?


no result with the addition of a usb2 hub…
There remains this “serial port” problem which seems to have no solution… :frowning:

Please post your docker configuration for zwavejsui - either take screen shots of each config screen including advanced or export the config and post that.

Ok PeteRage, is that ?