Zanzito - A lightweight bridge between your Android device and your MQTT/home automation system

I think using a list of SSIDs is a great idea. I would make it so that if it detects a given SSID that it doesn’t poll the location sensors and doesn’t send data. I would also do this when it detects the SSID and whether or not you are connected to it.

1 Like

That would burn more energy than what it saves: it means having the WiFi scanner always active… maybe not a good idea.

So, to recap: I would insert a list of WiFi SSIDs into Zanzito preferences and, whenever the device connects to any of them, it disables location tracking?
I mean: Zanzito remains connected for all other updates, is that right?
What do you all think?

1 Like


just show up in the notification pulldown but not show an icon

to get the back button action to not prompt to exit out of the app

It’s all done in Zanzito 1.2, see here

1 Like

Good point. I like that approach. If connected to a specified ssid then stop sending data but still be open to receive configuration messages.

Thanks, I really appreciate it.

1 Like

I start to have this problem

2017-07-24 22:34:41 ERROR (MainThread) [homeassistant.helpers.template] Error parsing value: ‘dict object’ has no attribute ‘users’ (value: {“message”:“You should insert fingerprints before tracking, see documentation”,“success”:false}
, template: {{ value_json.users.mi5splus[0].location }})

camera mi5splus:
  - platform: mqtt
    topic: zanzito/shared_pictures/mi5splus
    name: Zanzito MI5SPLUS Camera 

  - platform: mqtt_json
      my_device: zanzito/mi5splus/location

  - name: claudio_zanzito
    platform: zanzito
    device-name: mi5splus

It’s a FIND error: have a look at your FIND server status (via its web interface) and see if something is wrong there.

but is not enabled in zanzito.

I had find before I can’t remember my login … nowhere to get it from

as far as I can tell from the error message, you have somewhere in HA something that parses a location message from FIND, which in turns throws an error for not being properly setup.
I guess it is not related to Zanzito, but let me know what you find out :wink:


I started using the notifier component for Zanzito, thank you. I had a question about the config though, would it be possible to somehow pass a template to the device-name key? Something like the following?

─► grep notify: configuration.yaml; echo; cat notify/zanzito_jc.yaml
notify: !include_dir_list notify/

platform: zanzito
name: zanzito_jc
device-name: >
  {{ states('sensor.ha_jc_name')|lower() }}

I’ve abstracted personal information using secrets.yaml and have created a sensor with my name (which contains a capital letter), I then use my name as the device name which is also used with OwnTracks emulation. This may be a limitation of the notify component of HA and I’m just looking for other options.

Yes, as far as I know you can’t pass a template as a component configuration parameter in HA. I’m afraid configuration parameters validation is out of the hand on the single component, but I could be wrong…

If you haven’t already done so, why don’t you open another thread asking this question in general: there are a lot of people here that know the internals of HA far better than myself…


I didn’t know if it had something to do with the component but after I ran some tests with other components, I came to the same conclusion. Thanks! :slight_smile:

1 Like

So a really out of left field observation, but I noticed at times when I’m having issues with HA I tend to swear at it by name, Zanzito detects the keyword and spits back command not found. I thought for a quick half hour project I’d give it a bit more personality and write some activities/automations so that when I spout off and Zanzito detects it, HA would shoot back some funny responses through TTS. Because of this I found there’s a profanity filter in google voice that *****'s out parts of profanity even while it searches using the entire term.

No big deal. However, it turns out when you use a voice command in an activity that includes ***'d out terms, Zanzito encounters an error and shuts the entire app down. Not sure if there’s a workaround, or even a large need to workaround it, but I’m sure I’m not the only one swearing at my HA setup sometimes.

Wow, I didn’t know Zanzito could be so prude :smiley:

I could not reproduce this bug in in Italian: I’ll try in English later…


EDIT: maybe you could send me a PM with the exact profanities that trigger the crash? :smiley:

You can turn this off in the JSON

"profanityFilter": false

I think it defaults to true.

On your phone, you can set it from here:

1 Like

Had to grab a slightly more recent faq on removing blocked swear words, but that did the trick. Still very weird that it gave Zanzito such trouble. Pretty modest app you’ve got there.

1 Like

Would be nice if you linked that more recent FAQ… Damn it! LOL

1 Like

Sonofa… good point.


Literally LOL’d at your response. Thanks!

Thanks for a great app.

Would it be possible to set a prefix for the topic? Everything else is with service/something, except zanzito