Zeroconf error

I ran into a weird error resulting to some of my stuff not being recognised anymore.
Running latest stable on docker (raspberry pi4)

My logs show the following error:

2019-12-09 18:33:17 ERROR (MainThread) [homeassistant.setup] Error during setup of component zeroconf
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 176, in _async_setup_component
    component.setup, hass, processed_config  # type: ignore
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/zeroconf/", line 40, in setup
    zeroconf = Zeroconf()
  File "/usr/local/lib/python3.7/site-packages/", line 1817, in __init__
    self._listen_socket.setsockopt(socket.IPPROTO_IP, socket.IP_ADD_MEMBERSHIP, _value)
OSError: [Errno 105] No buffer space available

I only added a few docker containers and added the transmission integration through the integrations page… any idea why this is happening?

1 Like

Check out this thread

1 Like

Unfortunately the suggested docker prune command did not help. I have one more network than before, but that should not be a problem itself, or?

fixed this by increasing buffer size/multicast connection in /etc/sysctl.conf:

# Bigger buffers (to make 40Gb more practical). These are maximums, but the default is unaffected.

# Avoids problems with multicast traffic arriving on non-default interfaces

# Force IGMP v2 (required by CBF switch)

# Increase the ARP cache table

# Increase number of multicast groups permitted

You can also try this:


Nice, mark as a solution for others

This works for me as well, thanks!

For some reason it stopped working again for me and I got the zeroconf error again. I tried docker network prune as suggested in the other thread again which resolved the zeroconf error for me, but now hassio/homeassistant cannot find ANY chromecast enabled devices anymore… I’m a little bit lost here.

Should this be done on the host or in the docker container?

on the host system

Hi, the above worked for me and maybe others know this already but the file needs to be rebooted sudo sysctl -p or the system rebooted after the changes are made.


Worked for me. Thank you!

As a note, this error may actually be hidden behind a discovery “network is unavailable” error. My docker configuration suddenly starting spewing that error. I created an issue to document it in case anyone else sees it.


Post#4 fixed it for me as well. Ran sudo sysctl -p afterwards and restarted the espohome docker container. Bye bye error and hello dashboard status and available upgrades.

Was struggeling with this, my Google Assistant/Home and also Chromecast integration not working - this solution solved it all :ok_hand:

The sysctl values didn’t do it for me, but adding

  default_interface: true

to configuration.yaml and restarting the container got rid of the error. From the zeroconf integration page it was my understanding this makes it use only main ip instead trying to bind to which causes the issue under docker.

Since then I restarted the RPi twice for unrelated reasons and the zeroconf error hasn’t showed up.


this solved it for me as well, Thanks!

Helped me too. I guess the problem comes from Tasmo Admin. After disabling it and restarting the problem was gone too.

Hi There,
I got rid of this issue by using this configuration as well.
Thank you !

It’s fixed my problem too on raspberry pi 4

great, it works for me too! Thanks