ZHA Hue bulb integration zigbee issues

Zigbee stick: HUSBZB-1 USB stick
HA Versoin: 0.84.2 on HASS.io

Hi All
I’m just getting started with HA with HASS.io and i keep having issues with zigbee using the ZHA component. Right now i’m trying to connect hue bulbs which I was able to reset with a hue dimmer and originally I was able to connect one bulb then everything got screwed up and now I can’t seem to fix it.

I have three hue bulbs and a dimmer switch. I connected one bulb, and it connected correctly. Then I changed the name and ID using the gear icon when clicking on it within the front end. Then I tried connecting a second bulb which partially connected. It showed up in the front end but without the proper type (no color wheel or settings gear icon). Then the first bulb became “offline” and wouldn’t respond. Tried to connect a 3rd bulb and nothing would happen. I tried to remove all devices and reconnected them but when I reconnect them, it appears to pull data from the first time so it’s not fully deleteting the bubls from HA.

Anyone know if this is a Hue issue or a ZHA zigbee issue? It seems like whenever I try to rename a zigbee device there’s a high probability that it screws everything up. NOTE right now I can still control a couple other zigbee devices.

picture of the front end showing the living room hue bulb connected but not controllable.
Not sure why this is offline right now, The bulb is on and within 10 feet of the hub. Funny enough, if I were to “remove” it right now, the bulb would respond with a blink but right now the bubl doesn’t respond to on/off and shows “offline”.

showing the device status and here there is a gear settings icon

showing the light device, no settings gear icon is present and color wheel options are gone

showing ZHA integration page. NOTE: the second light and dimmer have been “removed” yet they still show up here. You can also see that the lights don’t show any kind of icon next to them.

So how do I go about clearing out these zigbee devices completely and try reconnecting the bulbs again to fix the problem? And is there a certain way you need to add zigbee devices and update their name to avoid these issues? Any help would be greatly appreciated! Thanks!

Currently in HA there’s no way to clean up device registry on device removal. For ZHA, if you don’t have the “zha device” entity, then you can consider it gone. To verify, you could run bellows devices -D /path/to/zigbee.db

  1. enable debug logging
  2. Factory reset the zigbee devices
  3. run zha.permit and join devices. Make sure bulbs are really close to HUSBZB-1
  4. collect logs and post it here, otherwise it is hard to say what could be wrong

thanks for the quick reply. I was able to get another bulb added successfully and it works as expected. But not the other bulbs that were already linked.

I’ve already tried resetting the bulbs and removing them using zha.remove. Once removed, I’ll restart HA, then run zha.permit and join the bulb. The problem is when the bulb re-joins, it automatically gets the name I had changed it to originally not the default ID name (even though I had “removed” the device) and seems to have the same problem once joined. It seems like a similar problem i had with another zigbee device when I first started, when I change the entity ID through the front end, it seems to lose it’s link to the actual device or cause some kind of problem.

As for logs:
These errors show up when I reset the bulb with the hue dimmer:

2019-01-04 20:26:18 ERROR (MainThread) [bellows.zigbee.application] Failed to parse message (b’004e0b0bb1b1b1b1’) on cluster 6, because 177 is not a valid Status
2019-01-04 20:26:18 ERROR (MainThread) [bellows.zigbee.application] Failed to parse message (b’00660b0bb2b2b2b2’) on cluster 6, because 178 is not a valid Status

The logs when I run zha.permit:

2019-01-04 20:29:09 INFO (MainThread) [homeassistant.components.zha] Permitting joins for 60s
2019-01-04 20:29:47 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py”, line 344, in _async_add_entity
raise HomeAssistantError(msg)
homeassistant.exceptions.HomeAssistantError: Entity id already exists: zha.zha_philips_lct001_024ff010. Platform zha does not generate unique IDs
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py”, line 344, in _async_add_entity
raise HomeAssistantError(msg)
homeassistant.exceptions.HomeAssistantError: Entity id already exists: light.philips_lct001_024ff010_11_LivRm1. Platform zha does not generate unique IDs
2019-01-04 20:30:01 ERROR (MainThread) [bellows.zigbee.application] Failed to parse message (b’00670b0bb2b2b2b2’) on cluster 6, because 178 is not a valid Status
2019-01-04 20:30:01 ERROR (MainThread) [bellows.zigbee.application] Failed to parse message (b’004f0b0bbfbfbfbf’) on cluster 6, because 191 is not a valid Status

Here are the logs when I try to turn on a bulb when the zha says it’s connected but the light doesn’t respond:

2019-01-04 20:20:45 ERROR (MainThread) [bellows.zigbee.application] Failed to parse message (b’00640b0bb3b3b3b3’) on cluster 6, because 179 is not a valid Status
2019-01-04 20:20:45 ERROR (MainThread) [bellows.zigbee.application] Failed to parse message (b’004c0b0bb4b4b4b4’) on cluster 6, because 180 is not a valid Status

It appears to be an HA naming issue. The only way I was able to go in and fix it was to go to the
/config/.storage/core.entity_registry file and change the entity ID names back to the default values and change the friendly name back to null. Once I did that and restarted HA, the bulbs started working without issues.

I tried to look at the file to see if there were any errors in the entity_registry but nothing stood out. All I changed was the ID and name, and boom it started working.

I am also using HUSBZB-1 with hue sensors and they keep going offline and randomly comes back online. Very unstable so far. Did you set the entity for zha to default or all binary sensors as well? Thank you.

No I didn’t change the entity names for ZHA, they were always their default names.

When the sensor triggers, does it come back online? I’d guess the sensors show offline if HA hasn’t heard from them in awhile and because they’re battery operated they probably don’t respond to updates requests from HA so HA probably changes it to offline. This is only my guess though.

Sometimes they come back online and other times they don’t. Also, I meant to ask if you had changed the binary sensor entity id and names? For my sensors, it registers 3 domains (zha, sensor, binary_sensor), i changed entity and name for sensor and binary_sensor. Wondering if i should reverse those changes.

Also, do you know if repeaters would work for these sensors to help with better signal? I thought of getting the Zigbee smart outlets to use as repeaters.


I do think repeaters work. I’m using a plugin zigbee device as a repeater for the hue bulbs to work.

My hue dimmer will show offline and still respond within HA so maybe the online/offline states aren’t accurate? In general i’m finding zigbee for me isn’t very stable. Not sure if it’s the ZHA component or zigbee itself.

Thank you for the information, I’ll try some repeaters and I hope zha improves in the next Hassio versions.

I got some hue bulbs and connected them easily. They also have similar issue of disconnecting. I only changed the friendly name this time. If I keep everything default, is there a different way I can over ride the name so that it has a good name to be able to use with voice assistant? Thanks.

I was able to change the entity name later. I don’t know why sometimes it seems to mess everything up though.

I finally decided to give up on the HUSBZB-1 controller as ZHA is not yet at its best with HASSIO. I got the Hue Bridge on Ebay for $30 and I am amazed how well the motion sensors work. They respond instantly with motion and sends accurate temperature and light levels to HASSIO so that I can automate. My Hue lights also works flawlessly. For anyone who is looking for some great all in one (temp, motion, light) sensor, I would recommend the Hue Sensors with the Hue Bridge.

That’s awesome to hear how well the hue hub works with HA. I gave up on my hue hub a while ago because it kept having trouble upgrading and still had issues connecting to some bulbs. about 50% of the time I would open the hue app, it would say the hub needed to be updated but fail ever time I tried. Now, new features are added but you need the new hub. I do agree though, ZHA needs to improve in HASSIO, hopefully it will. For now I’m not relying on it for any critical things like motion sensors. So here’s waiting and hoping!

A few months further down the track and I can tell you with Hue globes and sensors, you are better off using the Hue bridge. Hue have some interesting quirks that work best with the Hue bridge. Hue Sensors are now exposed via the API so you can see them in HA as well as in the bridge.
Xiaomi and TradFri (ikea) work better via ZHA than via there bridges. Especially with the TradFri one as the TradFri bridge is quite unstable in my experience.
Downside of the Hue API and sensors exposed is the 5 second polling time due to the way the API works. It means motion sensors exposed in HA do not have instant response like they do in the Hue App. For Temperature and Light, the 5 second polling cycle isn’t really an issue for most :slight_smile:.

I wanted to try and eliminate all bridges and have everything in HA, but for Hue it just is not reliable enough.

1 Like