ZHA locked up?

Okay so I bought 28 more sengled bulbs to change every light out in my house. I started to pair them tonight to home assistant using the HUSBZb-1. After already having 6 active bulbs connected and one removed from the network but still in the database I was able to add 6 more and then nada. Thinking it was a bad bulb I tired 6 more bulbs and still nada. I am trying to pair the bulbs maybe two feet away from the stick. I am still able to open the database and even control the 12 current bulbs but can’t add anymore. @rcloran is there a device limit?

Raspberry Pi
Home Assistant 61.1

Now that you mention it I can’t seem to get past 12 iris contact sensors. I saw #13 show it got paired but nothing showed up in the database or front end. Even after a restart and pairing the device in the same room as the controller. Device pairs fine with SmartThings though.

1 Like

Well for troubleshooting purposes I tried removing one of the 12 working bulbs from the network and still can’t get a new bulb to pair. Unless it isnt a device limit but a limit by type. I currently have 12 white smart bulbs (5 Philips and 7 Sengled) and 1 color Philips bulb.

1 Like

To test this theory I put back in my color light that I removed to put in a white. I can control all 12 white and the color. So it doesn’t appear to be a device limit but a type limit.

1 Like

No problems here. Running latest bellows from GitHub.

One thing you might want to be aware of is that the sengled bulbs are not repeaters. I also have had better luck physically turning off near by zigbee bulbs when pairing.

1 Like

How do I check and run latest version from github? Sorry I am a windows guy. I have been learning as I go. I’m going to try the physical turn off at least 7 and try again.

Here you go:

pip3 install --upgrade git+git://github.com/rcloran/bellows


Thanks after turning off all the lights and trying again after I first posted. I have almost paired all the lights I need for the house. Since everyone else is asleep I’ll wait until in the morning to put them up and test them all as a group.

1 Like

hmm I don’t have any lights hooked up to zha but I do have some Iris smart plugs, wonder if i need to unplug those and try the iris sensor again?

It is worthy trying.

Thank you for your help. I was able to install them today without updating bellows and they all work.

Tried to unplug all my switches and power down lights but still no go. Device says it pairs but nothing shows up in the db or home assistant :frowning:

Thank you for the install instructions to update bellows. I did go ahead and run it for another issue I am having as was up to date.

Glad to hear it helped.

You might also be interested in the fantastic work that @Yoda-x is doing updating bellows and the zha component. I’m running a copy in a test environment and it’s looking really promising. Currently it supports a lot of components that bellows does not, and adds LQI and RSSI to your Zigbee bulbs, so you have an idea on your mesh network coverage. For future releases, he is adding updating the state of zigbee bulbs – so if you manually change the power state of a bulb or restart HA the state is updated.

One of my experiences with my USB stick was, that it supports only 8 paired devices as default.
I have a qivicon usb stick flashed with some 5year old zigbee stack. https://community.home-assistant.io/t/eu-usb-sticks-for-the-new-zigbee-component/16718/10
You can easily increase the amount of supported childs with some lines in the bellows code I have now ~20 devices (bulbs, plugs, sensors) in my home.
I assume this restrictions depends on the used zigbee usb stick/device and the installed stack software.
These 4 lines made the difference for me:
yield from self._cfg(c.CONFIG_ADDRESS_TABLE_SIZE, 16 )
yield from self._cfg(c.CONFIG_NEIGHBOR_TABLE_SIZE, 16 )
yield from self._cfg(c.CONFIG_SOURCE_ROUTE_TABLE_SIZE, 32 )
yield from self._cfg(c.CONFIG_MAX_END_DEVICE_CHILDREN, 32 )
have a look in my bellows fork for details

I was actually able to install 31 lights (5 philips hue white, and 26 sengled). I still have a philips hue color paired as well but koto connected to anything.

Are you on version 0.61.1? Are you having any issues with ZHA losing connection and needing to reboot HA to get it back?

Is there any way to use your bellows fork if I’m running hassio? Custom components folder or something? Thanks for all of the zigbee work you’ve done by the way!

Yes I am running 61.1 and not having any issue with locking up.