ZHA Xiaomi Aqara Vibration Sensor Settings

Hello, I have a setup of Hass.IO on Raspberry 4 with ZHA. On this network I have the Xiaomi Aqara vibration sensor, and this have settings for sensitivity:

How can I change this setting on ZHA? I´d rather not change to Deconz or Zigbee2mqtt… :expressionless:

1 Like

Under configuration -> ZHA
Select the device, probably (LUMI lumi.vibration.aq1)
Select VibrationBasicCluster (in)
Then select the sensitivity attribute
Put 1 for the value and 4447 for the manufacture code
Then choose set ZIgbee attribute


Thank you! :slight_smile: This is swell!

What is the values for low, medium and high? Is that 1,2,3 or similar?

Another question, how do you know to put 4447 for manufacturer code? Is this documented somewhere?

I think it was figured out from the smarthings code…

1 - high, 11 - medium, 21 - low for values from that.


Thanks for the help. I will try to apply these settings next time I am on the location. This sensor is in my boat, which is on the hard for the winter. To apply this setting I think I need to wake the sensor.

Woohoo! A whole new area of ZHA I hadn’t even discovered! Thanks!

Let’s see whether I can make mine detect the operation of my washing machine now…

1 Like

1, 11, and 21. Is this a scale where I could set it to say 7 for medium-high, or will only those values work?

I believe it’s only the set values

Out of curiosity, I set it to 7 to see what would happen. 7 definitely works as far as getting detection vs clear, however I have no idea how to accurately test if its really using a sensitivity between medium and high, or if it set it to the closest one to my number.

Did anybody try this? I’m getting a message send failure when trying to read the current sensitivity setting. I did make the sensor awake before sending though. I’m using Conbee II USB. Home Assistant Core 0.106.2 in a Python venv.

Mar 05 17:24:12 raspi4 hass[12391]: 2020-03-05 17:24:12 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.2565641904] Error handling message: Unknown error
Mar 05 17:24:12 raspi4 hass[12391]: Traceback (most recent call last):
Mar 05 17:24:12 raspi4 hass[12391]:   File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/websocket_api/decorators.py", line 20, in _handle_async_response
Mar 05 17:24:12 raspi4 hass[12391]:     await func(hass, connection, msg)
Mar 05 17:24:12 raspi4 hass[12391]:   File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/zha/api.py", line 576, in websocket_read_zigbee_cluster_attributes
Mar 05 17:24:12 raspi4 hass[12391]:     [attribute], allow_cache=False, only_cache=False, manufacturer=manufacturer
Mar 05 17:24:12 raspi4 hass[12391]:   File "/srv/homeassistant/lib/python3.7/site-packages/zigpy/zcl/__init__.py", line 230, in read_attributes
Mar 05 17:24:12 raspi4 hass[12391]:     result = await self.read_attributes_raw(to_read, manufacturer=manufacturer)
Mar 05 17:24:12 raspi4 hass[12391]:   File "/srv/homeassistant/lib/python3.7/site-packages/zigpy/device.py", line 187, in request
Mar 05 17:24:12 raspi4 hass[12391]:     self.nwk, dst_ep, cluster
Mar 05 17:24:12 raspi4 hass[12391]: zigpy.exceptions.DeliveryError: [0xda13:1:0x0000]: Message send failure

That looks ike a delivery error. I’d try again, but keep pressing the button every 5 seconds, it may have gone back to sleep.

1 Like

Thanks @PrairieSnpr. After trying several times the way you suggested it indeed worked. It’s a bit tricky though.

Are the details still accurate here? I don’t see VibrationBasicCluster anywhere in the device config. I’m going to Configuration > Zigbee Home Automation (at the bottom of the config page). Then selecting my device and I see this:


nevermind, I see how it works now!


Found this thread because i found myself in the same situation with useless sensors… i REALLY wanted them originally for the washer/dryer in my condo… but I don’t know what’s up with these things, but it takes a 7.0 earthquake to keep them active…

Note: I have a stacked side-load washer and dryer

so… since these sensors are cheap, i was annoyed, i just grabbed some double sided tape, mounted it INSIDE the dryer on the backend of one of those tossing fins, and amazingly it worked… worked for over 10 loads… the heat in there doesn’t seem to fry it.

Now, i cant speak for everyone’s dryer temperatures, so try this at your own risk if you simply don’t care about them.

After the dryer thing worked, i figured why not try the washer too?
Put the sensor in 3 double-seal ziplock freezer bags, duct taped it up, double sided tape to the drum against the tossing fin. And yup, did 3 full loads tonight and it worked just fine. With side load washers they don’t fill up with water anyways, just 2-3” at the bottom, so it wasn’t submerged.

I did have too add some timed triggers to my node-red flows, because in the dryer, sometimes it lost signal for a minute or so, but that’s it.

So if you don’t really care too much about your sensors, give it a try.


My washer/dryer do not vibrate enough; sign of well-balanced appliances.
So I tuya-convert’d some cheap smart plugs with power monitoring (bn-link) and trigger laundry automations off power consumption.
With power consumption, I can tell the difference between wash and spin cycles, for example. Just graph in Grafana to learn the wattage levels.

Yes, mine didn’t either. That stupid proof of concept above definitely isn’t a practical one. Since then, I’ve added a plug power watt sensor for the washer (as you did and I monitor the output and automate based of those levels) and as for the dryer, since mine is a 240v plug type, I couldn’t do the smart plug thing, so for that I went basic with a window/door open/close sensor (those magnetic ones) and stuck it to the dryer dial. When the dial reaches the top and it’s done, it closes the sensor. Simple, but effective.

1 Like

Thank you for this. I was trying to use one on our dryer and I swear the default setting is set to “detect asteroid impact/extinction-level event only.” To me, at least, a “vibration sensor” should pickup even a small vibration!

1 Like

My Aqara Vibration Sensor keeps false triggering or the sensitivity is too high. I’ve tried reducing the sensitivity to 21, but it’s still false triggers. It’s possible that the change of setting didn’t ‘stick’, but I’m unable to read back the setting because selecting ‘Get Zigbee Attribute’ doesn’t work.

Have you figured this out? Did you make sure the device was active when you were trying to read back the setting?

Thanks for the reply ‘val.dipietro’.
I subsequently found the device unresponsive. I re-paired it and saw that the battery was low - so I’ve changed it. Having changed the battery I still can’t read back the sensitivity setting, even immediately after triggering the device.