ZHA Zigbee Tested Devices...Please add your device results

check logger component configuration. You’d want something like

  default: info
    asyncio: debug
    homeassistant.core: debug
    homeassistant.components.zha: debug
    zigpy: debug
    bellows: debug
    zigpy_xbee: debug
    zigpy_deconz: debug
    zigpy_zigate: debug

in your configuration.yaml

Thank you,

I knew it was an addition to the configuration.yaml I just wasn’t sure exactly what to include. I will give this a go

I just looked at one of the lights that lost communication, it was on the 2nd floor in a bedroom directly above my HA machine


I have now enabled debug logging to see if I can catch something

The Osram Lightify Bulbs have a known firmware bug that makes them really un-reliable as repeaters. I’have got a bunch of them and I’m trying to phase them out of my set up as they cause a ton of network instability.

See the blurb at the bottom of this page…

one option I saw on the smartthings forums is to just make sure they are the last devices added to the network to try and minimize their role as repeaters.

1 Like

Hmm that is interesting. I have a couple of spare Ecosmart bulbs I can switch out and try. I only have the 2 Osram RGB bulbs

The Osram Lightify Bulbs have a known firmware bug that makes them really un-reliable as repeaters. I’have got a bunch of them and I’m trying to phase them out of my set up as they cause a ton of network instability.

Same here. Very frustrating - everything else on my network is locked in and works great. The Lightify bulbs keep dropping off.

Do you (or does anyone) have a recommendation for affordable Zigbee bulbs that work solidly as repeaters? Both RGBW and dimmable 2700K white options would be nice.

I’m after bulbs that retain their last state, or can be configured to a default state when power is lost. Mainly because my wife wants a non-standard temp of white but isn’t on-board with not turning off the knobs on the lamps.

I imported some innr bulbs from the UK and the ones that work are great. They are starting to bring bulbs to the US and have some listed on amazon, RGB coming later this year.

I’ve also started trying the newer Slyvania Ledvance bulbs (I think these are branded as the zigbee smart+ line), which is a bit confusing as they are now a different company than Osram, the rgb bulbs I’ve tried have been pretty stable, and are strong repeaters. They have fallen off my network a few times, but I still have the crappy lightify bulbs in play and as I’ve reduced those the network has gotten more and more stable.


Sorry for the ping but was wondering if you happen to know how to prevent this remote from “sleeping”

it’s goes offline while it sleeps and once you tap a button on it, it takes about 5-10 seconds to wake up and preform the action.

Also, do you happen to have a ZHA discord? If so, what is the invite code?

@CauseFX Zigbee channel on HA discord.

the devices are designed to sleep. There are some quasi polling changes in .98. If that doesn’t help we can look at alternatives.

thanks for that. I see the channel now.

Osram Lightify Bulbs are probably one of the worst smart-home investments I’ve made… and I’ve bought a lot of junk over the years :neutral_face:

@CauseFX I recently picked up some Ikea Tradfri bulbs that I am going to try with ZHA when I get the chance. I think they support last state power on with one of their firmware updates, but someone correct me if I’m wrong…

I’ve finally removed all my Lightify (Osram) bulbs and replaced them with Sylvania Smart+ (Ledvance) bulbs or innr bulbs, plus a pair of old wemo bulbs. I’ve seen a gradual improvement of my zigbee network as the lightify bulbs were removed. Optimistic that now things will be a lot stabler with them all gone!

Hi , have you figured this out? Is Ikea remote switch 5 button version now working?

Thanks for the heads-up on Innr and Ledvance. I just replaced three Lightify bulbs with one Hue and two Cree – let’s see how it goes!

nope direct binding and also being able to use the left and right buttons in an automation still does not work for me in 0.98

Hooked one of the Ikea 5 button remotes up to see. You need to specify args in your automation to get left and right to work properly. Have this working in node-red.

UP button - event command “step_with_on_off”
DOWN button - event command “step”
CENTER - event command “toggle”
LEFT - event command “press”, event args “1,1,13,0”
RIGHT - event command “press”, event args “0,1,13,0”

And long press? Is that working? I still use deconz now, not zha, just want to know if it will work

Also, do you need to enable debug to see this?

Will check long presses when I get home tonight, forgot about that one.
No, you can just subscribe to zha events (developer -> events --> subscribe area) to see the different parameters for each button press.

Cool, keep me posted… If that works, I gonna change also do zha , now using deconz…
Is there a way to see the mesh with zha ?

Looks like it registers a hold of every button properly, with different args for them. It registers press, hold and release hold of all the buttons except the centre button, which just registers the press and hold (no release from hold)
I don’t believe there is any way to view the mesh with zha.

Also, for whoever above was asking for bulbs retaining state, I check with the latest firmware on the ikea tradfri colour bulbs and they remember their colour settings with power off but don’t keep the state (ie, always turn on with mains but to the last colour setting (not off like hue does)