Zigbee2mqtt and IKEA Remote control N2

Hi i have at problem connecting IKEA Remote Control N2.

i´m using Zigbee2mqtt

I get the Support status “Unsupported” and under Exposes it says “Device doesn’t expose anything”

I keep get the same error with both my IKEA Remote Control N2.

How can i fix this ?

Is it listed on the official zigbee2mqtt page? :point_right: zigbee2mqtt.io | 📘 Zigbee2mqtt documentation

If it is: remove device and try again until it’s recognized. If it’s not listed there, then the device is not supported so it will never work unless zigbee2mqtt adds support. See this to ask for new device support :point_right: How to support new devices | zigbee2mqtt.io

P.S. You could have just asked this in the long going thread instead of creating a new one with a single question :point_right: Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI). You’ll have higher chances of finding others that use this device there as well, which allows others to be informed as well.

1 Like

Sorry but:

Do i have to do anything after parring this device, i newer had a problem like this before.
I have already bee reading a lot of information, but nothing have helped me in the right direction.
Including the link you provided me with.

Did it pair already successful ?

It pair but still with the message unsupported.

I have paired it more than 30 times, each time i see it in Zigbee2mqtt.
But if i try the buttons out i get fault messages + link to an url than doesn’t help me.

Warning Received message from unsupported device with Zigbee model 'Remote Control N2' and manufacturer name 'IKEA of Sweden'

Warning Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.

Try to pair within 5 cm of the coordinator.

By the way: what coordinator are you using ?

I have tried that already ,read it in another tread where you suggested it :slightly_smiling_face:

I´m using the one you told me to use some time ago :slightly_smiling_face: :slightly_smiling_face: Conbee2 and it is on latest firmware.

The only thing I find is this :

Make sure your Conbee2 has the latest firmware, and else open a ticket on https://github.com/Koenkk/zigbee-herdsman-converters

1 Like

I think this is the problem, thanks a lot for your effort .




Here is dokumentation if someone else should have same problem.

Thanks francisp

For me that’s not working!
I updated my ConBee 2 with the newest FW but still the device is not supported :frowning:

Anybody an idea?

Btw…mine are W2049 & W2051. None of them is working

I don’t think there ist fixed yet.
We have to wait until the “new” contact will be supported by zigbee2mqtt.

Hi Ole

Thanks for your reply.

I thought some ppl got it up running. Anyway they’re on the market for a while now, so I wonder when this will be.

There also is the possibility to connect unsupported devices.

But I don’t understand how and where I can do this… :confused:

Ok. I managed to “support” the device, by putting all relevant data in the file device.js.
Unfortunately that’s apparently not everything has to be done, cos I get error messages configuring the device. Also no commands will be sent.

Any idea how to solve that?

EDIT: I managed to make it work! After many attempts I simply uninstalled zigbee2mqtt and reinstalled it - DONE! Now it´s working!!!

Sorry i am still to new to this to help you there, i wish i could :slightly_smiling_face:

hi did you get this working ?

I was having the same issues then discovered that the repo had changed for z2m.

I added

https://github.com/zigbee2mqtt/hassio-zigbee2mqtt

to the add ons page repos and copied the config from the old one (1.18) and stoped it then pasted the config into the new one (1.22) and it all came back and the E2001 was discover and all is working.

hope this helps

No sorry no fix yet

Having the same problem. The zigbee2mqtt page says it’s supported but I keep getting the same errors as you do.

Having the same problem. The zigbee2mqtt page says it’s supported but I keep getting the same errors as you do.
Using: CC2652RB Zigbee Controller

Also, Ikea blinds are recognized and I have all the options except to move the blinds…