Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#1365

Now i was wondering this myself and did find a couple of DIY zigbee projects, but didn’t get very inspired by what I saw.

anyway, what I found was via google :slight_smile:


#1366

looks like it’s ok with cc2530

Setup the relay/Contactor, and button:
Connect relay 1 control pin with P1.0, relay 2 with P1.1, relay 3 with P1.2, relay 4 with P1.3,
Connect your button 1 with P0.0, button 2 with P0.1, button 3 with P0.4, button 4 with P0.5


#1367

Keep us updated if you try this out


#1368

My Xiaomi Aqara wired double wall switch (no neutral) shows as a switch. Is there anyway to change this to a light without using a Template?

Thanks


#1369

Without fixing the root cause, you could use this: https://www.home-assistant.io/components/light.switch/


#1370

hey all. After using hass.io with zigbee2mqtt on a rpi for months without any problems, I have decided to move over to a pc running ubuntu. I decided I wanted to stay with hass.io for it’s simplicity and add-on store. Now I did a fresh install of hass.io and installed the zigbee2mqtt add-on. It starts, connects to the cc2531, so far so good…

untill I want to pair my devices. With everything I try to pair (Ikea light bulbs, Xiaomi sensors etc) I get the following error:
PM Cannot get the Node Descriptor of the Device: 0x90fd9ffffe1fac14 (Error: Timed out after 10000 ms)
So the docker image is able to communicate with the CC2531 USB because it does read the devices, but for some reason it’s not able to actually pair with anything.
Help!!


#1371

Do you have this working with zigbee2mqtt or are you using the Xiaomi hub?


#1372

EDIT scratch that, this supplier is hopeless, said they had no black stock and said could they send silver, I said yes and yet they cancelled my order saying they were out of stock. And they are still advertising it for sale.

Thanks for the link to the enclosure. The Amazon site you point to doesn’t seem to have stock at present, but I found something that looks identical in AliExpress. Adding a link here for anyone interested.


#1373

Yeah I am :grinning:


#1374

@Eeeeeediot that was not a yes or no question :wink:

zigbee2mqtt or xiaomi hub?


#1375

Hahaha, of course zigbee2mqtt!


#1376

Hey sorry for the late reply, still need this?


#1377

Is anyone able to add support of a new device for me if I provide the database info? Is this even possible. I tried following the docs but can’t ash into hass.io and the rest seems complicated to say the least!


#1378

Hi @h4nc have you come across any decent guides for a C2531 antenna mod? I’ve found a couple but they weren’t that great, the best being this really (but still not all that easy to follow)


#1379

I could not describe it better than in this link. I think the pictures there should explain everything.


#1380

True, I had a second more detailed look after posting the link and it’s not too bad really. I’ve got 4 CC2531 on order (they’re so cheap!) so will certainly give it a go.


#1381

Hey guys,

One of my Xiaomi Zigbee smart plugs has stopped reporting power consumption, any ideas?

zigbee2mqtt:info 2019-3-5 04:08:28 MQTT publish: topic ‘zigbee2mqtt/0x00158d000249693d’, payload ‘{“state”:“ON”,“linkquality”:94}’

Below is what the rest of them show:

zigbee2mqtt:info 2019-3-5 04:26:33 MQTT publish: topic ‘zigbee2mqtt/0x00158d0001b1987f’, payload ‘{“state”:“ON”,“power”:0.85,“voltage”:null,“consumption”:81.04,“temperature”:41,“linkquality”:92}’

Thanks!


#1382

I have a very similar case! Added a Xiaomi movement sensor yesterday and it reports movement detection as well as illumination, but no value for battery.

It works perfectly for all 3 parameters on another (exactly the same) added a few weeks ago.


#1383

I think the battery state takes a while to show up.


#1384

Thanks h4nc! You were right. Late this morning all of a sudden it was there!