Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#1405

I have been using hass.io and zigbee2mqtt now one month and everything has been working fine. Yesterday I tried to add cc2531 router to my network but I realized that I had already 16 devices connected to zigbee2mqtt and nothing happened when I tried to add router (cc2531 memory full?). Then I did remove two devices (Osram smart plugs) using zigbee2mqtt/bridge/config/remove and removed them from the database. However, this did not allow me to pair new device, I did then reset one the existing xiaomi sensor and tried to pair sensor back but nothing happened. No errors or anything in the logs just the data from the paired devices. So is there something I could do to get the pairing working again or do I need to reflash the cc2531 and start pairing from the beginning. Pairing first the router(s) and then the sensors so I can pair more than 16 devices.


#1406

Maybe you should open an issue on github. Could also be an issue of an older firmware of your stick. I read something about automatically reconnecting already removed devices somewhere. But I think that was an issue of a router firmware.
I could/might be wrong, so don’t take this as a fact. Koenkk will know better.


#1407

I will check the firmware and if it is old I will reflash the router stick with the coordinator firmware and first pair my Xiaomi bulb, which also act as router and some other sensor for test. If this works I will repair my devices and then reflash the working cc2531 as router. If the firmware is up to date I can open an issue on github.

The final solution is to buy the Xiaomi bridge if I cannot get this working.


#1408

Switched to zigbee2mqtt and extremely happy about it! Just a question about the max number of devices: when moving away from the Xiaomi gateway I first moved all the “wired” devices - 5 Xiaomi switches (with neutral line) and they all are described as Routers in z2m logs. Then I started pairing all other sensors (20+ devices in total located all around the house, always initiate pairing close to the nearest router to try to avoid pairing with the coordinator itself). What’s the maximum theoretical number of devices that I could use in my case? I.e. I’m still in the process of migration and haven’t hit the limit yet, but wondering if I should start being worried any time soon :slight_smile:
I’m running z2m docker dev-latest image (and Jan 2019 firmware).

Konstantin


#1409

See https://www.zigbee2mqtt.io/information/FAQ.html

Last question


#1410

Thanks! I saw that response but it doesn’t explicitly answer the question of the absolute maximum number of devices in case of many routers in the network. I.e. in my case of 5 routers does it mean that if each can accept 20+ devices then the whole network could be 100+ or if a router joins a router which is already connected to a router (not sure if that’s even possible :))


#1411

One question to the switch and wall button users.

I’m really happy with my huge z2m network with about 40+ devices.
But I’m wondering how do you deal with buttons and switches.

I mean for example the wall switch Xiaomi WXKG02LM
I have two entity states
click - LEFT
click - RIGHT
I can make my automation like
If state click-LEFT do something.
My automation works but afterwards the wall switch entity retains the state to click-LEFT for more than 30minutes.
If i click againg the click - LEFT nothing happens.

The same of course with my pushbuttons Aqara WXKG11LM
single-click / double-click / triple-click

Whats my mistake??! :smiley: :see_no_evil:


#1412

This http://www.zigbee2mqtt.io/integration/home_assistant.html

search for “Respond to button clicks” in that link.


#1413

Use MQTT to read the messages in the topic of the remote


#1414

Hahaha!!! I’m SO stoked!!! Thanks a lot!!!

I’m suffering for months now with this topic!
I already tried to force a entity state change with external python scripts but it’s so much easier
THANK YOU SO MUCH!!!


#1415

I reflashed cc2531stick but kept the database. Almost all of the devices did connect automatically and I can now pair more devices. I think there was still some data left in the cc2531 stick because reflashing solved the issue. Now I have one coordinator and two routers and 22 devices connected.


#1416

Did check or uncheck the “retain ieee” box in the flash software. Read somewhere that this is responsible for the data.


#1417

Hi all.
After upgrading HA from 0.87 to 0.89, I experienced some degree of instability of zigbee2mqtt.
I have one coordinator, two router pens and four Ikea tradfri lamps on a Raspberry 3b under hassbian.
Some lamps become unavailable without notice, and I am forced to reboot again the system to regain control.
Anyone else ??


#1418

“Retain IEEE address…” box was unchecked, but everything works fine.


#1419

Looks like it makes no difference, if check or uncheck that box. @Koenkk could you enlighten us/me?


#1420

See https://github.com/Koenkk/zigbee2mqtt.io/pull/29#issuecomment-470254897


#1421

ok, so this means, it makes no difference right?


#1422

yes, I didn’t see a difference yet.


#1423

@Koenkk, thanks for great and useful (hate see my data going to China via his gateways) add on, but I have trouble installing it on hass.io + RPi 3B+: Can’t install dwelch2101/zigbee2mqtt-armv7:1.1.1 -> 404 Client Error: Not Found (“pull access denied for dwelch2101/zigbee2mqtt-armv7, repository does not exist or may require ‘docker login’”)

Detailed log:

19-03-08 19:00:10 INFO (SyncWorker_12) [hassio.docker.interface] Pull image dwelch2101/zigbee2mqtt-armv7 tag 1.1.1.
19-03-08 19:00:12 ERROR (SyncWorker_12) [hassio.docker.interface] Can’t install dwelch2101/zigbee2mqtt-armv7:1.1.1 -> 404 Client Error: Not Found (“pull access denied for dwelch2101/zigbee2mqtt-armv7, repository does not exist or may require ‘docker login’”).

Any ideas what is wrong?

EDIT: Similar topic: Error while trying to install zigbee2mqtt on Hassio


Error while trying to install zigbee2mqtt on Hassio
#1425

@frenck already created pull request with the fix: https://github.com/danielwelch/hassio-zigbee2mqtt/pull/124 :slight_smile: