Zipato Bulb 2 RGBW


#1

Recently I purchased a Zipato Bulb 2 which can dimm and also change the rgb colors but I seem to have some problems with it.

At first once I included it Hass.io does recognize it but I could only turn it on/off and dimm as well. The color wheel would not even show up once I clicked on my entity in the UI. Only after a couple of reboots then Hass.io showed me the color wheel. But even now once I select a few colors nothing even happpen, the bulb just stays on the factory white default color even when the color changes on the UI.

I hope someone can help with this. Currently running Hass.io 0.73, openzwave 1.4.2926


#2

I just got the same bulb and set it up a few hours ago (hass 0.73.0), and have been having the same issues. I did a bunch of research and found two other forum threads (here and here) and a github issue about the problem.

I haven’t looked into the code enough, and don’t know about open-zwave enough, to tell where the bug is, but I’ve found a workaround for this:

  1. Navigate to the “Services” developer tool (/dev-service).
  2. Select light.turn_on as the service
  3. Select your light as the Entity. I only have one of these, so it showed up as light.zipato_bulb_2_level.
  4. In the Service Data section, specify the following JSON, making sure to include the correct entity_id:
{
  "entity_id": "light.zipato_bulb_2_level",
  "white_value": 0,
  "rgb_color": [255, 0, 0]
}

That should turn the light red. This seems to confirm what I saw in one of the other forum threads, that for some reason the light needs to receive an explicit white_value of 0 in order for the colors to work. You can play with the rgb_color value in that JSON to get different colors. On mine at least, setting rgb_value to [255, 255, 255] gives white.


#3

Thank you jantman,

I already played with the dev-tool before but I forgot to turn off the white_value to zero. Everything now works as aspected and I can use the color wheel now. Even so, when the power is completly off the bulb remembers the white_value is set to zero.


#4

hmm, for some reason this is not working for me.
My bulbs dont seem to reacto to Whitebalance nor color at all. I remember it working once way way back. thats also why one of my bulbs is very whitisch while the other one still has a warm color tone. I never managed to turn it back to normal.
Dimming work fine though.

any ideas?
using hass.io 0.77.3


#5

Hi there,

like for @achmed20 dimming and switching works fine for me but neither white balance nor rgb color work, no matter if I explicitly set white_value to 0.
Any ideas?

using hassio 0.81.0


#6

Same here I am only able to dimm


#7

Did anyone find a solution to this issue? The workaround doesn’t seem to fix the issue. I have been running 0.77 and now 0.81.2, I see the same behaviour. Turning on/off and dimm work only.


#8

I am trying to get help from OpenZWave on this issue if you are also having the same problem please join or follow this


#9

I got mine finaly to work by removing the <CommandClass id="51" colorchannels="31" > </CommandClass> from RGBBulb2.xml
here are the commands for hassbian:

sudo service [email protected] stop
cd /srv/homeassistant/lib/python3.5/site-packages/python_openzwave/ozw_config/zipato
sudo sed -i.bak -e ‘24,25d’ RGBBulb2.xml
sudo rm /home/homeassistant/.homeassistant/zwcfg_*.xml
sudo service [email protected] start

(If it is not woking allow it some time to start and then restart again.)


#10

Are you using Hassio? Or else, where can one find the directory where you can put and edit the RGBBulb2.xml?


#11

Yes the I can change color.
I am running Hassbian not the Hassio version.


#12

Ok so…does anyone know where to place the edited rgb2.xml file using hassio? Otherwise for those using hassio the problem is still alive and the case on github might need to be open again…


#13

open-zwave have been updated on github I don’t know how long it takes for it to make it to in to hassio


#14

Get this errors:
Invalid service data for light.toggle: extra keys not allowed @ data[‘white_value’]. Got ‘0’
ERROR (MainThread) [homeassistant.core] Invalid service data for light.toggle: extra keys not allowed @ data[‘rgb_color’]. Got [255, 0, 0]

Invalid service data for light.toggle: extra keys not allowed @ data[‘rgb_color’]. Got [255, 0, 0]

Any solution? Can not change temperature or color. Hassio 0.82.1


#15

Well I went changing my setup, installed Hassbian this time and edited the rgb2.xml like you did and now my colors are working again. Thx VMG for posting this here and on Git as well.

Further more those running Hass.io one can try to use zwave.update_config inside the dev tool. To me it seems it will update hassio to use the newer zwave config files from git bit some how it did not work for me or the new rgb2.xml has not been pushed into the newer zwave config branch…but im no expert on this tho.


#16

Have tried that and still no color


#17

can you post your RGBBulb2.xml file here?
It should look like this one https://github.com/OpenZWave/open-zwave/blob/7263e90b892fb835cea25aa857d02909a0e05ffd/config/zipato/RGBBulb2.xml
Also I am curious what the date-code on the bulb is


#18

Do not have this file


#19

If you dont have it then its logical it does not work…you either get the rgb2.xml from Git or you edit the .xml file inside your zwave folder. Secondly it’s important to stop home assistant first before you edit the config xml file and also you need to delete zwcfgxxxx.xml file too before you reboot your host system.


#20

This file is implemented long time, they said. Still tried it, still no color