Zwave Entities require 2 Toggles to Turn ON/OFF in HA

Hi Everyone - Hoping to get some help.

Recently got Nortek Zwave/Zigbee HUB and connected to my HA VM (Proxmox)

Nortek is working and I’m able to connect with Zwave devices (Inovelli Red Dimmer).

I connected a Leviton DZS15-1LZ Switch that I was using with SmartThings but trying to move things away from Cloud.

I’m able to use the Leviton but having problem with LoveLace UI and properly reflecting the state of the Switch. Here is what I’m encountering:

  • Starting with the Switch Off.

  • Clicking toggle turns (via Lovelace) Switch turns ON (light comes on) and toggle briefly moves to ON but moves back to OFF after a couple of seconds.

  • Clicking toggle ON again (via Lovelace) leaves Switch ON (no change) but now moves toggle to ON and stays there.

  • Clicking toggle OFF (via Lovelace) now turns Switch OFF (light turns off) and toggle briefly moves to OFF but moves back to ON after a couple of seconds.

  • Clicking toggle OFF again leaves Switch OFF (no change) and now moves toggle to OFF and stays there.

Here is a quick GIF of what I see:

Any ideas why it takes 2 toggles for state of this Leviton switch to be proper in Lovelace?

Also when manually operating the Switch the Lovelace toggle does not Change.

Appreciate any help. Thank you!

1 Like

Does the actual light behave the same?

Seems like your device isn’t reporting the state back.

1 Like

I have the same issue quite often. Restarting HA fixes it. It’s not the device, it’s the software.

I’m new to HA, but not Z-wave or X10, I have been running home automation with X10 for 30 years, and Z-wave for about 20 I think… don’t have that written down.

Many weird things in HA still as compared to HomeSeer which I used for years.

I finally got pissed at HS because they would lock out some competitors’ hardware, and did not handle my Z-Uno device, but HA still needs to improve.


I have the same experience. Toggling a light off shows it turning off then back on a second or two later. So you hit the toggle again, and again, and eventually it stays off.

HA_Steve came up with the explanation and a workaround a few years ago; I can’t find the original post, but here’s what I saved:


Basically, HA sends out the command, and the target device starts to make the change. Then HA polls the device, but before the change has actually finished happening. So it gets the “wrong” state and displays it in the GUI. The light shows “on” even though it is “off”. So you hit the toggle again, which turns it on. Again. Again…

This happens with devices that don’t report state, so HA tries to track state by polling, but apparently only once and too soon for the poll results to reflect the new reality. I’m not sure this is what’s happening to you, but it sounds like what happened to me.

The fix is to set refresh_value: true for such devices, and set delay: 2 so HA doesn’t poll until the remote device has finished executing the command.


1 Like

Thanks. Can’t see your picture you uploaded

Do you have examples of where you but those settings in config files?

Appreciate the guidance I will try it when I get home.

Sorry about that; I don’t know why the image isn’t working. It shows says to add the following to configuration.yaml:

     usb_path: <whatever...>
               refresh_value: true
               delay: 2

This was from 2018, so I’m not sure if it’s still the right way with the latest ZWave mechanism. The key is to get HA to do a refresh for each device you have that doesn’t report state changes, and set the delay long enough so that the device has changed state before it gets polled. For some devices (dimmers that slowly ramp up/down) that may be longer than 2 seconds.

The devices that need this are those that don’t send status messages because it would violate a patent to do so. I have a bunch of old GE/Leviton/Jasco switches and dimmers that unfortunately behave that way. You need that code snippet for each such device.


I’ll have to try that, but it does not explain the case I have, where it stops happening after a restart, and then eventually some devices start doing this. It seems to me more of something messing up the queue of commands.

Thanks but it doesn’t look like that will work for me.

According to Zwave config info for HA, those settings only apply to light integrations:


My switch comes up as a Zwave switch entity:


Thank you anyway!