0.84: Cloud webhooks, Wunderlist and USGS Earth Quakes


#142

Good luck…!
start with 1 and Refresh…


#143

I’m using the GUI editor so no need to refresh. But yeah… raw mode and just one to start!


#144

OK… just dumped raw config to a file and did a search for id: and deleted the lines then pasted back in and all seems well…


#145

I’ve noticed that in this version entities cards which contain only sensors are showing the header toggle switch unless the show_header_toggle option is set to false. This was only happening previously when there are switches in the card. Has something changed?


#146

Just updated to the latest docker image and it states 0.84.5 not 0.84.4.


#147

0.84.5 is the latest, although not mentioned on the website.


#148

On 0.84.5 I get this for Harmony:

      File "/usr/src/app/homeassistant/helpers/entity.py", line 221, in async_update_ha_state
        await self.async_device_update()
      File "/usr/src/app/homeassistant/helpers/entity.py", line 347, in async_device_update
        await self.async_update()
      File "/usr/src/app/homeassistant/components/remote/harmony.py", line 203, in async_update
        await self._client.get_config()
      File "/usr/local/lib/python3.6/site-packages/pyharmony/client.py", line 205, in get_config
        'vnd.logitech.harmony/vnd.logitech.harmony.engine?config'
      File "/usr/local/lib/python3.6/site-packages/pyharmony/client.py", line 158, in _send_request
        await self._perform_connect()
      File "/usr/local/lib/python3.6/site-packages/pyharmony/client.py", line 119, in _perform_connect
        await self.retrieve_hub_info()
      File "/usr/local/lib/python3.6/site-packages/pyharmony/client.py", line 99, in retrieve_hub_info
        url, json=json_request, headers=headers) as response:
      File "/usr/local/lib/python3.6/site-packages/aiohttp/client.py", line 855, in __aenter__
        self._resp = await self._coro
      File "/usr/local/lib/python3.6/site-packages/aiohttp/client.py", line 370, in _request
        timeout=timeout
      File "/usr/local/lib/python3.6/site-packages/aiohttp/connector.py", line 445, in connect
        proto = await self._create_connection(req, traces, timeout)
      File "/usr/local/lib/python3.6/site-packages/aiohttp/connector.py", line 757, in _create_connection
        req, traces, timeout)
      File "/usr/local/lib/python3.6/site-packages/aiohttp/connector.py", line 847, in _create_direct_connection
        raise ClientConnectorError(req.connection_key, exc) from exc
    aiohttp.client_exceptions.ClientConnectorError: Cannot connect to host harmonyhub.my.domain.local:8088 ssl:None [Temporary failure in name resolution]

My config yaml:

  - platform: harmony
    name: Zapper
    username: !secret harmony_email
    password: !secret harmony_pass
    host: 'HarmonyHub.my.domain.local'
    port: 8088```

#149

I read that the Harmony hub just lost local control, could it be that?


#150

HI,rsachoc, I don’t think so. It is the latest version which includes the new websocket version of the harmony ext.
And it does appear to be connecting on the correct port for that.


#151

DNS problem

Fix your DNS.


#152

Aaargh, it was the first thing I tested. Checked I could ping from that system. Anywhows reset the DNS server, the hass and switch. All good. Tx for the push.


#153

Has anyone else been getting the below error with harmony? On 84.5.

Update for remote.living_room fails
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity.py”, line 221, in async_update_ha_state
await self.async_device_update()
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity.py”, line 347, in async_device_update
await self.async_update()
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/remote/harmony.py”, line 205, in async_update
activity_id = await self._client.get_current_activity()
File “/srv/homeassistant/lib/python3.6/site-packages/pyharmony/client.py”, line 234, in get_current_activity
‘vnd.logitech.harmony/vnd.logitech.harmony.engine’
File “/srv/homeassistant/lib/python3.6/site-packages/pyharmony/client.py”, line 158, in _send_request
await self._perform_connect()
File “/srv/homeassistant/lib/python3.6/site-packages/pyharmony/client.py”, line 113, in _perform_connect
if not self._websocket.closed:
AttributeError: ‘WebSocketClientProtocol’ object has no attribute ‘closed’


#154

Have you bothered to read any of the posts about Logitech Harmony over the last 2 days? A search regarding Harmony may have done you well prior to this post.


#155

Search harmony or harmony hub. It takes awhile to get to a result from this year much less anything relative to the current issue.


#156

Actually Yes I have searched and I have not found this current issue. I do know that Harmony closed their local API but this is with the web hooks fix that came in with 84.4.


#157

Ok. Upgraded and now get a whole lot of

10:09:49 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.1737303856] Error handling message: {'id': 166, 'type': 'subscribe_events'}
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/websocket_api/connection.py", line 66, in async_handle
    handler(self.hass, self, schema(msg))
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/websocket_api/commands.py", line 102, in handle_subscribe_events
    if not connection.user.is_admin:
AttributeError: 'NoneType' object has no attribute 'is_admin'

#158

Ever since updating to 0.84 my automations don’t get triggered anymore. Example fo the code:

- id: '10'
  alias: Alarmpaneel Algemeen Uit
  trigger:
  - entity_id: binary_sensor.algemeen_uit
    platform: state
    to: 'on'
  action:
  - alias: ''
    service: light.turn_off
    entity_id: 
    - group.beneden_lights
    - group.boven_lights

Anyone have the same problem?

EDIT: Found the solution!

For some reason the default states for automations seem now to be “off” (something to do with the change in state restoration?

Adding the following to my automations solved it:

initial_state: 'on'


#161

Do you use app daemon with an API password? or anything else that does? May have been switched over to use long live tokens. That was my issue.


#162

Yes an app daemon and own tracks as well. Thanks for the tip will dig in this way


#163

The issue here wasn’t that you needed to add that, it was that upon upgrade to 0.84 (where home-assistant switched to a new state engine), the first boot of 0.84 did not have a previous state to resume from, so some automations were turned off.

This was in the release notes, but it didn’t list what some of the effects would be (like random automations not being on), so it’s hard to put that together.

If you go to the developer tools services tab, then select service “automation.turn_on”, then click “Call Service” that will turn on all of your automations and they will stay on through reboots (unless you turn them off).

The line you added will turn them back on even if you wanted them to be off (let’s say you temporarily want to disable one because a guest is staying with your or something)


0.85: ESPHome, Plum Lightpad, OpenSenseMap