2021.9.0: More energy, USB discovery, template ❤️

https://southeastwater.com.au/residential/upgrades-and-projects/projects/digital-water-meters/

My Aqara Opple remotes have stopped sending events (on button press) after upgrading, anyone have any ideas? I have these added via ZHA.

Tasmota themselves now recommend using the HA Tasmota integration. If you’re using HA OS or a supervised install you should use the MQTT Broker provided and configure MQTT via the GUI instead of yaml as well. Tasmota are gradually withdrawing features for MQTT Discovery in HA now as well. So use the MQTT Broker addon, GUI for MQTT and add the tasmota integration as well.

Thanks. I’m in a Yarra Valley Water and it looks like they are only testing in one suburb and not taking volunteers. Hopefully we’ll get this one day. There’s no mention of in-home reading of the meters that I saw.

My energy panel seems to have stopped updating costs after the update.

It has been working great and you can see in the pic it was updating in the morning but after the upgrade it has carried on with energy but the costs haven’t updated and today is 3.77kWh peak but 0p.

I have tried removing and re-adding the sensors and also set them to different prices but doesn’t seem to work.

13.7kWh x 0.055 for offpeak should be 75p ish

I have the same problem and have even tried removing and re-adding energy with no luck.

Not sure if you managed to get an anwser. The long term statistics are allso stored in the HA db if you use the standard config.
You could install SQLite Web add on to explore this data. In statitics_meta you can find the ID for the sensor , then in statistics you could run:
delete
FROM “statistics”
where metadata_id =‘YOUR ID FROM STATISTICS_META’

This will delete ALL data for the ID you select. Offcource you can add additional operators in the where clause to limit the results.

(Allways create a backup before running queries like this. :wink: )

1 Like

Ah yes, reading that thread it looks like that is my problem.

Logger: homeassistant.components.sensor.recorder
Source: components/sensor/recorder.py:353
Integration: Sensor (documentation, issues)
First occurred: 3 September 2021, 23:12:07 (2 occurrences)
Last logged: 3 September 2021, 23:12:07

The unit of sensor.energy_real_sensors_day_kwh_offpeak_cost (GBP) does not match the unit of already compiled statistics (EUR). Generation of long term statistics will be suppressed unless the unit changes back to EUR
The unit of sensor.energy_real_sensors_day_kwh_peak_cost (GBP) does not match the unit of already compiled statistics (EUR). Generation of long term statistics will be suppressed unless the unit changes back to EUR

So I guess it is getting supressed.

Will have to have a look at it later, not sure why the upgrade has caused this though I don’t think I have changed EUR to GBP at anypoint.

Just updated to core-2021.9.2 and looking at my Shelly i3 all entities for the 3 entries are gone. In the device “Shelly i3…” have only 4 entities left and all are marked as “not available”.
Cloud, firmwareupdater, RSSI and uptime.
Shelly Firmware is latest v1.11.3, CoIoT and MQTT are activated as well.

Hi, Just installed 2019.9.3

can anyone help me out where I can find a recap of all issues?
Currently I am looking at:
twitter / facebook / github for some integrations / this thread / this website

but no overview of issues found.

for me energy is not working anymore,

  • Known issue?
  • Do I have to wait a couple of hours after upgrading if so where can I find this in documentation, instead of asking this?

new integration for tractive not working, I am getting error " Config flow could not be loaded"

So not searching enough can cause many new threads/ questions while there is an answer somewhere :innocent:

As explained on FB group, There are no list of per release issues, all issues if they are reported are on github.

The best you can do is search with the string, core-2021.9, this is only applicable if they have added that in their issue
Issues · home-assistant/core (github.com)

maybe a suggestion for future to tag all issues with label of version. So a kind of recap page can be build to show all known/ repported issues
I think it can prevent a lot of double questions.

for me as a relative newbie it is a very big forest right now, and I can not so any trees at all.

I had to find out via twitter the initial release was withdrawn, why it was not reported in this blog?

You can search the issues by version, but that will fall down if the person reporting it fails to add it

just add something like core-2021.9 and it should pickup all those with it in

Just search for the integration name, you’ll see all open issues against that integration. You can add filters to see closed and fixed ones too

Same issue.

I’ve changed back to EUR and waiting to see if costs are calculated again.

Neat trick seeing as .2 seems to be the latest

copy paste error / typo you are right it is .2

I would also like to know how exactly this works.
My recorder runs of site on a PG database server.
Will this long term statistic work with this setup too?
I saw that there is a “statistics” table in the database but it does not have any record.

From what I remember, it independent of the recorder purge settings

Hi.

I really love the Energy additions and get some meaningful graphs. The only downside is the gas. Gas is expressed in m3 however my meter in the UK (glowmqtt from hildebrand) reports in kwh
Any suggestions?

Regards,
M