Aeon Labs Minimote with zwave js?

No I did see someone using Smartthings with the NanoMote Quad having two functions for a single button. Like one press & Double press - or was it long press? cant remember

try listenning it it. press once, and see the log, and then double press and see if the log is diferent

developers tools,
listen to events - zwave_js_event
and click start listening
and try it

looks to be the same:

Event 20 fired 5:19 PM:
    "event_type": "zwave_js_event",
    "data": {
        "type": "value_notification",
        "domain": "zwave_js",
        "node_id": 7,
        "home_id": 3547954940,
        "endpoint": null,
        "device_id": "90d9eb9a18e9bc5277e8ab130b86120d",
        "command_class": 91,
        "command_class_name": "Central Scene",
        "label": "Scene 001",
        "property_name": "scene",
        "property_key_name": "001",
        "value": "KeyPressed"
    "origin": "LOCAL",
    "time_fired": "2021-03-03T16:19:13.107803+00:00",
    "context": {
        "id": "758ea15e7fb47b77ea9cdaf6cbc0f012",
        "parent_id": null,
        "user_id": null

only the last part changes: “id”: “758ea15e7fb47b77ea9cdaf6cbc0f012”,

show me the event of pressed once and long press or whatever method you wish to use. show me both

disclamer: im a total noob!

Same her! (noob) but maybee this would work… will have to experiement

I am using the zwavejs2mqtt addon, I have 22 devices configured and working properly (switches, lights, thermostats, etc.). When I try and listen to events for zwave_js_event I do not see anything. If I listen for * I see other actions happening within HASS, is there something I am missing?

Additionally, I am trying to setup a Hank One Key scene controller button, but I am not making much progress.

Edit, I got it fixed. I had to refresh the device.

can yu show me a picture?
sometimes you misspell, and off course you must press the buttons

I have this remote, I have it paired with ZwaveJS, cant configure it. I am totally lost following this guide. Can someone find some time to talk to me on discord about it? I am Sanity
#5603 on there.

Where the heck do you find this screen? Im using Zwave_JS and I find no way to see buttons for the Minimote.

did you manage? still need help?

With 2021.05 update my minimotes stopped working, I cannot see the event for zwavejs but I can see the button presses in zwavejs2mqtt.
Anyone else facing any issue?

No problems here. Make sure the node Interview status in zwavejs2mqtt is Complete and the device Node Ready status in HA is Yes. If none of those, HA will not see the events.

Thanks. Turns out there was some big driver update for Aeon minimote and I had to reinterview it. But for interview to complete, had to wake up the device atleast 6-7 times.

Perhaps someone can shed some light on this for me.

I’ve got my minimote paired and I assume it’s ok.

Device info
by AEON Labs
Firmware: 1.19
Z-Wave Info
Node ID: 5
Node Status: Asleep
Node Ready: Yes

I had to re-interview it to get it to go “ready”.

If I go to “configure Device” then “logs”, when I press buttons I get log entries :-

Subscribed to Z-Wave JS Log Messages...
2021-10-02T17:36:00.727Z SERIAL « 0x010c00040005042b010100bc0061                                      (14 bytes)
2021-10-02T17:36:00.729Z CNTRLR   [Node 005] [!] [Scene Activation] sceneId: 1                      [Endpoint 0]
2021-10-02T17:36:00.731Z CNTRLR   [Node 005] [~] [Scene Activation] dimmingDuration: {"value":0,"un [Endpoint 0]
                                  it":"seconds"} => {"value":0,"unit":"seconds"}
2021-10-02T17:36:00.733Z SERIAL » [ACK]                                                                   (0x06)
2021-10-02T17:36:00.737Z DRIVER « [Node 005] [REQ] [ApplicationCommand]
                                      scene id:         1
                                      dimming duration: 0s

However, trying to listen for events on zwave_js_event end pressing buttons gives nothing!

Any ideas where I can look now. I’ve tried a couple of restarts just in case.


I believe there’s been a name change. Instead of zwave_js_event, it is now called zwave_js_value_notification. At least, that is what I am now using in my button automation…

I just worked this out this morning. I found a blueprint (ZWave-JS - AEON Labs (Aeotec) Minimote) that worked and when I looked into the code I found the different event name.

Thanks for your comment though - at the very least it reminded me that I should come back here and report!

Thanks for the tricks!

I converted everything over today, a bit grudgingly, after the old solution completely stopped working. It took a while but everything seems to be working except the Minimote I use. I’m currently on 2021.10.7 (though I tried 10.6 as well) but the /developer-tools/event pane still shows nothing when I press the buttons on the MInimote, however I can see the data in the Zwave-JS log and in the HA debug log:


2021-11-01 18:15:40 DEBUG (MainThread) [zwave_js_server] Received message:
WSMessage(type=<WSMsgType.TEXT: 1>, data='{"type":"event","event":{"source":"node","event":"statistics updated","nodeId":17,"statistics":{"commandsTX":0,"commandsRX":158,"commandsDroppedRX":0,"commandsDroppedTX":0,"timeoutResponse":0}}}', extra='')

Z-Wave JS

18:15:54.909 CNTRLR   [Node 017] [!] [Scene Activation] sceneId: 1                      [Endpoint 0]
18:15:54.909 CNTRLR   [Node 017] [~] [Scene Activation] dimmingDuration: {"value":0,"un [Endpoint 0]
                      it":"seconds"} => {"value":0,"unit":"seconds"}
18:15:54.912 SERIAL » [ACK]                                                                   (0x06)
18:15:54.913 DRIVER « [Node 017] [REQ] [ApplicationCommand]
                          scene id:         1
                          dimming duration: 0s

Weirdly, even if I put in * (to listen to all events), while I see lots of events, I don’t see anything from the minimote. I’ve tried doing the “Re-Interview Device” several times, and it looks like that succeeds based on the Zwave-JS log.

It feels like something else is going on if I can’t see the remote when showing all events? Before the old deprecated Z-Wave failed on me, this worked without issue.

Any thoughts?

Did you confirm the node is in the proper state?