Alarm-panel not showing keypad or Accept input

Hey all,

I updated to the latest 0.85.1 version, and after that I no longer see the keypad for the alarm-panel.
When I enter my code, which I positively know works (I’ve tested it trough the Alarm menu where it works as intended), but nothing happens when I hit ‘TILKOBLE UDE’ (ARM AWAY).

If I arm my alarm through the Alarm Menu, the icon on the alarm-panel updates just fine. I just cant arm / disarm through the panel.

I’m not 100% sure, but this “error” seems appear when I hit the key:

Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: “all”

Here is the Card:

  - entity:
    name: Alarm
      - arm_away
    type: alarm-panel
  - entity: alarm_control_panel.xxxxxxx
    name: Arlo
      - arm_away
    type: alarm-panel
type: vertical-stack


Any one have some good suggestions?

try to add show_keypad: true :

  - entity:
    name: Alarm
      - arm_away
    type: alarm-panel
    show_keypad: true

Already tried that, no luck :frowning:

Not sure what else to check, your card looks just like mine.
Have you tried with a single alarm card, just in case?
Also may be a silly question, but I’ll ask it anyway, do you have an alarm code set up?

  - platform: manual
    name: Alarm
    code: !secret alarm_code
    pending_time: 30

I haven’t - but I should have!
I did a restore half an hour ago and now things are back to normal.

I can see that I’m not the only one:

I think our problem is about the way is handling the services. This is a custom component, so I guess no one can help you but the creator himself.

You are probably right.
But how do we get in contact with him or how do we raise the. Problem so he sees it :blush:?

by logging issue on github page for the component. Issues · gazoscalvertos/Hass-Custom-Alarm · GitHub

i am also using the alarm card with this componenet without issue…
type: alarm-panel

What version of HA are you on?
Maybe we can try to compare?

85.1. even tried using the dev build without issue

what is the version of bwalarm are you using


The same as I have used for the past 3 (maybe even way more) months I guess. I didn’t see that it got updated?
I asked earlier to see if we could get it added to the custom_updater so I was sure I was running with the latest version.

EDIT: I opened the alarm.yaml file - is that was you were referring to?

VERSION: 1.0.2

MODIFIED: 18/04/18

Here is where you can download the latest file, but the alarm is the same for the last 2 months.

In my case, I re installed everything 2 days ago. So, I curently have the latest HA and also the custom alarm. I am also on 0.85.1.
The problem is still there. The last time it worked for me without errors was with 0.84.6

if you open with a editor it shows the version in there

my code keypad is also gone, from 84.2 to 85.1 , and i am NOT using the custom project, but original platform

  - platform: mqtt
    name: Risco Alarm
    state_topic: "riscopanel/armstatus"
    command_topic: "riscopanel/armstatus/SET"
    payload_disarm: "disarmed" 
    payload_arm_home: "partially"
    payload_arm_away: "armed"

and in lovelace :

  - type: alarm-panel
    name: Risco Alarm
    entity: alarm_control_panel.risco_alarm    
    show_keypad: true

ok, i added now line below in my configuration, and keypad is back
this was not needed before

code: 1234

Hey Fabio,

Nice! Silly question, but the line added is that the code used for arming / disarming?

You are right. Have you downloaded the latest files?
Also, did you try to add (Alarm-panel not showing keypad or Accept input - #25 by rhodan52)

code: 1234

I’ve not tried anything yet, but it looks like this might be fixed in the next release:

Nice! Fingers crossed. Hopefully it will be available soon.

Seems to be an issue in 0.86.2 again?
Had it running in 0.86.1, but after the update this evening the issue is back.

Anyone else experiencing this?