Aqara M2 gateway support

Quick question - how do I uninstall HomeKit integration as I don’t see any option to do that - ie nowhere on the integration page on that particular integration that you can click delete or remove?

yeah, you can’t, can only ignore / some you can disable , then they will still be found under “integrations” as “ignored/disabled” … thou ii know i had “problems” with Homekit-Integration insisted “popping” up regardless, but as i haven’t had any device added lately , i guess it will popup again eventually :frowning: , so just have to click ignore again
EDIT: i currently have 3 integrations “ignored”, but “Homekit-integrations” is not 1 of them, and i don’t even know what/why these 3 integrations remain in the “Ignore-list” and what to do with them, as it seems if they are “ignored” maybe you have to ADD them again the “ordinary” way “ADD integration”, pretty weird/inconsistent

1 Like
  1. First install the Aqara App and register the M2 Hub and all accessories.
  2. Go to HomeKit and add the M2 there. After that remove the M2 from HomeKit.
  3. Got to HA and install the HomeKit-Controller. It will find the M2 and its accessories.

I dont’t know if all possible Aqara accessories work. My Sensors do.


Thank you!! I have been trying to get this to work for months with no luck. I couldn’t still get this to work with M2 but had bought an E1 as a backup and this method worked perfectly. The E1 blinds now work perfectly and I can set automations to only open them later on non working days and earlier on work days which is brilliant. Thanks so much I am over the moon with finally getting them to work with HA!!!

Once Aqara M2 is added to HA, I have noticed that you lose the ability to control accessories in HA app. This means that if you set up Home mode, Away mode or night mode and selected devices that could trigger alarms in those modes, you lose the ability ot tweak that further.
I had setup the system such that a particular motion sensor does not trigger an alarm in Home mode but only does so in Away mode. Another one triggers and alarm in Night and away only. So on and so forth. Now, if i want to tweak those customizations, I had to remove Aqara M2 from HA, re-pair it in Aqara app, make the changes, and then do a reset again and re-do all the naming work for all sensors and so on in HA.

Is this understanding correct?

I doubt that, sounds pretty weird, thou your “description” is also not much to go on , so if you want more clarity in your thoughts, i think ur better off by presenting your automation’s( in details) as well as your procedure and Errors/“obstructions” you encounter , that lead to your decision to remove the M2, from whatever integration you had it in, would also be in good place to mention where these automation’s were made, in HA / Aqara AP ?, or 1 in each place ? . so you see , your description is not of much help/info for anyone.
But i also noticed that it’s your first post here, and that your read-time is 18 min, so maybe you have had the time to read the first Post in this forum

Feel free to add some more details, after you figured out what you did, how you did it, and why

Hi, I’ve one doubt: I saw that Aqara M2 is going to have an OTA update with Matter support. Once this update arrives, it will work with HA with Matter integration correct?

1 Like

I hope so, I am so confused on how to get my Aqara devices on HA. I am an android user and don’t want to use homekit.

Homekit-Controller( Now Homekit-Device) in HA has nothing to do whether you are android-phone-user, and yes when you have your devices installed in Aqara-App ( on your android ) as i asume you have now, then in HA, install Homekit-Controller( Now Homekit-Device), ( Not Homekit-Integration ) , after you installed Homekit-Controller( Now Homekit-Device), restart HA , pluug-out you M2 from power, then Plug it in again, press the “pair” button for 5-10 second, and Homekit-Device should discover it, and your good to go, if homekit-integration pops up … click IGNORE


You are the MAN!! I got it to work!!! Thank you

1 Like

Did you find any approach to being able to manage the M2 from both their app and from the HomeKit integration in HA? I have this working with some accessories, but if I want to view logs in M2, or add more, I seem to have to do a network reset, add the hub back to the mobile app, lose it from HA and later add it back.

When I add it back to HA it shows up as a new device with all new entities, which is not really usable.

Hi. I’m noob to HA and I’m trying to connect my Aqara devices to HA. I have some sensors connected to Aqara Camera hub G2H Pro. I tried the mentioned method with Homekit Controller but without success.
If I understand correctly by “Install Homekit-Controller” it means in HA Settings → Devices and services → Integrations → Add Integration → Homekit-Controller, it says no unpaired devices find.
After that I restarted HA, unplug power to the camera hub, put the pin in the reset, it says its ready for connect, but doesn’t appear in HA.
Maybe I’m doing something wrong?

I have HA installed in VM in Hyper V in Windows if that is important.

Not even Aqara M2 is mentioned as “Suppoted Device” in Homekit-Controller, so i shouldn’t expect that “Aqara Camera hub G2H Pro” would-

In fact if you search on your device “Aqara Camera hub G2H Pro” in this forum, you would get some hints and suggestions upon another github-reposetory , which ive never seen before, as i have M2 (EU)

PS: above is same url as “ndo” posted above

Below is hints from this forum

Hello, thank you for looking into the topic. I also have the problem of not being able to integrate the M2 into HA. M2 is connected in my Aqara App (Android). Then I want to install Homekit controllers in HA and it shows me that no unpaired devices were found. Thus, Homekit controller is not installed in HA…

What do you actually mean by this ? … do you want to install Homekit Controller ? or did you install homekit-controller, and it says it havent found any unpaired devices … yet ? …

or is …

I was able to solve my issue following @Blackway instruction (THANKS!)
After removing it from HomeKit, I went to HA to add it thru the HomeKit controller.
Funny enough I did not have to re-add it in Homekit, it seemed to have been back there automatically.
but don’t quote me on that one, I feel like I may have gone insane working on that thing for hours.

  • I still have the m2 in the aqara app, I can see logs and most importantly still uses it’s IR blaster through Alexa. I had an intricate IR blaster setup with 4 remotes I spent hours doing, so was pretty pissed to lose this since it requires to be in the aqara app.

  • I have the m2 in homekit so I can see temperature stuff in there and control the aqara alert system.

  • I have it in HA so I do more elaborate stuff with its sensors, my initial reason to migrate to HA.

All set! Thanks Again @Blackway !!

So I need an iOS device in order to connect the camera hub G2H Pro to HA. I’ll find one and update here on the progress.

Right, I want to install Homekit controllers in HA via “add integration”. The Homekit controller then immediately searches for unbound devices. And since it doesn’t find any, Homekit Controller won’t install either.

Got that, so make sure your M2 is “offline/plugged out”, plugg it in again reset it, so i goes into “pair” mode, clcik on “Add- homekit controller”

And, if you for some reason “already” have tried, and “happend” to add the M2 in another Integration, make sure you remove it there first !

Meaing if your M2 is still “pair/bound” to i.e, Homekit, Aqara App, or any other “Controller/App” … Homekit-Controller wont find it

… Or simply “”“press the button”“” on the M2 for about 10 seconds, when you clicked " ADD Homekit-Ctrl " …( PS: it doesn’t mean exact 10 sec., you can let go when HK-C get the message)

I was able to add the Gateway but ii dont get my Cube T1 Pro as new device in HA.
Does someone get the Cube?