Delays and low framerate with Aqara G2H Pro camera

I am trying to integrate the Aqara Camera Hub G2H Pro with Home Assistant. I managed to pair it using using the HomeKit Controller using the following steps:

  • Reset and connect the camera to the Aqara app
  • Connect it with HomeKit
  • Unpair the camera from HomeKit
  • Pair with Home Assistant through HomeKit Controller

A new card appears on the dashboard but the picture doesn’t show up. Upon looking on the console I found that the request for the picture throws the following error without any further context:

(500) internal server error

This request seems to fail randomly, although more often than not, so the picture actually shows sometimes for a few seconds. There isn’t any information in the logs either giving insights about this issue.

Upon clicking, the live stream takes a few seconds to load, and has a few seconds between frames too. You can barely tell what’s going on with that speed and the request also fails sometimes, making it stop and continue after a few seconds more.

When trying to integrate it back with HomeKit using a “HASS Bridge” in accessory mode, the picture shows and is refreshed slowly (probably due to the 500 errors) and the live stream does not work at all. The error shown is:

Camera has no stream source

I tried to pair it directly with HomeKit and the Aqara app to test if it was a device issue, but everything works fine with that set up. I found this topic that describes similar problems when integrating the camera with Home Assistant:

That pointed me to this HACS integration:

It mentions that the G2H Pro is supported, but there is not explicitly explained in their description. I tried to connect to Telnet after finding this issue, but my firmware came above the version 3.3.4 so I can’t exploit that vulnerability to gain access to the camera anymore.

I also saw this topic by @callumw, that makes me think that integrating it should be easy and pretty straightforward, but there aren’t any details beyond saying that it was set up with HomeKit Controller:

So I was wondering, did anyone manage to successfully integrate the Aqara camera and Home Assistant with good results? I feel like I am missing something…

Any help is appreciated!

On my setup all I did was configure it with the (android) Aqara app and then add it to my HA via the HomeKit Controller integration.

Nothing else other than that.
There are no hubs or HomeKit here. Just HA and a dongle :slight_smile:

Thanks for the reply! Those are the steps I followed except that I used an iOS device instead of Android.

And the stream works correctly through the Home Assistant dashboard? I seem to have problems when live streaming, even though the Aqara app works fine.

Seems like this issue is pretty common after all: