Home Assistant Community

Ariela - Home Assistant Android Client

#1232

Switched from WebUI to the native client and so much stuff is working :slight_smile:

Any chance of getting the lovelace history_graph and thermostat component supported?

I also have a camera view that shows up, but only for a split second before it crashes the whole app. It is displaying a looping gif file. The android crash generates this:

time: 1550145882205
msg: java.lang.NullPointerException: Attempt to invoke virtual method 'android.graphics.drawable.Drawable android.graphics.drawable.Drawable$ConstantState.newDrawable()' on a null object reference
stacktrace: java.lang.NullPointerException: Attempt to invoke virtual method 'android.graphics.drawable.Drawable android.graphics.drawable.Drawable$ConstantState.newDrawable()' on a null object reference
	at com.surodev.ariela.view.lovelace.GlanceViewHolder.lambda$null$2(GlanceViewHolder.java:109)
	at com.surodev.ariela.view.lovelace.-$$Lambda$GlanceViewHolder$w-AhbbbhmXa7ebVYm0r8VaTtkDY.run(Unknown Source:4)
	at android.os.Handler.handleCallback(Handler.java:873)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:193)
	at android.app.ActivityThread.main(ActivityThread.java:6739)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:495)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:859)

I’ve emailed over the logs.

0 Likes

#1233

Looks like also in the very latest update, this “show sensor value instead of icon in badges” is applied maybe too broadly.

The motion sensor (binary sensor), now shows on/off vs the solid/empty dot and the weather symbol is now just a number.

0 Likes

#1234

device_tracker is enabled and device tracking is on in Ariela. I’ve added the sensor to my main screen. It show as being away for the last 24 hrs and it’s not showing up on the map. Is there something I’m missing?

0 Likes

#1235

Enable debug mode in Ariela please and send me the logs. I will take a look and let you know what is wrong.
Thank you.

0 Likes

#1236

Just installed the app and I’m liking it so far. I have a few locks setup with Lovelace Entity Cards. In the web UI, they have a proper lock icon, but when using Ariela (referencing the Lovelace UI config) these cards have, what appear to be, some default icon that is a circle with 3 dots inside. Is this expected or should I be seeing the same icons as I do in the web UI?

0 Likes

#1237

Great work @Ionut, just bought Ariela PRO to show some support :wink:

As I already switched to lovelace, I’m having trouble reconstructing my lovelace view to Ariela.
I’m using custom-button card, it isn’t supported by Ariela, but I’m willing to switch to core button card, that is supported (I think).
Now the trouble is that I cannot get the same result as I get with web view.
I use vertical-horizontal stack to define the row for the buttons, but when I was testing the new lovelace layout, web view looked like it suppose to, but in ariela all button cards was arranged one by one.
I treyed with column number, but that didn’t gave great results.

Anyone else using button card, would love some examples that work with Ariela, and still look good in web view?
Here is a sample of my web view (don’t mind custom button card and modder, I can live without that), is something like that possible to achieve in Ariela?
Also is simple-thermostat supported in Ariela?

sample

0 Likes

#1238

Hello,
Button card is supported in Ariela. Regarding the vertical-horizontal stack, because some users didn’t realized they have to swipe left / right to show the cards in horizontal card, i decided to make rendering in Ariela show as vertical cards. In i will see what i can do in the future about this situation.
Also, thank you very much for the support, i really appreciate.

0 Likes

#1239

Swiping left right isn’t realy what I’m after, but simply to order my view like in the image above.
Swiping is in my opinion better to be left for switching tabs, or eaven better - swiping trough some cards like custom-swiper-card.
Also if you use light component with slider, or any slider it’s dificult to be recognized what are you trying to swipe.
A lot of swipes in single post :rofl:

0 Likes

#1240

Are picture-elements going to be supported in the near future?
I have an horizontal stack with 2 picutre-elements, that does not render at all in Ariela

0 Likes

#1241

It’s already added to my TODO list. The plan is to support at least all official lovelace cards.

Too much swipes :stuck_out_tongue: I will see what i can do about this

0 Likes

#1242

One more suggestion…
Why not making a list of lovelace cards that are supported, so we know what to work with atm :wink:

1 Like

#1243

Will do.

Also, version 1.2.8.7 is out.
What’s new:

  • NEW: NFC MQTT reader (read and send NFC tags to Home Assistant)
  • fixed crash when icon / picture / camera images are GIF

Please let me know if you find any issues.

1 Like

#1244

Hello all,

If anyone want to check what lovelace cards are currently supported by Ariela, the list can be found here: http://ariela.surodev.com/2019/02/15/lovelace-cards/

1 Like

#1245

In this latest change, I can no longer open the app when using lovelace (and non-webUI). As soon as I uncheck webui, it crashes and now I can’t open it at all, it just crashes straight away.

Is turning on debug mode, and then switching off webui mode going to capture anything usable? I wont be able to turn on debug to capture a start up crash. To get back into the app I need to wipe its setting and start again.

0 Likes

#1246

Hello,
I found the issue and i fixed it.

Version 1.2.8.8 is out.
What’s new:

  • fixed application crash
0 Likes

#1247

Hello,

The “Ariela” app is really good and works great too. I can start Netflix via HA on my Yoga Tablet. Unfortunately, I can not start “Youtube” via HA, “Youtube” is not listed in the “Sensors” in HA, but “Netflix” is ​​listed here. Is there something blocked by Google?

For answers or tips I would be grateful

0 Likes

#1248

Hey guys, today I got my first wear os smart watch and installed the Ariela app. Unfortunately, when I open the app it says

Failed to connect to URL =

It won’t let me configure the server first

0 Likes

#1249

Same here, I deleted the app so I could reinstall it but now I can’t find it anywhere.

0 Likes

#1250

I also couldn’t find it in the play store. It took a while to appear again as installed on my phone

0 Likes

#1251

What do you mean that it wont let you configure server. Can you post a screenshot or something similar?

0 Likes