Can't install homeassistant:2020.12.0

Tags: #<Tag:0x00007fc418055170> #<Tag:0x00007fc418054cc0>

I just did an OS downgrade and am able to update the supervisor. If you remove the quotes from 5.5 it should work.

I downgraded to 4.2 as that was what I was using before the update and it was the last stable release before 5.8.
ha os upgrade --version 4.20

I have tried a new install with 4.2 and it works ! Thanks @richt
I will try update to 5.9…

I downloaded latest vm and cannot downgrade to 4.2.
supervisor errors as before …
Attempts to down grade or upgrade result in errors as already stated.

I just setup a RPi and same thing. Cannot downgrade …

This morning I tried again, and it worked. I don’t know if it is a random failure and you just need to keep trying multiple times, or if something was changed. At least for me it took multiple tries across 3 days, but now all my installations are updated.

I make a fresh install from 4.2, but when I update to 5.8 by using the UI, my system doesn’t start again…

I just installed build 4.2 on a RPi 4.
It is running …

@bradleyallan have you tried to update your 4.2 to 5.8 ?

No I am afraid too…

I just popped the upgrade from 4.2 to 5.8…
So will see in 40m if I screwed up.
I did spend a few minutes looking at HA. It is interesting …

Upgrade just finished, rebooted and nothing.
No CLI or web UI…

Seems that if I keep rebooting, like 1 out of 5 times I get a login prompt but says CLI not running.

Here is an update …

I can install 4.2 on my RPi and it works but as soon as I attempt to upgrade to any v5.x version I get 500 errors.
Even fresh RPi 4 installs of v5.x fail.

As a side note, I set my router to use Google DNS and set the RPi to be on the DMZ.

I don’t know what to do now…

I’m also getting the same error. Using the brand new image from the instructions on the HA website. I have tried a total of 8 reflash/reload using two different cards and tried both 32 and 64 bit. None are working. I am brand new to HA… and this is my first time trying to install.

Any suggestions? Is this build just broken?

It seems there is a 5.9 version, giving it a try, seeing if it works

I tried it yesterday, same errors… Only 4.2 is success but without possibility to update to 5.X…

Will go for 4.2 then, I just want to create some esphome nodemcu devices…
I wantet to upgrade mi pi3 that is not running hass but custom setup to the pi4 with hass but I will wait a bit longer.

Go to supervisor than System than under Host System next to Ip address click change than expend IPV4 and change IP DHCP to static and under DNS server add google DNS : 8.8.8.8

Reboot HA and than update supervisor.
than update Home Assistant to latest available version.

10 Likes

Thanks for the suggestion, following your update to the System:Host System:DNS fixed the “500 Server Error” when trying to install an Add-On using supervisor.

When I update my “IPv4” Host System to “Static”, and saved it, after restart “DHCP” is always checked… Is this normal?

This worked!

Note to other people having trouble with a fresh install:
1: wait a couple hours. The below steps didn’t work for me after 20 min, but DID work when I woke up the next morning.

2: plug in monitor to the pi

3: enter root: type root as user and hit enter

4: type: os upgrade --version 4.20

5: give it like 20 minutes to complete

6: try going to http://homeassistant:8123/ on a computer or phone. If it doesn’t work, try another device.

7: Once logged into the UI, follow onlinegill’s instruction:
1) Go to supervisor
2) Click System (gear icon)
3) Under Host System, next to IP address click change. Expand IPV4 and change IP DHCP to static and under DNS server add google DNS : 8.8.8.8
4) Click Reboot
5) Go back to Supervisor menu and upgrade supervisor

8: Once supervisor is upgraded to most recent version, HA should show updated to latest as well.

3 Likes