CLI not running. How to get HA running properly?

I downloaded https://github.com/home-assistant/operating-system/releases/download/4.13/hassos_rpi3-64-4.13.img.gz and did put this on a sd-card. Added the network folder and file. After booting I see in the last lines:
docker0: link not ready
hassio: link not ready
after that there is the line
homeassistant login:
When I login with root I get the warning
Home Assistant CLI is not running! Jump into emergency console …

Wireless connection is made according my router.
However homeassistant.local:8123 doesn’t find Home Assistant. Neither wioth the complete ip-address.

What am I doing wrong or forgetting?

Got the same problem man…

OK, so I am not the only one. But we have to wait untill somebody in this forum helps us to get HA running properly.

How long did you wait after you saw the login prompt ? You need to wait at least 20 minutes, HA still needs to be downloaded and installed.

1 Like

3 hours. That should be enough I thought

3 hours should be enough. It might be that your can’t get the correct time. There is a topic about it on the forum.

what has the correct time to do with starting HA? I don’t get HA running…

If your time is not correct, the SSL certificates for downloading HA are considered invalid, and HA does not get downloaded.

This is what I was seeing in logs once enabling debugging mode (see here for details https://developers.home-assistant.io/docs/operating-system/debugging/), you need debug mode in order to be able to SSH to the HA server:

# systemctl status systemd-timesyncd.service
Warning: The unit file, source configuration file or drop-ins of systemd-timesyncd.service changed on disk. Run 'systemctl daemon-reload' to reload units.
● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/systemd-timesyncd.service.d
             └─hassos.conf, ro.conf
     Active: active (running) since Fri 2020-02-07 15:50:57 UTC; 2h 45min ago
       Docs: man:systemd-timesyncd.service(8)
   Main PID: 285 (systemd-timesyn)
     Status: "Idle."
      Tasks: 2 (limit: 4915)
     Memory: 1020.0K
     CGroup: /system.slice/systemd-timesyncd.service
             └─285 /usr/lib/systemd/systemd-timesyncd

Feb 07 16:09:53 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.123:123 (time.cloudflare.com).
Feb 07 16:10:03 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.1:123 (time.cloudflare.com).
Feb 07 16:27:18 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.1:123 (time.cloudflare.com).
Feb 07 16:27:28 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.123:123 (time.cloudflare.com).
Feb 07 17:01:47 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.1:123 (time.cloudflare.com).
Feb 07 17:01:57 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.123:123 (time.cloudflare.com).
Feb 07 17:36:15 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.1:123 (time.cloudflare.com).
Feb 07 17:36:26 homeassistant systemd-timesyncd[285]: Timed out waiting for reply from 162.159.200.123:123 (time.cloudflare.com).
Feb 07 18:06:54 homeassistant systemd-timesyncd[285]: Network configuration changed, trying to establish connection.
Feb 07 18:06:54 homeassistant systemd-timesyncd[285]: Network configuration changed, trying to establish connection.
#

Time sync is not working with time.cloudflare.com hosts.

After debug access is set up you can SSH to the HA server where you will be presented with the hypervisor prompt, type login to get to a shell prompt:

❯ ssh [email protected] -p 22222
Warning: Permanently added '[192.168.10.17]:22222' (ECDSA) to the list of known hosts.
 _    _                                         _     _              _
| |  | |                          /\           (_)   | |            | |
| |__| | ___  _ __ ___   ___     /  \   ___ ___ _ ___| |_ __ _ _ __ | |_
|  __  |/ _ \| '_ ` _ \ / _ \   / /\ \ / __/ __| / __| __/ _` | '_ \| __|
| |  | | (_) | | | | | |  __/  / ____ \\__ \__ \ \__ \ || (_| | | | | |_
|_|  |_|\___/|_| |_| |_|\___| /_/    \_\___/___/_|___/\__\__,_|_| |_|\__|

Welcome on Home Assistant command line.

For more details use 'help' and 'exit' to close.
If you need access to host system use 'login'.

ha > login
#

I modified the NTP server entry: vi /etc/systemd/timesyncd.conf

Reloaded systemd config: systemctl daemon-reload

Restarted timesyncd service: systemctl restart systemd-timesyncd.service

Confirmed time was now syncing: systemctl status systemd-timesyncd.service

systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/systemd-timesyncd.service.d
             └─hassos.conf, ro.conf
     Active: active (running) since Sat 2020-09-19 15:09:05 UTC; 2s ago
       Docs: man:systemd-timesyncd.service(8)
   Main PID: 4587 (systemd-timesyn)
     Status: "Initial synchronization to time server 192.168.10.1:123 (192.168.10.1)."
      Tasks: 2 (limit: 4915)
     Memory: 552.0K
     CGroup: /system.slice/systemd-timesyncd.service
             └─4587 /usr/lib/systemd/systemd-timesyncd

Sep 19 15:09:05 homeassistant systemd[1]: Starting Network Time Synchronization...
Sep 19 15:09:05 homeassistant systemd[1]: Started Network Time Synchronization.
Sep 19 15:09:05 homeassistant systemd-timesyncd[4587]: Initial synchronization to time server 192.168.10.1:123 (192.168.10.1).

Once this was done I restarted the HA supervisor service: systemctl restart hassos-supervisor.service

1 Like

I’m having this issue too. Did anyone manage to fix it using the instructions above?

I have not yet. He doesn’t say how he edited the timesyncs.conf and I don’t know how to use the text editor on the Pi.

Yes I did.

He’s using the text editor ‘vi’ another alternative is ‘nano’ it depends what’s installed on your system.

Linux text editors take a bit of getting used to if you’re coming from Windows but they don’t take too long to get the hang of.

Thanks for replying. From ilium007’s instructions, I couldn’t tell what was changed on the conf file. When I opened mine it was just a single line with some URLs to the time sync service. I didn’t see anything recognizable from the code snippets.

That being said, my actual problem was embarrassingly simple. I either grabbed a bad Ethernet cable or didn’t plug it in all the way, so my Pi wasn’t connected to the Internet when I was trying to install.

So, I’m up and running now. Perhaps others are making a mistake with their WiFi config and not getting connected?