Community Hass.io Add-on: Home Assistant Control Panel

I can’t get this working on any device I have tried it on. At first it says it detects it but it never connects.

It’s worth noting I also can’t connect to http://hassio.local:8123

I have no idea where to start.

When I click “OPEN WEG UI” I got this below:

“Unable to connect to Home Assistant. Please check the Server URL is accessible from this device or change the URL below:”

Does anyone know if you edit the groups on the Control Panel if it modifies your groups in HASS?

@gambit2552. Nope it will not.

1 Like

:tada: Release v1.1.0

This release is exciting, at least, for me it is. I’ve been working on this for months! And for you? Well, almost nothing changed :stuck_out_tongue:

So what did change? I’ve updated the workflows of the Community Hass.io Add-ons project. Things include:

  • Replaced CircleCI and CodeClimate. We are now using GitLab CI, backed by a couple of custom servers building and testing these add-ons.
  • All add-ons are now scanned during built and release by Clair to prevent security issues in our add-ons.
  • All add-ons are constantly scanned and monitored by Anchore.io. We will be notified immediately in case of security issues occur. (Major thanks to Anchore.io for helping us out!)
  • The add-ons repository is now entirely generated and automatically synced with all the add-ons. This ensures repositories are in sync, never forgotten and releases are almost instantly.
  • The base images that these add-ons are built on are entirely revised.
  • All add-ons have been updated to follow the Docker best practices. These are checked on every code change by GitLab CI.
  • All add-ons had maintenance. All software is updated to the latest and greatest and the documentation has been revisited.
  • There are now 2 bots in place on the GitHub project. The Add-ons Assistant is helping us out with the GitHub issues and pull requests and the AddonsBot is fully active taking care of updating code across the different GitHub Repositories.
  • We now have Edge & Beta add-ons repositories available. This allows everybody to test the latest and greatest (in case you don’t care about stability that much, or just wanna help out!)
  • I’ve removed all the PayPal, Bitcoin, … buttons. If you’d like to show your appreciation, then please, just buy me a coffee.

So that’s quite a lot, right? So what changed in this specific add-on?

Full Changelog

Added

  • Adds .yamllint configuration
  • Adds Probot configuration
  • Adds add-on README template
  • Adds Gitlab CI

Fixed

  • Fixes Markdownlint warning in License
  • Fixes hadolint warnings

Changed

  • Replaces Changelog with GitHub releases
  • Updates README
  • Upgrades add-on base image to v1.4.1

Removed

  • Removes CodeClimate
  • Removes CircleCI
2 Likes

I was getting the same cannot login problem like some of you get and I realized that the addon does not pass my api password (bug?)

I wrote http://myserver.com:8123?api_password=password when it asks the address and I managed to login. :slight_smile:

For those of you need also an alarm control panel, please check this post MQTT Alarm Control Panel for Raspberry Pi and Android

You can integrate both panels simply adding the URL of this panel to other MQTT alarm control panel. (In the settings click hass and add the URL) When you slide left, you will find your control panel :slight_smile: It seems they will be a perfect couple.

Thanks

Update: Please bear in my mind that sliding won’t be possible if you integrate both. One page of buttons should be enough for you

Hi. I have been testing and trying to use this on an Android tablet set to be permanently on and no screen shut down. Plugged into power.
Managed to get it connected all good.
However, my slight issue is , after a few hours, the status is not updated.
When my lights are turned on or off (via other means), the background colour of the buttons do not change.
I can still turn on and off the lights , but it just doesn’t update.
Should I be downloading a local file instead ? (The config section has a “download” button on the top left).
Thanks !

I successfully installed the Control Panel addon. I can start it, and no errors show up in the logging. However, when I access hassio.local:7080 I keep getting a popup to enter the correct URL, with this message:

Unable to connect to Home Assistant. Please check the Server URL is accessible from this device or change the URL below:

And below it a text field with the same url pre-filled.

What am I doing wrong? This is my configuration.yaml section:

http:            
  api_password: !secret http_password
  base_url: hassio.local:8123               
  cors_allowed_origins:
    - http://hassio.local:7080

I get the same error.

Using a Ubiquity USG route but don’t think i have blocked any ports.

Did you get yours working?

I had the same error and it took longer than it should have to figure out :joy:. You have to use the actual ip address of the pi. You cant use hassio.local:7080

Look at other post

i still didnt manage to get this working… just stuck on this loading square

When I try to add in the config about the baseURL and CORS the text goes red and I cannot save. I even tried copy pasting exactly from others on this thread and its always red. All I want is baseurl and cors, I dont have a password. Can someone paste an example config?

My setup looks to be identical to yours. Did you have to add the port forwarding to include 7080 in order to make it work?

Yep, port forward and it should work! Good luck.

Hi all

I’ve just installed ed it runs.

Is it possible to customize the views differently than what I get, without modifying groups in HA?

I tried also to Download locally but I don’t get the download and I don’t get any message (error or informational), any suggestions?

Thanks

:tada: Release v1.2.0

Full Changelog

Changed

  • Upgrades base image in GitLab CI to 1.4.2
  • Rewrites GitLab CI
  • Upgrades base image to v1.4.2
  • Moves build-env to latest

Removed

  • Removes old links

Hey Frenck, Will you be updating this add-on with the developers latest improvements? Cheers

Of course!

I’ve already applied the changes on development. Will do a little testing and planning on releasing it today :slight_smile:

1 Like

Is there anyway to store this information on the server side? I plan to dedicate that CP install to a single HA instance, and would prefer not having to replicate the setup on all of my devices.