Custom Component: HACS

The first post tells you how to report bugs (to github)

I haven’t thought of updating HACS before now. I’m on 0.15.2. I have to update to 0.16.3 Which I can’t see on the dropdown, oldest is 0.17.3.

Can I download the zip file and just put everything in the HACS folder?

yes https://github.com/hacs/integration/releases/tag/0.16.3

Can you please expain, how and why is this blacklisted.

Thanks!

It’s blacklisted because it’s depreciated

How: Author wanted it
Why: it has been replaced with Custom Header

Thank you guys for the quick reply. Unfortunately I hadn’t noticed that there is a new thing coming out.

Reinstalled Hassio because I couldn’t update HACS. Followed every step on HACS install, go to add integration and it shows this when I search for it. Pressing it just puts me back to the list.HACS1

Did you restart HA before going to this list ?

Multiple times, both HA and the pi.
Reinstalling again right now, will do HACS first thing.

Try setting your language by clicking your name/icon at the bottom of the HA sidebar.
Then try the integrations again.

I got it working. Used Firefox and deleted all data, took a few minutes but it works now :slight_smile:

I have not found the cause, so most likely something on the GitHub side changed (HACS is using some experimental API’s)

Should be covered in the next HACS release https://github.com/hacs/frontend/blob/5f896df07ce90a2418d3bff2f23bd9a68f8bfe9c/src/markdown/markdown.ts#L34-L55

1 Like

I’m converting all my custom-components to hacs compatible github repos.
I have two questions, how does versioning works, does it scan github tag versions?
I can’t get it to display version, only commit#, is this for hacs default only?

And I’m using below template in my info.md files, in one component/integration this works, but for the others it doesn’t parse them but just display the source, I see no typo’s either.

Running version: 0.18.2

{% if not installed %}

### Installation

* Copy directory  `custom_components/p2000`  to your  `<config dir>/custom_components`  directory.
* Configure with config below.
* Restart Home-Assistant.

{% endif %}

It looks for releases, not tags

Release/version is fixed, nice!
But I still have the issue with some repos displaying raw code from info.md instead of parsing.

This one is working:



Correctly hiding install text block.

This one is not working (displaying {% if not installed %} … {% endif %} instead of hiding block (at bottom of screenshot visible)

When there are templates it can not evaluate it fails, and revert to show the raw file.

on your second repo you have "{{ states.sensor.p2000.state}}" which messes with the template loading.

Hi Per, I have the exact same issue. After following the steps, I cannot find the HACS integration. Of course, as the manual stated, I restarted HA and deleted the cache. Still, I get an empty option just like you. As you did, I also installed Firefox to have a try with another browser (I use Safari), unfortunately with the same result. Do you, or anyone else reading, have an idea on the source of the error?

I can see the plugin loading in the log files, so I am relatively sure the installation part went okay. As a test, I went back to hacs v0.18.2 without any success. I am on the latest HA with docker on Synology.

The source is that you did not copy over the .translations folder.

Dear Ludeeus,
This was indeed the problem. Copying the extracted folder using the Synology web-environment, skips all dot-files. Copying the .zip file and do the extract there solved everything. Seems logical that it would not work with a folder called ‘translations’ missing.

Thanks again!