Fix IP / AutoUpdate for Deconz with Conbee II

Hey Folks,

it unfortunatly already happend a Couple of Times, that after a Reboot i coulnd’t control any Zigbee-Device with HA. The Reason is, that the Gateways IP changes, e.g. before Boot, after Reboot
I have to manually update the Adress in /config/.storage/core.config_entries

Im Running lates HomeassistantOS. How can i assure either the IP never changes, or that it gets automatically updated in HA?

Thank you so much to help save precious Time when rebooting in the Future :slight_smile:

1 Like is the docker address of the machine. You shouldn’t need to use this anywhere. Instead you can use the IP address of the machine that hassos is running on (eg. Under “Configuration > Add-ons, Backup & Supervisor > System” you can give hassos a static IP address under “Host > IP Address”.

Thank you very much! Well,

In Fact, it clearly is used - by the Deconz Gateway. I didnt assign it by myself, it seems its always auto assigned. After update Home Assistant, Error connecting to deCONZ gateway - #18 by EngiBenchi
There are some Users with the same Issue - but i couldn’t find a working-proven Solution

The IP of the HAssOS Machine itself is not a static, but fixed IP adress (DHCP, gets always the same IP assigned).
So im not really sure, if entering the “static” IP under “Configuration > Add-ons, Backup & Supervisor > System” will fix that Problem, or yet make it even worse :crazy_face:

As far as I understand this it should be possible to point to the container_name: and/or service: name
Assuming the container is setup with a docker_compose file and they are all in the same docker network.
The service: name is addressable as a DNS name for inter_container communication.

But I haven’t tested it in hone assistant.
Used it in a reverse proxy setup with containers though

Looking at my /config/.storage/core.config_entries under deconz, I have

"host": "core-deconz"

This is suspiciously close to the container name (addon-core-deconz) and not an IP address as suggested by the link you provided.

I’m running hassos on a VM with the standard deConz integration, and a Conbee stick plugged into the physical machine (and made visible to the VM). When I go to the Phoscon login screen, it identifies the Phoscon-GW and shows (IP of the VM), and when I log in at the top right it shows (no idea if this has ever changed as I’ve not had this issue). What is your setup?


2/3 Settings are comparable :smiley:


“host”: “”,
“port”: 40850

The Funny part is, that when i have the Problem with Zigbee not beeing reachable, i look up the IP in the Phoscon-GW (which by the way always works fine), update it in the core-config, reboot, and then its done.
Looks to me, beeing absolutely no Pro, that your host-setting “core-deconz” (aka almost container-name) resolves to the Internal IP. Probably with the advantage that it (might be) dynamic.
Im just really curious why our core config differs.

I feel i should just try out to change it to “host”: “core-deconz”. Worstcase Zigbee won’t work and i have to set it back?

I just tried it and it works for now. I did a host reboot and my zigbee devices are still working in HA.

1 Like

Awesome, Thanks for trying it as well! Can confirm, works for me too.
Fingers crossed no longterm Problems occuring :wink:
But at least feels like a lasting solution :relaxed:

My setup is with a VM as well. Used the llinux Kvm version. From… I think two years back.
It has in that same spot an IP address. It is most likely placed there by the deconz addon installation script andthat must has evolved over time.

I just recently started with Homeassistant, my Installation with IP set is max 3 Month old :stuck_out_tongue_winking_eye:

Awesome! Changed the IP to *core-deconz and it worked like a charm for me as well.
This fix should def be in the add-on documentation!

Hi there!

Please i want to change the config also like : “host”: “core-deconz” but i dont know how and where.
Please can somebody help me to ?


Please how did you do that and where? Tried in core studio but I can’t find /config/.storage/

I were in the same situation, and it took me forever to figure out where to change the ip.
Hope you figured it out. If not, and to hopefully help others:

Install Studio Code Server
In Studio press the three lines in the top left corner (It took me HOURS to figure out :smiley: )
File → Open folder → config → .storage → ok
Then locate “core.config_entries” and locate “domain”: “deconz”
Change the “host” “ip” or change it to “core-deconz”
Reboot Home Assistant

Hope it helps someone.