HASSIO installation problem

I tried cleaning out all port forwarding entries from my router and tried both options of Wifi and Ethernet by placing network config files in system-connection folder. I can see my PI3 connected to router by static IP by all attempt to connect failed and http://ipaddress:8123 is returning ERR_CONNECTION_REFUSED. http://hasshio.local:8123 is returning ERR_NAME_NOT_RESOLVED.

I also tried with PI0 image on PI3 as both images are of exactly same size but after placing SD card it did not boot/ no sign of being active/ no green light on board.

Any help appreciated.

Which ports?

Can take a LONG time for initial install, over an hour in my experience

Those are all my redirected ports

Service Port Internal
80 80
443 8123
1883 1883
9999 22
3000 3000

Can you let me know what you needed to name the file? I was using resin-wifi before, but I am assuming that isn’t what you’d need for an ethernet connection… I’ll try resin-ethernet for now since I can’t find any info on that.

EDIT: i ended up duplicating the file so I ended up with one called resin-ethernet and one called resin-sample. It worked on the first try!

i used the same sample file name. All i did is change those parameters to match my network and saved with the same name. But I did edit that file with notepad++

Chariyski, I have a similar router to you the TP-link WR1043ND. and im having the exact same problems. How did you fix the issue?

I never forwarded any ports on my router either. Maybe i should have?

i can see the hassio in the DHCP client list ( but cannot connect with http://hassio.local:8123 and also cannot connect with pi_ip/8123 either. no idea what the problem could be.

I hope you did pi_ip:8123 in stead of /

I stopped all port redirects and I added
for the SSID - check HASSIO installation problem

So, I’ve tried everything here and I still can’t get Hassio working. From watching my router, it looks like my Raspberry Pi 3 will only periodically connect to the network for a couple of seconds. I’ve tried both wifi and ethernet. I’d really like to get this working; this is my first foray into Home Assistant.

Does anyone have any ideas?

Well, this is embarrassing. After hours of research and trying different things, it came down to a faulty power supply…


Hi all, I had the same issue when setting up but managed to solve it by finding the Hassio local ip address (e.g from my router and using that instead of the http://hassio.local:8123 address.

So now going to takes me to my Hassio web interface.

Hope this helps anyone in a similar situation.

One other thing that might work, is drop the “.local”. On my network, I just type “hassio:8123” and it takes me to my web interface.

I had same issue, turned out my SD card was too small (2gb) so the download kept failing.

I discovered it by enabling ssh debugging https://home-assistant.io/developers/hassio/debugging/ and checking logs.

Anyone know how big a memory card HASSIO needs?

I was having the same issues described here. My power supply was not adequate. I was just using an old phone charger. The Rpi 3 requires a minimum 2Amp power source. I learned something new about electricity today!


same problem here , after installing on new SD , rasp3 is unresponsive , the web interface do not responds to any call , just a blank screen , not even an error message ,
i have the R3 wired to LAN, so have not changed the defaul config file yet .
any ideas ?


1 Like

still not working , tryed with Eth, wifi, fixed ip, auto , and is not working .
i suspect is not even reading the file , as when testing with fixed ip address , the ip address assigined was by the LAN DHCP , and not the one on the file ,
could it be that the image file on the web is damaged?

It’s working for me. I had the problem that I could see the hassio client in the DHCP settings of my host but wasn’t able to connect to the box using any combination of IP address:port. I thought that the web frontend would be accessible instantly after the installation but now I know that you have to wait for the downloads to finish. I gave it about an hour and finally I was able to open the web frontend (btw. I have 100Mb/s download speed and therefore wondering why it took so long).

I’m having issues editing the resin-sample file. Can’t seem to mount the boot image with write permissions on Windows or Mac.