HASSIO installation problem

After using AIO a long time I wanted to install the IO version, just to see, and what’s best it only takes 20 minutes to install.
Formatted my SD card, installed the image, started the pi and there it was a nice have a 20 minutes patience screen, and it started and it ran and it ran and never came back, so after more then an hour I had to pull the plug and corupted my fine SD card.
Why not make SSH possible upfront like in raspi-config? Now there is no way of knowing what it does or where it is stuck, mine had a ip address but that was it, had I SSH I could have rebooted it or check the running processes.

Must say first impression on the IO thing not so good!

1 Like

Hi tried your method I am using a raspberry pi + , I am still stuck at the preparing Hass.io page when it refreshes it goes to can’t find server, then I hit the refresh and it goes back to preparing ! don’t kn ow what I am doing wrong , the only thing I can think of is the gateway address yours has well as my router is but that too does not seem to help when I change it!

Yes mine is because my network is so you’ll only need to change your to:








dns= or


where 192.168.0.x will be the IP address of your RPi(HASSIO)

tried all solution in this page, finally found my issue is relate to power less than 2.5A and so Raspberry Pi 3 keep restarting …

thanks for the hints

My install is doing the very same thing…20 minute screen never goes away…I have given up on this now…can only assume the server the pi 3 is getting its data from is down or the code is pointing in the wrong direction…I will await the next version of hass:io before I throw the towel in !!

This is strange.

I etched the latest image to the MicroSD card, put it in the Pi3, connected keyboard and mouse (I’m no genius) and HDMI. Seconds later I see the Home Assistant logo come up and that’s it. Nothing else. No 20 minute loading screen, no nothin…

So, I scanned the network. There it is… and it loaded the HA dashboard right off the bat.

Is the most recent image just plug and go without anything else needed?

Not sure if i am having a different or the same issue to others. When i power up my Pi3 with the flashed image, it connects to my wifi & ethernet (on DHCP list on my router), i can connect to the Pi3 on ip:8123 and get the “preparing Hassio” screen. Also, i can ssh on to Pi3 to look at log. It then gets stuck in this loop:

Oct 22 08:55:22 hassio start-resin-supervisor[999]: 17-10-22 08:55:22 ERROR (MainThread) [hassio.tasks] Watchdog found a problem with Home-Assistant docker!
Oct 22 08:55:22 hassio start-resin-supervisor[999]: 17-10-22 08:55:22 INFO (SyncWorker_4) [hassio.dock.interface] Clean homeassistant/raspberrypi3-homeassistant docker application
Oct 22 08:55:26 hassio start-resin-supervisor[999]: 17-10-22 08:55:26 INFO (SyncWorker_4) [hassio.dock.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.55.2

Using 16gb SD card and Raspberry power plug/cable. Hassbian has worked fine on it the past.

Found the solution (should have used google more before posting!) - frenck’s post here:

More info on setting up SSH here:

Can then update home assistant within the normal web interface.

I realize this is late but hopefully this can help someone else where the above solutions didn’t work. My problem was simply that my Aeotec Z-Stick needed to be unplugged from the Rpi3 on the initial boot.

Hey Harry, I’m having the same problem, unfortunately. Did you fix this, and if so, what did you do?

I was reading over this because I had issues with the HASSIO install. Weird things like browser timing out or getting stuck at the Preparing screen.

It turned out, in my case, it was nothing to do with HASSIO. It was the Browser (Microsoft Edge) that caused the issue. Clearing the temp files out solved it, but I just use a different browser now as I can not trust Edge at this stage.

I am having the same problem. I am changing from hassbian to hassio. I used etcher to flash the hassio image on my raspi 3 B. Same up that was running hassbian. Nothing. I don’t even get a splash screen with the logo say 20 mins. I have tried reflashing. I have turned off my previous port forwards. The pi registers on the network though seems as though no traffic is passing. It is connected via eth. Any help would be great.

I am about to give up. Hassio will NOT boot. I have left it overnight. I have my raspi 3b plugged directly into my router. I have turned off the static ip reservation and port forwarding. I am not sure what to do I order to get this to work.

OK so after days of trying. Having restarted everything over and over again I came across this thread. Hass is running but no web gui. Which recommended restarting my Asus 68u DD-WRT router and the pi at the same time. Not sure if I did or did not do this in one of my many reboots/flashes but I have the hassio splash screen. Though still no UI

I suggest you install it manually by installing raspbian stretch then run the script. It works for me any error you encounter just run again the script.

Run as root (sudo su):

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install | bash -s


I got it working after several router and pi resets. But next time I will do that for sure.