hassOS 4.8 upgrade breaks my install

Hi All, I hope everybody is healthy and I’m posting in the correct group :slight_smile:

This morning I was looking through my supervisor and saw new updates. So I started updating my addons, HomeAssistant version and when all was still well I started the OS update to 4.8.

After that reboot, my web interface was unavailable. After 10 minutes of nothing, I decided to hard reboot my NUC (running proxmox and only HASS as a VM).

That didn’t work. So I attached a monitor to it and tried some troubleshooting.
All of the dockers seem to be running when I run “docker ps”
And my proxymanager is accessible.
It looks a lot like a firewall is blocking things, when I do a port-scan on the HASSIO IP address I only get 443 (nginx proxy)

Where can I find base OS troubleshooting tips? Since ifconfig isn’t even working on the console when I’m logged on to the base os…
Any tips are very helpfull


Small update:

If i do SU LOG
I see that everything is running. but the supervisor.homeassistant claims it cannot access connection refused

When I manually connect to my docker supervisor with:
docker exec -it hassio_supervisor /bin/bash and do an ifconfig the ip is:

Could this be the culprit?

Same result. Me on an RPI 4.

But after update it doesn’t even seem to boot.


Strange thing… I did the following:

docker stop addon_a0d7b954_nginxproxymanager
docker stop addon_15ef4d2f_esphome
docker stop addon_806b11b5_zigbee2mqttassistant
docker stop addon_7ad98f9c_zigbee2mqtt
docker stop addon_a0d7b954_vscode
docker stop addon_a0d7b954_ssh
docker stop addon_a0d7b954_unifi
docker stop addon_a0d7b954_adguard
docker stop addon_a0d7b954_influxdb

Then I did a docker restart hassio_supervisor
And the interface came back. The IP is still on .2 so that wasn’t the culprit.

I’ve started my addons again and all seems well. Too scared to do a reboot test though…

@Lucio_Tarantino Maybe doing the same will help for you?

@RoRoo Yes and no. I tried to bring the kernel configuration to default (I’m on an RPI4 so I put the original /boot/config.txt back) and I managed to boot but the network was not working. I put my configuration back (I still had the CONFIG usb stick) and everything started again … on the second boot, the first one I had your same error!

It seems that if I enable UART2 it won’t boot. I open an issue on github.

I think I have the same issue, updated to 4.8 on RPI 3 and now I cannot connect anymore. It would be pretty bad if this update brakes everyone’s installation …

I had the same experience.
Running on a Pi 3B+
Have performed many upgrades including this OS upgrade, no issues.
My Pi stops at a login line but when i try the root user is return an error “No such container: hassio_cli”
My other user login refuses the login credentials but these have not changed.


Just did the update, while it was happening I saw you guys had issues which got me a little worried, but it did boot up in the end after 5 mins or so.

No issues on my side!
(RPI 4)

1 Like

Same problem, but since I don’t have a Linux installation I can’t recover my snapshot files from the SD card :frowning: . (HW: Raspberry 2 model B (I know, it’s old, but it was doing his job pretty well)

If you have windows and a card-reader, you can use diskinternals linux reader


thanks, didn’t know about it. But we have a reply from GitHub, even if I don’t understand what he is talking about.

I managed to extract the latest snapshot from the card (it’s from 2 days ago, I should just have to reinstall AdGuard, because it breaks after updating it to 2.4.1), so if I have to make a new installation I will be just fine.

I have the same problem, cannot read my backup because I am on a Mac. Would have been nice if there had been some indication that if you make backups on the SD card, you cannot read them when you really need them. Fortunately I also have my yaml files on github, sans all the passwords …

I just flashed a brand new home assistant, it is booting now (I hope, I have no display attached), the images are also already on 4.8.

I’m sorry for you man, glad the new installation works.

Mac can read ext4 too.

1 Like

Same problem here on an Rpi 2 going from supervisor 3.13 to 4.8 under Hassio. I could ping the IP address, but no interface, SSH access, etc. Putting the SD card in my laptop the backup snapshots and other files are all there. Following my usual advice of leave it alone and think twice, I followed the USB stick method and it rebooted fine reverted back to 3.13 where I will leave it until smarter minds solve the problem or I decide to do a new install. I had not bothered with the USB stick CONFIG before but it is very simple - just use any handy USB stick (it will need to be reformatted/renamed to CONFIG so no other critical data on it) to place a file with the network details on it. From steps 4-6 of the Hassio installation:

  1. Follow this step if you want to configure Wi-Fi or a static IP address (this step requires a USB stick). Otherwise, move to step 5.
  • Format a USB stick to FAT32 with the volume name CONFIG .
  • Create a folder named network in the root of the newly-formatted USB stick.
  • Within that folder, create a file named my-network without a file extension.
  • Copy one of the examples to the my-network file and adjust accordingly.
  • Plug the USB stick into the Raspberry Pi.
  1. Insert the SD card into your Raspberry Pi. If you are going to use an Ethernet cable, connect that too.
  2. Connect your power supply to the Raspberry Pi.

For someone this solution worked (I saw it on GitHub), I’m searching for a USB stick right now.

The brand new image does boot, so at least the installer images might not be affected.

Thanks for the MacOSX link, I will at least try to save my old backups. I am thinking about taking the opportunity to rebuild my HAS version, because I have been updating it for years already.

1 Like

If this happened a few weeks later I would be fine, because I wanted to switch from my Pi 2 to maybe a Pi 3 or 4 (I can’t decide which one to switch to), and if you want to switch hardware you need a new installation.

I am also having this issue. Im running a Asus Tinker Board S though.
I agreed to update 3.13 to 4.8, it didnt come back ever since.